You are not logged in.

#2426 2013-12-13 20:21:05

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

horsemanoffaith wrote:

This isn't specifically a Unity issue, but it happened right after the upgrade to gtk-3.10, and there was discussion of that here, so I figured I can ask... If I need to create a new topic, I'm more than happy to do so. After I did my update with gtk-3.10, evolution has stopped working. Here's the error:

 evolution: symbol lookup error: /usr/lib/libwebkitgtk-3.0.so.0: undefined symbol: gdk_wayland_display_get_type 

Any suggestions? I have searched Google, but there is nothing about evolution and gdk_wayland.

I'm still working on this one. GTK 3.10 doesn't compile against the version of Wayland in the Arch repos right now. I had to disable wayland support for it to compile at all.


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#2427 2013-12-14 03:02:06

horsemanoffaith
Member
Registered: 2013-05-10
Posts: 134

Re: Progress on Unity under Arch Linux!

I'm still working on this one. GTK 3.10 doesn't compile against the version of Wayland in the Arch repos right now. I had to disable wayland support for it to compile at all.

Thanks for your input, Chen!!! I really appreciate you getting back to me on this!

Offline

#2428 2013-12-14 03:24:39

serdotlinecho
Member
Registered: 2013-01-26
Posts: 100

Re: Progress on Unity under Arch Linux!

darkshines wrote:

@dotfiles: Well cloning from git@github.com:freyja-dev/unity-tweak-tool.git and simply running the tweak tool from there works.

@darkshines, thanks for the workaround. But, what is wrong with the unity-tweak-tool PKGBUILD?

Offline

#2429 2013-12-14 06:32:22

serdotlinecho
Member
Registered: 2013-01-26
Posts: 100

Re: Progress on Unity under Arch Linux!

I enabled show emblem on compiz scale plugin. Anyone having similar problem with Firefox emblem?

Screenshot_from_2013_12_14_14_25_05.jpg

Offline

#2430 2013-12-14 12:33:37

gianluca.pettinello
Member
Registered: 2013-04-16
Posts: 56

Re: Progress on Unity under Arch Linux!

In my case everything works except brightnes fn keys. It started with gnome 3.10 but now in gnome they work. But in unity not. I'm pretty sure it is related to the mapping of fn keys. Do you know in which package to dig to find the solution?
Thanks

Offline

#2431 2013-12-14 12:35:20

darkshines
Member
From: Bremen, Germany
Registered: 2012-05-04
Posts: 11

Re: Progress on Unity under Arch Linux!

Has anyone else noticed that some standard indicators are missing, like Dropbox and Transmission?


Unity for Arch! Check it out https://wiki.archlinux.org/index.php/unity

Offline

#2432 2013-12-15 10:24:26

qiuwei
Member
Registered: 2009-12-18
Posts: 245

Re: Progress on Unity under Arch Linux!

darkshines wrote:

Has anyone else noticed that some standard indicators are missing, like Dropbox and Transmission?

At least dropbox works for me.

Offline

#2433 2013-12-15 10:34:29

darkshines
Member
From: Bremen, Germany
Registered: 2012-05-04
Posts: 11

Re: Progress on Unity under Arch Linux!

This is odd. I reinstalled dropbox from AUR and deleted my .dropbox* folders. Still no indicator icon. Or do I need to install something to get it working?


Unity for Arch! Check it out https://wiki.archlinux.org/index.php/unity

Offline

#2434 2013-12-16 02:25:07

agszepp
Member
Registered: 2013-07-29
Posts: 20

Re: Progress on Unity under Arch Linux!

I would like to give Unity another try, but whenever I try installing it, it gives me this error:

error: failed to prepare transaction (could not satisfy dependencies)
:: libdbusmenu-gtk2: requires libdbusmenu-glib=12.10.3daily13.11.25
:: libindicate: requires libdbusmenu

I tried running this to see if it solves the problem, but it didn't.

sudo pacman -S Unity-for-Arch/libdbusmenu-gtk2 Unity-for-Arch/libindicate Unity-for-Arch/libdbusmenu

What should I do?

Offline

#2435 2013-12-16 07:09:34

horsemanoffaith
Member
Registered: 2013-05-10
Posts: 134

Re: Progress on Unity under Arch Linux!

agszepp wrote:

I would like to give Unity another try, but whenever I try installing it, it gives me this error:

error: failed to prepare transaction (could not satisfy dependencies)
:: libdbusmenu-gtk2: requires libdbusmenu-glib=12.10.3daily13.11.25
:: libindicate: requires libdbusmenu

I tried running this to see if it solves the problem, but it didn't.

sudo pacman -S Unity-for-Arch/libdbusmenu-gtk2 Unity-for-Arch/libindicate Unity-for-Arch/libdbusmenu

What should I do?

I had this same problem, and I solved it by commenting out the community repo in /etc/pacman.conf (putting a hash mark (# sign) in front of two lines for the community repo), installing Unity, then removing the hash marks from the community repo. Every time you update it will warn you that libdbusmenu-glib is newer than the community version, but it will not over-write it.

Offline

#2436 2013-12-16 09:18:40

qiuwei
Member
Registered: 2009-12-18
Posts: 245

Re: Progress on Unity under Arch Linux!

agszepp wrote:

What should I do?

try

pacman -S Unity-for-Arch/libdbusmenu-glib Unity-for-Arch/libdbusmenu-gtk2 Unity-for-Arch/libdbusmenu-gtk3

Offline

#2437 2013-12-16 20:44:55

gauravpadia
Member
Registered: 2013-12-16
Posts: 12

Re: Progress on Unity under Arch Linux!

Can anyone help me to get bluetooth icon and install blueman ? Thanks

Offline

#2438 2013-12-17 00:14:19

agszepp
Member
Registered: 2013-07-29
Posts: 20

Re: Progress on Unity under Arch Linux!

horsemanoffaith wrote:

I had this same problem, and I solved it by commenting out the community repo in /etc/pacman.conf (putting a hash mark (# sign) in front of two lines for the community repo), installing Unity, then removing the hash marks from the community repo. Every time you update it will warn you that libdbusmenu-glib is newer than the community version, but it will not over-write it.

I tried this, and now I got this list:

warning: libappindicator-12.10.1daily13.09.20-101 is up to date -- reinstalling
warning: downgrading package libdbusmenu-glib (12.10.3daily13.11.25-100 => 12.10.2-3)
warning: libdbusmenu-gtk2-12.10.3daily13.11.25-100 is up to date -- reinstalling
warning: downgrading package libdbusmenu-gtk3 (12.10.3daily13.11.25-100 => 12.10.2-3)
warning: libindicate-12.10.1-110 is up to date -- reinstalling
warning: libindicate-gtk2-12.10.1-110 is up to date -- reinstalling
warning: libindicate-gtk3-12.10.1-110 is up to date -- reinstalling
warning: libindicate-qt-0.2.5.91.5-106 is up to date -- reinstalling
warning: libindicator-12.10.2daily13.11.25-100 is up to date -- reinstalling
resolving dependencies...
looking for inter-conflicts...
warning: removing 'dee' from target list because it conflicts with 'dee-ubuntu'
:: gtk3-ubuntu and gtk3 are in conflict. Remove gtk3? [y/N] y
:: gsettings-desktop-schemas-ubuntu and gsettings-desktop-schemas are in conflict. Remove gsettings-desktop-schemas? [y/N] y
:: gnome-settings-daemon-ubuntu and gnome-settings-daemon are in conflict. Remove gnome-settings-daemon? [y/N] y
:: network-manager-applet-ubuntu and network-manager-applet are in conflict. Remove network-manager-applet? [y/N] y
:: gtk2-ubuntu and gtk2 are in conflict. Remove gtk2? [y/N] y
:: qt4-ubuntu and qt4 are in conflict. Remove qt4? [y/N] y
:: zeitgeist-ubuntu and zeitgeist are in conflict (zeitgeist-datahub). Remove zeitgeist? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: libdbusmenu-gtk2: requires libdbusmenu-glib=12.10.3daily13.11.25
:: libindicate: requires libdbusmenu
arch-linux% vim /etc/pacman.conf 
arch-linux% sudo vim /etc/pacman.conf
arch-linux% sudo pacman -S $(pacman -Slq Unity-for-Arch)
warning: libappindicator-12.10.1daily13.09.20-101 is up to date -- reinstalling
warning: libdbusmenu-glib-12.10.3daily13.11.25-100 is up to date -- reinstalling
warning: libdbusmenu-gtk2-12.10.3daily13.11.25-100 is up to date -- reinstalling
warning: libdbusmenu-gtk3-12.10.3daily13.11.25-100 is up to date -- reinstalling
warning: libindicate-12.10.1-110 is up to date -- reinstalling
warning: libindicate-gtk2-12.10.1-110 is up to date -- reinstalling
warning: libindicate-gtk3-12.10.1-110 is up to date -- reinstalling
warning: libindicate-qt-0.2.5.91.5-106 is up to date -- reinstalling
warning: libindicator-12.10.2daily13.11.25-100 is up to date -- reinstalling
resolving dependencies...
warning: cannot resolve "packagekit", a dependency of "libunity-webapps"
warning: cannot resolve "libunity-webapps", a dependency of "bamf"
warning: cannot resolve "packagekit", a dependency of "gnome-settings-daemon-ubuntu"
warning: cannot resolve "gnome-settings-daemon-ubuntu", a dependency of "gnome-control-center-ubuntu"
warning: cannot resolve "gnome-control-center", a dependency of "compiz-ubuntu"
warning: cannot resolve "protobuf", a dependency of "compiz-ubuntu"
warning: cannot resolve "packagekit", a dependency of "gnome-settings-daemon-ubuntu"
warning: cannot resolve "gnome-settings-daemon-ubuntu", a dependency of "gnome-control-center-ubuntu"
warning: cannot resolve "packagekit", a dependency of "gnome-settings-daemon-ubuntu"
warning: cannot resolve "packagekit", a dependency of "libunity-webapps"
warning: cannot resolve "libunity-webapps", a dependency of "bamf"
warning: cannot resolve "bamf", a dependency of "hud"
warning: cannot resolve "packagekit", a dependency of "libunity-webapps"
warning: cannot resolve "libunity-webapps", a dependency of "bamf"
warning: cannot resolve "bamf", a dependency of "indicator-appmenu"
warning: cannot resolve "packagekit", a dependency of "gnome-settings-daemon-ubuntu"
warning: cannot resolve "gnome-settings-daemon-ubuntu", a dependency of "gnome-control-center-ubuntu"
warning: cannot resolve "gnome-control-center", a dependency of "indicator-datetime"
warning: cannot resolve "packagekit", a dependency of "libunity-webapps"
warning: cannot resolve "polkit-gnome", a dependency of "network-manager-applet-ubuntu"
warning: cannot resolve "packagekit", a dependency of "libunity-webapps"
warning: cannot resolve "libunity-webapps", a dependency of "bamf"
warning: cannot resolve "bamf", a dependency of "unity"
warning: cannot resolve "packagekit", a dependency of "gnome-settings-daemon-ubuntu"
warning: cannot resolve "gnome-settings-daemon-ubuntu", a dependency of "gnome-control-center-ubuntu"
warning: cannot resolve "gnome-control-center", a dependency of "compiz-ubuntu"
warning: cannot resolve "protobuf", a dependency of "compiz-ubuntu"
warning: cannot resolve "compiz-ubuntu", a dependency of "unity"
warning: cannot resolve "packagekit", a dependency of "libunity-webapps"
warning: cannot resolve "libunity-webapps", a dependency of "bamf"
warning: cannot resolve "bamf", a dependency of "hud"
warning: cannot resolve "hud", a dependency of "unity"
warning: cannot resolve "xapian-core", a dependency of "unity-lens-applications"
warning: cannot resolve "libxdg-basedir", a dependency of "unity-lens-files"
warning: cannot resolve "python-httplib2", a dependency of "unity-lens-photos"
warning: cannot resolve "python-oauthlib", a dependency of "unity-lens-photos"
warning: cannot resolve "lsb-release", a dependency of "unity-scope-home"
warning: cannot resolve "lsb-release", a dependency of "unity-scope-home"
warning: cannot resolve "unity-scope-home", a dependency of "unity-scopes"
:: The following packages cannot be upgraded due to unresolvable dependencies:
      bamf  compiz-ubuntu  gnome-control-center-ubuntu
      gnome-settings-daemon-ubuntu  hud  indicator-appmenu  indicator-datetime
      libunity-webapps  network-manager-applet-ubuntu  unity
      unity-lens-applications  unity-lens-files  unity-lens-photos
      unity-scope-home  unity-scopes

:: Do you want to skip the above packages for this upgrade? [y/N] 
qiuwei wrote:

try

pacman -S Unity-for-Arch/libdbusmenu-glib Unity-for-Arch/libdbusmenu-gtk2 Unity-for-Arch/libdbusmenu-gtk3

I tried this, but I still got the same errors as before.

What should I do?

Last edited by agszepp (2013-12-17 00:14:47)

Offline

#2439 2013-12-17 06:03:25

horsemanoffaith
Member
Registered: 2013-05-10
Posts: 134

Re: Progress on Unity under Arch Linux!

agszepp wrote:
horsemanoffaith wrote:

I had this same problem, and I solved it by commenting out the community repo in /etc/pacman.conf (putting a hash mark (# sign) in front of two lines for the community repo), installing Unity, then removing the hash marks from the community repo. Every time you update it will warn you that libdbusmenu-glib is newer than the community version, but it will not over-write it.

I tried this, and now I got this list:

warning: libappindicator-12.10.1daily13.09.20-101 is up to date -- reinstalling
warning: downgrading package libdbusmenu-glib (12.10.3daily13.11.25-100 => 12.10.2-3)
warning: libdbusmenu-gtk2-12.10.3daily13.11.25-100 is up to date -- reinstalling
warning: downgrading package libdbusmenu-gtk3 (12.10.3daily13.11.25-100 => 12.10.2-3)
warning: libindicate-12.10.1-110 is up to date -- reinstalling
warning: libindicate-gtk2-12.10.1-110 is up to date -- reinstalling
warning: libindicate-gtk3-12.10.1-110 is up to date -- reinstalling
warning: libindicate-qt-0.2.5.91.5-106 is up to date -- reinstalling
warning: libindicator-12.10.2daily13.11.25-100 is up to date -- reinstalling
resolving dependencies...
looking for inter-conflicts...
warning: removing 'dee' from target list because it conflicts with 'dee-ubuntu'
:: gtk3-ubuntu and gtk3 are in conflict. Remove gtk3? [y/N] y
:: gsettings-desktop-schemas-ubuntu and gsettings-desktop-schemas are in conflict. Remove gsettings-desktop-schemas? [y/N] y
:: gnome-settings-daemon-ubuntu and gnome-settings-daemon are in conflict. Remove gnome-settings-daemon? [y/N] y
:: network-manager-applet-ubuntu and network-manager-applet are in conflict. Remove network-manager-applet? [y/N] y
:: gtk2-ubuntu and gtk2 are in conflict. Remove gtk2? [y/N] y
:: qt4-ubuntu and qt4 are in conflict. Remove qt4? [y/N] y
:: zeitgeist-ubuntu and zeitgeist are in conflict (zeitgeist-datahub). Remove zeitgeist? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: libdbusmenu-gtk2: requires libdbusmenu-glib=12.10.3daily13.11.25
:: libindicate: requires libdbusmenu
arch-linux% vim /etc/pacman.conf 
arch-linux% sudo vim /etc/pacman.conf
arch-linux% sudo pacman -S $(pacman -Slq Unity-for-Arch)
warning: libappindicator-12.10.1daily13.09.20-101 is up to date -- reinstalling
warning: libdbusmenu-glib-12.10.3daily13.11.25-100 is up to date -- reinstalling
warning: libdbusmenu-gtk2-12.10.3daily13.11.25-100 is up to date -- reinstalling
warning: libdbusmenu-gtk3-12.10.3daily13.11.25-100 is up to date -- reinstalling
warning: libindicate-12.10.1-110 is up to date -- reinstalling
warning: libindicate-gtk2-12.10.1-110 is up to date -- reinstalling
warning: libindicate-gtk3-12.10.1-110 is up to date -- reinstalling
warning: libindicate-qt-0.2.5.91.5-106 is up to date -- reinstalling
warning: libindicator-12.10.2daily13.11.25-100 is up to date -- reinstalling
resolving dependencies...
warning: cannot resolve "packagekit", a dependency of "libunity-webapps"
warning: cannot resolve "libunity-webapps", a dependency of "bamf"
warning: cannot resolve "packagekit", a dependency of "gnome-settings-daemon-ubuntu"
warning: cannot resolve "gnome-settings-daemon-ubuntu", a dependency of "gnome-control-center-ubuntu"
warning: cannot resolve "gnome-control-center", a dependency of "compiz-ubuntu"
warning: cannot resolve "protobuf", a dependency of "compiz-ubuntu"
warning: cannot resolve "packagekit", a dependency of "gnome-settings-daemon-ubuntu"
warning: cannot resolve "gnome-settings-daemon-ubuntu", a dependency of "gnome-control-center-ubuntu"
warning: cannot resolve "packagekit", a dependency of "gnome-settings-daemon-ubuntu"
warning: cannot resolve "packagekit", a dependency of "libunity-webapps"
warning: cannot resolve "libunity-webapps", a dependency of "bamf"
warning: cannot resolve "bamf", a dependency of "hud"
warning: cannot resolve "packagekit", a dependency of "libunity-webapps"
warning: cannot resolve "libunity-webapps", a dependency of "bamf"
warning: cannot resolve "bamf", a dependency of "indicator-appmenu"
warning: cannot resolve "packagekit", a dependency of "gnome-settings-daemon-ubuntu"
warning: cannot resolve "gnome-settings-daemon-ubuntu", a dependency of "gnome-control-center-ubuntu"
warning: cannot resolve "gnome-control-center", a dependency of "indicator-datetime"
warning: cannot resolve "packagekit", a dependency of "libunity-webapps"
warning: cannot resolve "polkit-gnome", a dependency of "network-manager-applet-ubuntu"
warning: cannot resolve "packagekit", a dependency of "libunity-webapps"
warning: cannot resolve "libunity-webapps", a dependency of "bamf"
warning: cannot resolve "bamf", a dependency of "unity"
warning: cannot resolve "packagekit", a dependency of "gnome-settings-daemon-ubuntu"
warning: cannot resolve "gnome-settings-daemon-ubuntu", a dependency of "gnome-control-center-ubuntu"
warning: cannot resolve "gnome-control-center", a dependency of "compiz-ubuntu"
warning: cannot resolve "protobuf", a dependency of "compiz-ubuntu"
warning: cannot resolve "compiz-ubuntu", a dependency of "unity"
warning: cannot resolve "packagekit", a dependency of "libunity-webapps"
warning: cannot resolve "libunity-webapps", a dependency of "bamf"
warning: cannot resolve "bamf", a dependency of "hud"
warning: cannot resolve "hud", a dependency of "unity"
warning: cannot resolve "xapian-core", a dependency of "unity-lens-applications"
warning: cannot resolve "libxdg-basedir", a dependency of "unity-lens-files"
warning: cannot resolve "python-httplib2", a dependency of "unity-lens-photos"
warning: cannot resolve "python-oauthlib", a dependency of "unity-lens-photos"
warning: cannot resolve "lsb-release", a dependency of "unity-scope-home"
warning: cannot resolve "lsb-release", a dependency of "unity-scope-home"
warning: cannot resolve "unity-scope-home", a dependency of "unity-scopes"
:: The following packages cannot be upgraded due to unresolvable dependencies:
      bamf  compiz-ubuntu  gnome-control-center-ubuntu
      gnome-settings-daemon-ubuntu  hud  indicator-appmenu  indicator-datetime
      libunity-webapps  network-manager-applet-ubuntu  unity
      unity-lens-applications  unity-lens-files  unity-lens-photos
      unity-scope-home  unity-scopes

:: Do you want to skip the above packages for this upgrade? [y/N] 
qiuwei wrote:

try

pacman -S Unity-for-Arch/libdbusmenu-glib Unity-for-Arch/libdbusmenu-gtk2 Unity-for-Arch/libdbusmenu-gtk3

I tried this, but I still got the same errors as before.

What should I do?

See my previous post here: https://bbs.archlinux.org/viewtopic.php … 1#p1346731

I had exactly the same problem and I describe what I did to fix it here. Sorry I didn't link to it before.

Last edited by horsemanoffaith (2013-12-17 06:06:32)

Offline

#2440 2013-12-17 13:29:36

oi_wtf
Member
From: /home/wtf
Registered: 2012-03-11
Posts: 190

Re: Progress on Unity under Arch Linux!

gauravpadia wrote:

Can anyone help me to get bluetooth icon and install blueman ? Thanks

blueman is not compatible with bluez 5.x and bluez4 and blueman were dropped from the repositories,
because it can't be installed in parallel to bluez 5 and blueman development is not very active,
so chances are, it'll never be compatible to bluez 5 or at least it'll take quite a time till it's fixed.
( source: https://mailman.archlinux.org/pipermail … 25621.html )

You should probably look for an alternative.

Last edited by oi_wtf (2013-12-17 13:37:39)


Laptop:   Arch Linux (x86_64) and Win8.1 (x86_64);  Intel Core i7-3630QM @ 2.40GHz, 8 GiB RAM, NViDiA GeForce GT 650M 2 GiB
Desktop: Arch Linux (x86_64) and Win8.1 (x86_64);  Intel Core i7-4771  @ 3.50GHz, 8 GiB RAM, NViDiA GeForce GTX 660 Ti 2GiB

Offline

#2441 2013-12-17 15:13:22

gauravpadia
Member
Registered: 2013-12-16
Posts: 12

Re: Progress on Unity under Arch Linux!

oi_wtf wrote:
gauravpadia wrote:

Can anyone help me to get bluetooth icon and install blueman ? Thanks

blueman is not compatible with bluez 5.x and bluez4 and blueman were dropped from the repositories,
because it can't be installed in parallel to bluez 5 and blueman development is not very active,
so chances are, it'll never be compatible to bluez 5 or at least it'll take quite a time till it's fixed.
( source: https://mailman.archlinux.org/pipermail … 25621.html )

You should probably look for an alternative.

Thanks for your reply. Yes later I came to know it's not compatible with bluez 5.x. Also I found there is gnome-bluetooth installed with unity so I don't need blueman now. So now just have only one issue, I can't see bluetooth icon. Can you please help me to get bluetooth indicator icon on top panel ? I have enabled bluetooth service too but still no icon on top panel.

Also global menu is not working for gtk applications like filezilla but I think Chen is working on it, I hope to have it fixed in next upgrade.

Thanks!!

Last edited by gauravpadia (2013-12-17 20:21:34)

Offline

#2442 2013-12-17 22:08:52

agszepp
Member
Registered: 2013-07-29
Posts: 20

Re: Progress on Unity under Arch Linux!

horsemanoffaith wrote:

See my previous post here: https://bbs.archlinux.org/viewtopic.php … 1#p1346731

I had exactly the same problem and I describe what I did to fix it here. Sorry I didn't link to it before.

Thanks for your help. I installed Unity. Do I have to do this every time I update? Also, for Nautilus and Settings, the window decorations don't seem to be working. It can be seen here: http://agoston.tk/Unity2.png What should I do?

Last edited by agszepp (2013-12-17 22:20:27)

Offline

#2443 2013-12-18 10:15:00

qiuwei
Member
Registered: 2009-12-18
Posts: 245

Re: Progress on Unity under Arch Linux!

agszepp wrote:

Thanks for your help. I installed Unity. Do I have to do this every time I update? Also, for Nautilus and Settings, the window decorations don't seem to be working. It can be seen here: http://agoston.tk/Unity2.png What should I do?

It's a new feature of Gnome 3.10. So currently we can do nothing.

Offline

#2444 2013-12-18 23:38:20

tydell
Member
From: actually: Hannover, DE
Registered: 2009-07-26
Posts: 102
Website

Re: Progress on Unity under Arch Linux!

I know about nautilus and other gnome 3.10 apps decorations, but what to do with "empty" control center ?
It's fresh Arch  install and I installed almost packages from Unity-for-Arch and Unity-for-Arch-Extra repos.
I also installed unity-tweak-tool but it doesn't work so I had to use lxappearance to change gtk theme and icons.

http://i.imgur.com/HlPDekq.png



-- mod edit: read the Forum Etiquette and only post thumbnails http://wiki.archlinux.org/index.php/For … s_and_Code [jwr] --

Offline

#2445 2013-12-20 12:49:35

darkshines
Member
From: Bremen, Germany
Registered: 2012-05-04
Posts: 11

Re: Progress on Unity under Arch Linux!

For those missing the indicator icon for dropbox: I fixed it by install libappindicator1 from AUR. But you have to uninstall libappindicator first, due to file conflicts.

Edit:
And I managed to get the transmission indicator by rebuilding transmission with ABS, so it finds libappindicator while configuring. If you still have no indicator icon at that point, make sure that the option "Show transmission icon in the notification area" under "Desktop" is checked.

Last edited by darkshines (2013-12-20 13:53:43)


Unity for Arch! Check it out https://wiki.archlinux.org/index.php/unity

Offline

#2446 2013-12-24 10:13:21

big_bum
Member
From: Bucharest,Romania,Europe,World
Registered: 2011-08-29
Posts: 47

Re: Progress on Unity under Arch Linux!

The wiki says that we can use a recommended repo and a testing one for Unity, but they both link the same address.
https://wiki.archlinux.org/index.php/un … mmended.29
https://wiki.archlinux.org/index.php/un … repository

Offline

#2447 2013-12-24 17:42:49

gianluca.pettinello
Member
Registered: 2013-04-16
Posts: 56

Re: Progress on Unity under Arch Linux!

gianluca.pettinello wrote:

In my case everything works except brightnes fn keys. It started with gnome 3.10 but now in gnome they work. But in unity not. I'm pretty sure it is related to the mapping of fn keys. Do you know in which package to dig to find the solution?
Thanks

No one able to help me? I'm desperate. At least to know if someone else has the same problem
Merry Xmas

Offline

#2448 2013-12-25 00:31:14

qiuwei
Member
Registered: 2009-12-18
Posts: 245

Re: Progress on Unity under Arch Linux!

gianluca.pettinello wrote:

me? I'm desperate. At least to know if someone else has the same problem
Merry Xmas

Merry Xmas. But I can confirm that I don't have this problem on thinkpad x220.

Offline

#2449 2013-12-27 08:01:58

gianluca.pettinello
Member
Registered: 2013-04-16
Posts: 56

Re: Progress on Unity under Arch Linux!

qiuwei wrote:
gianluca.pettinello wrote:

me? I'm desperate. At least to know if someone else has the same problem
Merry Xmas

Merry Xmas. But I can confirm that I don't have this problem on thinkpad x220.

Thanks qiuwei!
Please could you check this thing for me?
Type keyboard in the dash and open the keyboard settings. Then look for shortcuts yab. Do you find something related to brightness up and down?
Chen,
I tried to run the program dbus-launch --session... Trying to send a signal to increase the brightness: in gnome it works. In Unity it gives timeout after some time. Do you have any idea? Which program shoul I recompile?

Offline

#2450 2014-01-02 22:10:02

midfingr
Member
From: Canada
Registered: 2012-06-27
Posts: 26

Re: Progress on Unity under Arch Linux!

Happy New Year!

I've successfully installed Arch Unity in VirtualBox (Arch Linux host OS). However, launching Firefox crashes the entire environment; i.e. Vbox aborted. I'm not sure what the problem may be, other than being in a virtual machine. Oddly enough, Firefox doesn't always crash the system and seems random.

I used the pacman.conf method of installation w/ a 64-bit architecture - 4GB RAM and 6 cores + video acceleration @ 128MB.

Any thoughts?

UPDATE: When Firefox launches successfully, here is the output when launched from a terminal:

(process:996): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

(firefox:996): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::sm-connect after class was initialised

(firefox:996): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::show-crash-dialog after class was initialised

(firefox:996): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::display after class was initialised

(firefox:996): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::default-icon after class was initialised

Last edited by midfingr (2014-01-02 22:14:54)

Offline

Board footer

Powered by FluxBB