You are not logged in.

#1 2011-09-04 19:04:08

From: Belgium
Registered: 2010-07-07
Posts: 272

[solved] True Combat: CQB no sound (pulseaudio)


I'm trying out True Combat: Close Quarters Battle, everything works fine except for sound.
I get the error:

------- sound initialization -------
/dev/dsp: No such file or directory
Could not open /dev/dsp

I searched around and found that the reason is that enemy territory is already to old and doesn't work with alsa. I also found the patch but I can't get it to work. I tried the one in the AUR and downloaded and extracted one from the source site myself.

I made a launcher for tc:cqb:

export ETSDL_SDL_LIB=""
export SDL_AUDIODRIVER="pulse"
cd "/opt/enemy-territory/"
LD_PRELOAD="${LD_PRELOAD}:/opt/lib32/usr/lib/" exec ./et.x86 +set fs_game cqbtest +set com_soundMegs 64 +set com_hunkMegs 256 +set com_zoneMegs 64 +set s_khz 44 +set r_maxpolyverts 16384 +set r_maxpolys 4096 $*

exit $?

SDL_AUDIODRIVER is normally set to "alsa" but someone on the TE website stated that it works with "pulse" for pulseaudio.
However I keep getting the /dev/dsp error.

I also tried to modprobe snd_mixer_oss and snd_pcm_oss but that didn't help either.


Must have done something wrong, Modprobe snd_pcm_oss fixed the problem together with et-sdl-sound and the custom launcher

Last edited by Varg (2011-09-05 13:11:34)


Board footer

Powered by FluxBB