You are not logged in.

#1 2002-10-19 19:03:55

dunbar
Member
From: Central New Hampshire USA
Registered: 2002-08-14
Posts: 106
Website

/etc/rc.local isn't working as it should

Or some other  odd problem.

Issue: sound works for root, not for user.

in my /etc/rc.local:

modprobe snd-via686.o
chown root.users /dev/sound/*

That is, I think, per what apiero did here. After the edit, I rebooted to be certain I had a true boot situation to work from (I had already made so many cli attempts at modprobing, who knows what was running... reboots fix that).
The problem is an error I get as a user, under X: I open an xterm, and issue

# xmms &

so that I can see the error messages in the xterm.
I hit play, and xmms tells me it can't play (yet xmms is configured to use the same sound server as root used), and in the xterm I get this error:

** WARNING ** : oss_open() failed to open audio device (/dev/dsp): permission denied.

Ok, looks like the chown thing might not be working?

#ls -la /dev/sound
crw-------  1  root  users  14, 4 Dec 31 1969 audio
crw-------  1  root  users  14, 3 Dec 31 1969 dsp
crw-------  1  root  users  14, 0 Dec 31 1969 mixer
#

So, is the chown thing working? I think so, because when I comment out the chown thing in /etc/rc.local (and reboot), I get

crw-------  1  root  root  14, 4 Dec 31 1969 audio
crw-------  1  root  root  14, 3 Dec 31 1969 dsp
crw-------  1  root  root  14, 0 Dec 31 1969 mixer

I think I need to chmod, not chown.... or maybe chgrp?

Might anyone offering a pointer or three?

Offline

#2 2002-10-19 21:16:25

almostlucky
Member
From: California, USA
Registered: 2002-09-30
Posts: 16

Re: /etc/rc.local isn't working as it should

http://hints.linuxfromscratch.org/hints/dsp_devfsd.txt
there is some help right there.

they give you a few options in there.
You can have the devices set with permissions that you specify each startup (mainly what the article focuses on)

You can also have devfs 'remember' its previous settings
edit this section in your /etc/devfsd.conf to look like this:

#
# Uncomment this if you want permissions to be saved and restored
# Do not do this for pseudo-terminal devices
REGISTER        ^pt[sy]         IGNORE
CREATE          ^pt[sy]         IGNORE
CHANGE          ^pt[sy]         IGNORE
DELETE          ^pt[sy]         IGNORE
REGISTER        .*              COPY    /dev-state/$devname $devpath
CREATE          .*              COPY    $devpath /dev-state/$devname
CHANGE          .*              COPY    $devpath /dev-state/$devname
DELETE          .*              CFUNCTION GLOBAL unlink /dev-state/$devname
RESTORE         /dev-state

You should just have to uncomment those lines.

then as root:

# cd /dev

# chown -R root.users sound/

# chmod 774 sound/

# chmod 664 sound/*

I think that should take care of it wink

This assumes you have already probed your modules (or have them compiled into the kernel)

Offline

#3 2002-10-20 00:31:40

dunbar
Member
From: Central New Hampshire USA
Registered: 2002-08-14
Posts: 106
Website

Re: /etc/rc.local isn't working as it should

Thank you, sounds pretty good to me. I'll try it in the next few days but not immediately.

Offline

#4 2002-10-20 01:09:19

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: /etc/rc.local isn't working as it should

your original rc.local entry should work but you just need to add the "-R" to the chown line

and root to what ever you username is

(btw i don't think you need the ".o" in the module line either)


AKA uknowme

I am not your friend

Offline

#5 2002-10-21 09:54:48

dunbar
Member
From: Central New Hampshire USA
Registered: 2002-08-14
Posts: 106
Website

Re: /etc/rc.local isn't working as it should

almostlucky wrote:

I tried the lfs method in that link ('REGISTER sound/.*PERMISSIONSaudio.audio rw-rw----') and all is fine for user. Thank you for the link and for the assistance.

Offline

Board footer

Powered by FluxBB