You are not logged in.

#1 2011-09-30 21:06:19

Registered: 2011-08-03
Posts: 68

[SOLVED] No Sound, ATI R6xx, Netbook

Greetings Arch forum-goers!

I'm without sound on my Acer AO722 netbook, and I need some help. The only speaker working is the system beep "case speaker". On with the details:

$ lspci
00:01.1 Audio device: ATI Technologies Inc Device 1314
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
$ cat /proc/asound/modules
0 snd_hda_intel
1 snd_hda_intel

Installed: alsa-utils alsa-plugins

User is in the group "audio"

I created /etc/modprobe.d/sound.conf with this inside:

options snd-hda-intel model=acer

At one point I had created ~/.asoundrc with various configs that I found on the internet that may seemingly remedy my issue, but none of them did. Unfortunately I did not note which configs I used, sorry. The file is now deleted.

I hear nothing from a sound test, and the terminal output is:

$ speaker-test -c 2


Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
Playback open error: -2,No such file or directory

On youtube (using luakit), after hitting play, my terminal output scrolls same message until I hit pause:

ALSA lib pcm_dmix.c.1018: (snd_pcm_dmix_open) unable to open slave

In AlsaMixer, the default card information is displayed:
Card: HD-Audio Generic
Chip: ATI R6xx HDMI
Item: S/PDIF (unmuted, but levels at "00")

The other card's information is:
Chip: Conexant CX20588
Item: Master (db gain -5), Beep (Muted because it's annoying to hear), Capture (db gain 2)

I ran alsaconf from my terminal and went through the steps, but it didn't seem to help anything.

From what I am able to gather, this netbook's system beep speaker and my front panel speakers are both integrated. It doesn't seem that ALSA is differentiating the two correctly.

Is there any hope, or is this boat sinking down for good? Any help would be greatly appreciated, thanks tongue

Last edited by rogue (2011-10-01 18:22:03)


#2 2011-10-01 17:31:10

Registered: 2011-08-03
Posts: 68

Re: [SOLVED] No Sound, ATI R6xx, Netbook

I tried the fix in this thread: here, posted by cerronej. No luck yet though. Here is some more information:

# lsmod | grep snd
snd_hda_codec_conexant    46356    1
snd_hda_codec_hdmi    22092    1
snd_hda_intel    22122    0
snd_hda_codec    77927    3 snd_hda_codec_conexant,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep    6325    1 snd_hda_codec
snd_pcm    73888   3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda,codec
snd_timer    19416    1 snd_pcm
snd    57818    7 snd_hda_codec_conexant,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
soundcore    6146    1 snd
snd_page_alloc    7121    2 snd_hda_intel, snd_pcm

I seemingly passed right by the solution multiple times while going through the alsa wiki page. Both of my sound cards use the same module as I suspected. To get the front panel speakers working, you must open /usr/share/alsa/alsa.conf, and replace every instance of "card 0" with "card 1". Please note that this is a system-wide change, although, I don't know why you'd want to leave other users without sound too smile

Last edited by rogue (2011-10-01 18:21:37)


Board footer

Powered by FluxBB