You are not logged in.

#1 2011-10-14 04:58:34

DullOnion
Member
Registered: 2011-10-14
Posts: 6

Savestate hotkeys not working in VBA-M

I'm using this AUR package.  Using shift+function keys to save states worked fine up until I did a system update recently. 

[2011-10-11 18:00] upgraded xf86-input-evdev (2.6.0-3 -> 2.6.0-4)
[2011-10-11 18:00] upgraded xf86-input-keyboard (1.6.0-2 -> 1.6.0-3)
[2011-10-11 18:00] upgraded xf86-input-mouse (1.7.1-1 -> 1.7.1-2)
[2011-10-11 18:00] upgraded xf86-input-synaptics (1.4.1-1 -> 1.5.0-1)
[2011-10-11 18:00] upgraded xf86-video-intel (2.15.0-2 -> 2.16.0-1)
[2011-10-11 18:00] upgraded xf86-video-vesa (2.3.0-5 -> 2.3.0-6)
[2011-10-11 18:00] upgraded xkeyboard-config (2.2.1-1 -> 2.4.1-1)
[2011-10-11 18:00] upgraded xorg-server-common (1.10.4-1 -> 1.11.1-2)
[2011-10-11 18:00] upgraded xorg-server (1.10.4-1 -> 1.11.1-2)
[2011-10-11 18:00] upgraded xorg-xinit (1.3.0-3 -> 1.3.1-1)

I tested out the keys on the normal VBA package, but they don't work there either.  Pressing the function keys without shift works to load save states.   Saving states manually from the menu works.  Recompiling VBA-M doesn't solve the issue.  I suspected that the xorg update might have broken something, but the function keys work on every other program.  Anyone else having this problem?

Offline

#2 2011-10-14 08:19:32

bzt
Member
From: Germany
Registered: 2010-04-11
Posts: 38

Re: Savestate hotkeys not working in VBA-M

I have just tried and I have the same problem. How strange...


My Arch Linux related PKGBUILD pastes: http://pastebin.com/u/bzt

Offline

#3 2012-03-18 17:07:02

nghiavd
Member
Registered: 2010-10-02
Posts: 11

Re: Savestate hotkeys not working in VBA-M

I think the problem is that vba-m don't consider shift as a modifier key. When I try to set the pad buttons, it registered Shift_L and Shift_R as acceptable keys.

Offline

Board footer

Powered by FluxBB