You are not logged in.

#1 2011-10-15 07:50:07

rado3105
Member
Registered: 2011-10-09
Posts: 103

package-query: requires pacman<3.6

sudo pacman -Syu
warning: config file /etc/pacman.conf, line 23: directive 'SigLevel' in section 'options' not recognized.
:: Synchronizing package databases...
testing                    27.8K  644.6K/s 00:00:00 [###########################] 100%
core                       60.8K  858.2K/s 00:00:00 [###########################] 100%
extra                     838.8K  872.1K/s 00:00:01 [###########################] 100%
community-testing           1.8K 1625.6K/s 00:00:00 [###########################] 100%
community                 478.8K  810.1K/s 00:00:01 [###########################] 100%
archlinuxfr is up to date
:: The following packages should be upgraded first :
    pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] y

resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: package-query: requires pacman<3.6


Is any way to make an exception, or I have to wait?

Offline

#2 2011-10-15 08:03:27

loafer
Member
From: the pub
Registered: 2009-04-14
Posts: 1,772

Re: package-query: requires pacman<3.6

You can wait for package query to be updated or install package-query-git.  See the comments in the AUR.


All men have stood for freedom...
For freedom is the man that will turn the world upside down.
Gerrard Winstanley.

Offline

#3 2011-10-15 08:03:54

noidea
Member
Registered: 2011-08-12
Posts: 4

Re: package-query: requires pacman<3.6

From my point of view you want to wait another day. I updated just a few minutes ago. It looks like pacman 4.0 looks for a signature of the desired package and if a package (even its own predecessor) has now valid signature it won't install the package. I get this nice output when I want to reinstall yaourt and therefore downgrade pacman:

resolving dependencies...
looking for inter-conflicts...

Targets (3): package-query-0.9-1  pacman-3.5.4-4  yaourt-0.10.2-1

Total Installed Size:   3.19 MiB
Net Upgrade Size:       0.12 MiB

Proceed with installation? [Y/n]
(3/3) checking package integrity                                        [########################################] 100%
error: pacman: key "F99FFE0FEAE999BD" is unknown
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

Any sugestions?

Offline

#4 2011-10-15 08:24:08

rado3105
Member
Registered: 2011-10-09
Posts: 103

Re: package-query: requires pacman<3.6

Offline

#5 2011-10-15 08:34:02

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,941
Website

Re: package-query: requires pacman<3.6

stop installing old yaourt. you need the git version


Give what you have. To someone, it may be better than you dare to think.

Offline

#6 2011-10-15 08:35:47

rado3105
Member
Registered: 2011-10-09
Posts: 103

Re: package-query: requires pacman<3.6

didnt helped:

==> package-query-git conflicts:
- package-query-0.9-1

==> Continue building package-query-git ? [Y/n]
==> -------------------------------------------
==>
==> Building and installing package
==> Install or build missing dependencies for package-query-git:
warning: config file /etc/pacman.conf, line 23: directive 'SigLevel' in section 'options' not recognized.
:: The following packages should be upgraded first :
    pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] n

error: target not found: recognized.
==> Restart building package-query-git ? [y/N]

Offline

#7 2011-10-15 08:37:08

rado3105
Member
Registered: 2011-10-09
Posts: 103

Re: package-query: requires pacman<3.6

[r-c@r-c-laptop ~]$ sudo pacman -R yaourt
Password:
warning: config file /etc/pacman.conf, line 23: directive 'SigLevel' in section 'options' not recognized.
checking dependencies...

Remove (1): yaourt-0.10.2-1

Total Removed Size:   0.22 MB

Do you want to remove these packages? [Y/n] y
(1/1) removing yaourt                                [###########################] 100%
[r-c@r-c-laptop ~]$ sudo pacman -S yaourt-git
warning: config file /etc/pacman.conf, line 23: directive 'SigLevel' in section 'options' not recognized.
:: The following packages should be upgraded first :
    pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] n

error: target not found: yaourt-git

Offline

#8 2011-10-15 08:42:53

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,941
Website

Re: package-query: requires pacman<3.6

you already downgraded pacman to 3.5....


Give what you have. To someone, it may be better than you dare to think.

Offline

#9 2011-10-15 08:56:22

tuxce
Member
Registered: 2008-02-19
Posts: 56
Website

Re: package-query: requires pacman<3.6

rado3105 wrote:

didnt helped:
[...]
error: target not found: recognized.
==> Restart building package-query-git ? [y/N]

You have to remove them, make a normal upgrade, then, install the git version of both package-query and yaourt.

yaourt -G package-query-git yaourt-git
sudo pacman -Rs yaourt package-query
sudo pacman -Syu
cd package-query-git
makepkg -si
cd ../yaourt-git
makepkg -si

Offline

#10 2011-10-15 09:21:29

rado3105
Member
Registered: 2011-10-09
Posts: 103

Re: package-query: requires pacman<3.6

make[1]: Entering directory `/home/r-c/package-query-git/src/package-query-build'
make[2]: Entering directory `/home/r-c/package-query-git/src/package-query-build'
make[2]: Nothing to be done for `install-exec-am'.
make[2]: Nothing to be done for `install-data-am'.
make[2]: Leaving directory `/home/r-c/package-query-git/src/package-query-build'
make[1]: Leaving directory `/home/r-c/package-query-git/src/package-query-build'
==> Tidying install...
  -> Purging unwanted files...
  -> Compressing man and info pages...
  -> Stripping unneeded symbols from binaries and libraries...
==> Creating package...
  -> Generating .PKGINFO file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: package-query-git 20111013-1 (Sat Oct 15 11:18:28 CEST 2011)
==> Installing package package-query-git with pacman -U...
loading packages...
error: '/home/r-c/package-query-git/package-query-git-20111013-1-any.pkg.tar.xz': could not find or read package
==> WARNING: Failed to install built package(s).

Offline

#11 2011-10-15 09:51:18

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: package-query: requires pacman<3.6

rado3105, when pasting code, please use [ code ] tags https://bbs.archlinux.org/help.php#bbcode

like this

Did you try to install the built package by hand?
I had no problems in building and installing package-query-git and yaourt-git.

Offline

#12 2011-10-15 11:01:21

rado3105
Member
Registered: 2011-10-09
Posts: 103

Re: package-query: requires pacman<3.6

[r-c@r-c-laptop package-query-git]$ sudo makepkg -si
==> ERROR: Running makepkg as root is a BAD idea and can cause permanent,
catastrophic damage to your system. If you wish to run as root, please
use the --asroot option.
[r-c@r-c-laptop package-query-git]$ makepg -si
bash: makepg: command not found
[r-c@r-c-laptop package-query-git]$ cd /home/r-c/yaourt-git
[r-c@r-c-laptop yaourt-git]$ makepkg -si
==> Determining latest git revision...
  -> Version found: 20111015
==> Making package: yaourt-git 20111015-1 (Sat Oct 15 12:58:13 CEST 2011)
==> Checking runtime dependencies...
==> Installing missing dependencies...
Password: 
error: target not found: package-query-git
==> ERROR: 'pacman' failed to install missing dependencies.
[r-c@r-c-laptop yaourt-git]$ cd /home/r-c/package-query-git
[r-c@r-c-laptop package-query-git]$ ls
package-query-git-20111015-1-i686.pkg.tar.xz  pkg  PKGBUILD  src
[r-c@r-c-laptop package-query-git]$ makepkg -si

Yes I tryed

Offline

#13 2011-10-15 11:07:15

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: package-query: requires pacman<3.6

rado3105 wrote:
[r-c@r-c-laptop package-query-git]$ sudo makepkg -si
==> ERROR: Running makepkg as root is a BAD idea and can cause permanent,
catastrophic damage to your system. If you wish to run as root, please
use the --asroot option.
[r-c@r-c-laptop package-query-git]$ makepg -si
bash: makepg: command not found
[r-c@r-c-laptop package-query-git]$ cd /home/r-c/yaourt-git
[r-c@r-c-laptop yaourt-git]$ makepkg -si
==> Determining latest git revision...
  -> Version found: 20111015
==> Making package: yaourt-git 20111015-1 (Sat Oct 15 12:58:13 CEST 2011)
==> Checking runtime dependencies...
==> Installing missing dependencies...
Password: 
error: target not found: package-query-git
==> ERROR: 'pacman' failed to install missing dependencies.
[r-c@r-c-laptop yaourt-git]$ cd /home/r-c/package-query-git
[r-c@r-c-laptop package-query-git]$ ls
package-query-git-20111015-1-i686.pkg.tar.xz  pkg  PKGBUILD  src
[r-c@r-c-laptop package-query-git]$ makepkg -si

Yes I tryed

Huh? Where? You have package-query-git-20111015-1-i686.pkg.tar.xz there, so install it. Why did you run 'makepkg -si' again??
Excuse me, but I think you should read the wiki on how to use AUR, makepkg and pacman.

Offline

#14 2011-10-15 11:07:50

loafer
Member
From: the pub
Registered: 2009-04-14
Posts: 1,772

Re: package-query: requires pacman<3.6

It's not obvious from the above where to tried to install the package.

 pacman -U package-query-git-20111015-1-i686.pkg.tar.xz 

Last edited by loafer (2011-10-15 11:08:44)


All men have stood for freedom...
For freedom is the man that will turn the world upside down.
Gerrard Winstanley.

Offline

#15 2011-10-15 11:08:59

byte
Member
From: Düsseldorf (DE)
Registered: 2006-05-01
Posts: 2,046

Re: package-query: requires pacman<3.6

The problem is that makepkg -si simply looks in the repositories for the required package to install. package-query-git isn't in the repositories, you've built it yourself. So install it manually with 'pacman -U /home/r-c/package-query-git/package-query-git-20111015-1-i686.pkg.tar.xz' and then do the same for yaourt-git.


1000

Offline

#16 2011-10-15 12:37:56

_artem_
Member
Registered: 2010-09-17
Posts: 37

Re: package-query: requires pacman<3.6

omg.. what have you done.. now I can't do ANYTHING....

[_artem_@linux-void ~]$ sudo pacman -Syu
:: Synchronizing package databases...
 gnome-unstable is up to date
 testing                                                28.3 KiB   608K/s 00:00 [#############################################] 100%
 core is up to date
 extra                                                 840.6 KiB  1215K/s 00:01 [#############################################] 100%
 community-testing is up to date
 community                                             473.6 KiB  1264K/s 00:00 [#############################################] 100%
 multilib is up to date
 multilib-testing is up to date
 archlinuxfr is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...

Targets (6): gnutls-3.0.4-1  hyphen-2.8.3-1  man-pages-3.35-1  ncmpcpp-0.5.8-1  nettle-2.4-1  telepathy-glib-0.16.0-1

Total Download Size:    6.05 MiB
Total Installed Size:   39.63 MiB
Net Upgrade Size:       0.13 MiB

Proceed with installation? [Y/n] 
:: Retrieving packages from testing...
 man-pages-3.35-1-any                                    4.3 MiB  1343K/s 00:03 [#############################################] 100%
:: Retrieving packages from extra...
 nettle-2.4-1-x86_64                                   164.1 KiB  1437K/s 00:00 [#############################################] 100%
 gnutls-3.0.4-1-x86_64                                1368.9 KiB  1425K/s 00:01 [#############################################] 100%
 hyphen-2.8.3-1-x86_64                                  13.5 KiB  1648K/s 00:00 [#############################################] 100%
:: Retrieving packages from community...
 ncmpcpp-0.5.8-1-x86_64                                192.6 KiB  1432K/s 00:00 [#############################################] 100%
(6/6) checking package integrity                                                [#############################################] 100%
error: nettle: key "94657AB20F2A092B" is unknown
:: Import PGP key 0F2A092B, "Andreas Radke <andyrtr@archlinux.org>", created 2011-05-14? [Y/n] y
error: telepathy-glib: signature from "Ionut Biru <ibiru@archlinux.org>" is unknown trust
(6/6) checking package integrity                                                [#############################################] 100%
error: nettle: signature from "Andreas Radke <andyrtr@archlinux.org>" is unknown trust
error: gnutls: signature from "Andreas Radke <andyrtr@archlinux.org>" is unknown trust
error: hyphen: signature from "Andreas Radke <andyrtr@archlinux.org>" is unknown trust
error: man-pages: signature from "Andreas Radke <andyrtr@archlinux.org>" is unknown trust
error: telepathy-glib: signature from "Ionut Biru <ibiru@archlinux.org>" is unknown trust
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.
[_artem_@linux-void ~]$ 

I even can't downgrade to pacman 3.5.............

[_artem_@linux-void ~]$ sudo pacman -S core/pacman
warning: downgrading package pacman (4.0.0-2 => 3.5.4-4)
resolving dependencies...
looking for inter-conflicts...

Targets (1): pacman-3.5.4-4

Total Installed Size:   2.89 MiB
Net Upgrade Size:       -0.19 MiB

Proceed with installation? [Y/n] 
(1/1) checking package integrity                                                [#############################################] 100%
error: pacman: signature from "Allan McRae <me@allanmcrae.com>" is unknown trust
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.
[_artem_@linux-void ~]$ 

pffffffffffffffffffffffffffffffffff

Offline

#17 2011-10-15 12:45:18

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: package-query: requires pacman<3.6

Folks, I would like to remind you that you should read the ML when using [testing].

_artem_, edit pacman.conf and uncomment SigLevel = Optional TrustAll.

Offline

#18 2011-10-15 12:52:35

_artem_
Member
Registered: 2010-09-17
Posts: 37

Re: package-query: requires pacman<3.6

oh.. it used the old pacman.conf
not the new pacman.conf.pacnew why it hasn't replaced the old one automatically?

Offline

#19 2011-10-15 12:53:38

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: package-query: requires pacman<3.6

_artem_ wrote:

why it hasn't replaced the old one automatically?

Because you would get the default options and loose all you configs.

Offline

#20 2011-10-15 13:25:02

_artem_
Member
Registered: 2010-09-17
Posts: 37

Re: package-query: requires pacman<3.6

it's a closed disk

yaourt-git and package-query-git both require pacman4
they both are in aur so they only can be installed by yaourt
when I install pacman4 I can't use yaourt to install git versions from aur............

Offline

#21 2011-10-15 13:30:07

loafer
Member
From: the pub
Registered: 2009-04-14
Posts: 1,772

Re: package-query: requires pacman<3.6

There is no requirement to use yaourt.  You can use any aur helper or makepkg / pacman.  Please see karol's comments above.  Make yourself familiar by reading the Wiki articles.


All men have stood for freedom...
For freedom is the man that will turn the world upside down.
Gerrard Winstanley.

Offline

#22 2011-10-15 13:43:54

ngoonee
Forum Fellow
From: Between Thailand and Singapore
Registered: 2009-03-17
Posts: 7,322

Re: package-query: requires pacman<3.6

I'd actually suggest that you not use [testing], its assumed that if you use [testing] you know a bit more about how Arch works (and that you're subscribed to [arch-dev-public]).


Allan-Volunteer on the (topic being discussed) mailn lists. You never get the people who matters attention on the forums.
jasonwryan-Installing Arch is a measure of your literacy. Maintaining Arch is a measure of your diligence. Contributing to Arch is a measure of your competence.
Griemak-Bleeding edge, not bleeding flat. Edge denotes falls will occur from time to time. Bring your own parachute.

Offline

#23 2011-10-15 13:44:42

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: package-query: requires pacman<3.6

_artem_ wrote:

it's a closed disk

yaourt-git and package-query-git both require pacman4
they both are in aur so they only can be installed by yaourt
when I install pacman4 I can't use yaourt to install git versions from aur............

This is the reason we suggest doing things by hand first - when your AUR helper breaks in one way or another, you simply use wget to download the tAURball and makepkg to build the package.

Offline

#24 2011-10-15 13:47:07

_artem_
Member
Registered: 2010-09-17
Posts: 37

Re: package-query: requires pacman<3.6

I know how arch works, I know how makepkg -s works, I know what is and how to use abs

p.s. was just a bit confused (I quit smoking 43 hours ago, since that no sigaret)

Offline

#25 2011-11-21 01:15:31

ikey
Member
Registered: 2009-11-04
Posts: 3

Re: package-query: requires pacman<3.6

you enabled the testing.

add # to testing , i resolved my issue by this way.

Offline

Board footer

Powered by FluxBB