You are not logged in.

#1 2011-10-22 10:10:28

C911
Member
Registered: 2010-12-16
Posts: 2

SSHFS - remote host has disconnected [SOLVED]

So, I am trying to mount stuff using sshfs. I followed this guide https://wiki.archlinux.org/index.php/Sshfs, and to my frustration, I keep getting this (with the debug option):

[C911@MightyComputar ~]$ sshfs root@tardis:/ mymountpoint -p 22 -d
FUSE library version: 2.8.5
nullpath_ok: 0
root@tardis's password:
remote host has disconnected

If I try a different port (specifically port 21), it basically just hangs, and the mountpoint folder is gone untill I do a fusermount -u mymountpoint.

Now, I should say that I can run ssh root@tardis, and everything is fine and dandy.

The remote box is a NAS, Synology DS411j, running Linux (wouldn't have it any other way).

I have looked through a bunch of posts and googled for hours trying to find a solution to this, and so far no cigar.
Does anyone here have any idea to what would solve this?

Last edited by C911 (2011-10-27 16:48:01)

Offline

#2 2011-10-23 15:05:11

kotnik
Member
From: France
Registered: 2011-10-19
Posts: 34

Re: SSHFS - remote host has disconnected [SOLVED]

Did you try:

sshfs -o sshfs_debug root@tardis: mymountpoint

Also, is sftp subsystem active on the server?

Last edited by kotnik (2011-10-23 15:05:36)


It's all GNU to me.

Offline

#3 2011-10-23 16:40:30

firecat53
Member
From: Lake Stevens, Wa
Registered: 2007-05-14
Posts: 1,510
Website

Re: SSHFS - remote host has disconnected [SOLVED]

I found the path to the sftp subsystem was incorrect a while ago (probably had changed at some point and I didn't merge in a .pacnew). Check this line in /etc/ssh/sshd_config on the server and make sure the path is correct.

Subsystem       sftp    /usr/lib/ssh/sftp-server

Scott

Offline

#4 2011-10-27 16:47:39

C911
Member
Registered: 2010-12-16
Posts: 2

Re: SSHFS - remote host has disconnected [SOLVED]

Hello again,
I'm sorry for the late response - Something must have gone wrong because I did write back shortly after you replied, but it apparently didn't get posted properly.

Anyways, as I wrote in the now non-existant post;
This was where the problem was at. I ran this command to find the sftp-server location.

find / | grep sftp-server

This found that there was two different locations with sftp-server, and after trying the second one in the list (in my case, if I remember right, /volume1/@optware/sftp-server) it worked beautifully.

Thanks to both of you, you both were right about where the problem was smile

Oh, and sorry again for the late reply.

Marking this as solved!

Last edited by C911 (2011-10-27 16:49:00)

Offline

Board footer

Powered by FluxBB