You are not logged in.

#1 2011-11-02 19:12:06

truebuilder
Member
Registered: 2011-11-02
Posts: 12

[SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

Hello Arch enthusiasts ---

I'm new to Arch Linux, but not to Linux (I've been using the following distros for a decade or so, roughly in this sequence: Slackware, Redhat, SuSE, Debian, *buntu, & just this autumn Gentoo also) or Unix (I've been call-center-style professional support for a major computer vendor for fifteen years), and plan to be "always learning". Lately I've fallen out of love with Canonical, however; want to have more control of the installation, be more involved with the troubleshooting, and stick with distributions that offer two things [1] text-based configuration (no Unity-style "binary blobs", thank you), and [2] rolling upgrades (always blee..., uhhh, cutting-edge smile --- and the reason why Gentoo runs my other web-facing box).

My first Arch install went well, up on CLI in no time (my compliments to those who labor to create such ease, and such directions). However, I'm having X11 problems, as in it-won't-start. I followed various setup directions in several pages below archlinux.org, but the errors I'm getting suggest I'm missing something quite basic, and for life of me.... Google was almost useful, but not quite, thus this query.

As I can't get X running, I have to use a WinXP (the dual-boot portion of same computer) with FAT32 partition for data transfer (& some notepad-to-wordpad ux2dos-style conversions); I don't think that's introduced any artifacts, but can't be sure. And this antique has a Rage XL card (8MB I believe), so I chose the open-source xf86-video-ati driver.

$$$$$  Here are my relevant pacman commands:

   41  pacman -Syy
   42  pacman -Syu
   46  pacman -S sudo
   51  pacman -Syy
   52  pacman -Syu
   55  pacman -S alsa-utils
   56  pacman -S alsa-plugins
   72  pacman -S xorg-server xorg-xinit xorg-utils xorg-server-utils
   73  pacman -S mesa
   74  pacman -S mesa-demos
   75  pacman -S xf86-video-ati
   76  pacman -S xorg-twm xorg-xclock xterm
   80  pacman -S dbus
  126  history | grep pacman > /dos/pacman.txt

$$$$$  Here's the "startx" (no options) error:

This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.

X.Org X Server 1.11.1.902 (1.11.2 RC 2)
Release Date: 2011-10-28
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.1.0-2-ARCH i686
Current Operating System: Linux xw4600 3.0-ARCH #1 SMP PREEMPT Wed Oct 19 12:14:48 UTC 2011 i686
Kernel command line: root=/dev/disk/by-uuid/dc10849c-493b-4176-a9b9-114bdc7d6416 ro
Build Date: 30 October 2011  09:00:20AM

Current version of pixman: 0.22.2
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Nov  2 10:41:37 2011
(==) Using config directory: "/etc/X11/xorg.conf.d"
(EE) Failed to load module "mach64" (module does not exist, 0)
(EE) Failed to load module "vesa" (module does not exist, 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
     at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

$$$$$  I don't have either an ~/.xinitrc (still working as root, will worry about as a user later) or an xorg.conf:

ls: cannot access /root/.xinitrc: No such file or directory
ls: cannot access /etc/X11/xorg.conf: No such file or directory
/var/log/Xorg.0.log
/var/log/Xorg.0.log.old

$$$$$  Here's wgetpaste access for the two logfiles (I don't know how to make these "inline" scrollable windows - if someone might advise then any future posts will have those):

-rw-r--r-- 1 root root 7438 Nov  2 10:41 /var/log/Xorg.0.log ---> (wgetpaste _via_ /dos/ to) http://paste.pocoo.org/show/501834
-rw-r--r-- 1 root root 2525 Nov  2 09:34 /var/log/Xorg.0.log.old ---> (wgetpaste _via_ /dos/ to) http://paste.pocoo.org/show/501833

$$$$$  _After_ I get X running, I'll probably go on for either Gnome or LXDE, satisfy myself all is well, and then wipe & redo from netinstall (if I can do this twice...). But that's a ways down the road. Thanks in advance. smile

$$$$$ Forum Team --- thank you for doing what you do (this place wouldn't work without you); please reclassify this if you feel it would be better posted in "Installation" than "Newbie Corner".

Last edited by truebuilder (2011-11-10 04:12:10)

Offline

#2 2011-11-02 19:21:17

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

Create a user and a light .xinitrc for him with some wm - twm is fine.

(EE) Failed to load module "vesa" (module does not exist, 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)

Those are harmless.

Offline

#3 2011-11-02 20:05:32

truebuilder
Member
Registered: 2011-11-02
Posts: 12

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

karol --- Thank you for the reply. Based upon the Openbox example early on https://wiki.archlinux.org/index.php/Xinitrc I set up the following truly minimalist ~/.xinitrc for my new user:

#!/bin/sh
# ~/.xinitrc
exec twm

$$$$$  I then did a no-options "startx", and the results seem unchanged:

This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.

X.Org X Server 1.11.1.902 (1.11.2 RC 2)
Release Date: 2011-10-28
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.1.0-2-ARCH i686
Current Operating System: Linux xw4600 3.0-ARCH #1 SMP PREEMPT Wed Oct 19 12:14:48 UTC 2011

i686
Kernel command line: root=/dev/disk/by-uuid/dc10849c-493b-4176-a9b9-114bdc7d6416 ro
Build Date: 30 October 2011  09:00:20AM

Current version of pixman: 0.22.2
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Nov  2 12:47:20 2011
(==) Using config directory: "/etc/X11/xorg.conf.d"
(EE) Failed to load module "mach64" (module does not exist, 0)
(EE) Failed to load module "vesa" (module does not exist, 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
     at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

$$$$$  I have a feeling that it's not as simple as running-as-user over running-as-root (probably X as root is a Bad Plan from a security POV, but I haven't gotten far enough for that risk yet). But your subtle reminder that root is a security risk _is_ an excellent point. I'll look forward to future updates (yourself or others) on this developing thread.

Last edited by truebuilder (2011-11-02 20:07:15)

Offline

#4 2011-11-02 20:13:45

truebuilder
Member
Registered: 2011-11-02
Posts: 12

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

Let me be clear; "startx" (root or an unprivileged user) doesn't seem to give me an X graphical session, but instead dumps me back to a shell prompt in a minute or so. I'm never changing virtual consoles (still on initial Alt-F1 console). Perhaps I need to change to another console (Alt-F7 or another) in order to actually see the running X?

Offline

#5 2011-11-02 21:16:21

Gusar
Member
Registered: 2009-08-25
Posts: 3,605

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

xf86-video-ati is too new for that old thing. You need xf86-video-mach64

Offline

#6 2011-11-03 01:41:49

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,339

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

Moderator comment:  Truebuilder:  Could I request that you use BBCode code tags when posting program output or file contents.

it puts the text in a separate box, like this.  It  uses a monospaced font so that columns line up, and it provides scroll bars for long passages.

To see how it is done, you can hit the Quote link on this message and look at the raw text.  No need to actually post the response though (unless you've something you want to convey smile )

Thanks,
ewaller


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#7 2011-11-03 02:25:57

truebuilder
Member
Registered: 2011-11-02
Posts: 12

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

Thank you, Moderator ewaller, I was wondering how some of the formatting was done. I reviewed Forum Etiquette before posting, but it didn't seem to have mention of BBCodes.

And thank you, Gusar. I believe you're onto something. I removed (pacman -R) xf86-video-ati then mesa-demos then mesa, almost, mesa wouldn't remove (nice, this pacman may be the central tool of Arch), finally added xf86-video-mach64. From the ArchWiki entry for Mach64 I gathered that all I had to do was pacman -S xf86-video-mach64, and that's all I did.

That bought me a slightly different output; the only substantive line changed was from

(EE) Failed to load module "mach64" (module does not exist, 0)

to

(EE) Failed to load module "ati" (module does not exist, 0)

So I ran wild, pacman -S xf86-video-ati xf86-video-vesa xf86-video-fbdev (remember that at this point xf64-video-mach64 is still installed), and finally another startx:

This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.

X.Org X Server 1.11.1.902 (1.11.2 RC 2)
Release Date: 2011-10-28
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.1.0-2-ARCH i686 
Current Operating System: Linux xw4600 3.0-ARCH #1 SMP PREEMPT Wed Oct 19 12:14:48 UTC 2011 i686
Kernel command line: root=/dev/disk/by-uuid/dc10849c-493b-4176-a9b9-114bdc7d6416 ro
Build Date: 30 October 2011  09:00:20AM
 
Current version of pixman: 0.22.2
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Nov  2 18:37:13 2011
(==) Using config directory: "/etc/X11/xorg.conf.d"
(EE) open /dev/fb0: No such file or directory
FATAL: Module mach64 not found.
(EE) [drm] drmOpen failed.
(EE) MACH64(0): [dri] DRIScreenInit Failed
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
      after 544 requests (544 known processed) with 0 events remaining.
xinit: connection to X server lost

waiting for X server to shut down Server terminated successfully (0). Closing log file.

I wgetpaste'd the latest /var/log/Xorg.0.log and /var/log/Xorg.0.log.old. And indeed, I don't have a /dev/fb0, Google didn't seem to be enlightening about just rolling-your-own (I don't yet know any of the methods _in Linux_ for creating device files - it's probably not that easy anyway).

I'm going to back off, and think about this; I want to be asking good questions, and not ones I can deduce myself. And I'm about out of "weekend" anyway, on shift tomorrow through Sunday late, I'll be unable to do much experimentation. Perhaps I'll get time to just roll another netinstall (10_GB disk, I don't need a /home anyway...), and start fresh next Monday. Thanks all for reading. cool

Offline

#8 2011-11-03 17:36:07

perbh
Member
From: Republic of Texas
Registered: 2005-03-04
Posts: 765

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

try

lspci -k

and give us the output

Offline

#9 2011-11-05 16:21:54

truebuilder
Member
Registered: 2011-11-02
Posts: 12

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

perbh ---

Work is light so far, so I've run the lspci -k as you requested (thank you for the participation), and thrown in a dmesg for good measure:

(Arch) dmesg
(Arch) lspci -k

However, thinking away from the screen let me realize that I was overlooking a valuable tool. I don't seem to have problems with any of the *buntu LiveCDs. So here are the same plus Xorg.0.log for a successful boot with Lubuntu Desktop 11.10 Oneiric Ocelot:

(Lubuntu) dmesg
(Lubuntu) lspci -k
(Lubuntu) Xorg.0.log

When I compare the (previously posted, fails) (Arch) Xorg.0.log to the (successful) (Lubuntu) Xorg.0.log, I see that they diverge when the latter fails to LoadModule on "fglrx" but then goes on to load "ati" then "mach64" then "vesa" then "fbdev". By contrast, the former seems to know enough to not attempt to load "fglrx", but fails on "ati" (module does not exist, 0) then all the rest.

The Lubuntu logfile has this to say about "ati" & "mach64":

[    81.521] (II) LoadModule: "ati"
[    81.521] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
[    81.553] (II) Module ati: vendor="X.Org Foundation"
[    81.553] 	compiled for 1.10.2.902, module version = 6.14.99
[    81.553] 	Module class: X.Org Video Driver
[    81.553] 	ABI class: X.Org Video Driver, version 10.0
[    81.553] (II) LoadModule: "mach64"
[    81.554] (II) Loading /usr/lib/xorg/modules/drivers/mach64_drv.so
[    81.683] (II) Module mach64: vendor="X.Org Foundation"
[    81.683] 	compiled for 1.10.1, module version = 6.9.0
[    81.683] 	Module class: X.Org Video Driver
[    81.683] 	ABI class: X.Org Video Driver, version 10.0

Here's the Lubuntu LiveCD reading on that directory:

drwxr-xr-x 1 root root     220 2011-11-05 08:54 /
drwxr-xr-x 1 root root     100 2011-10-12 16:06 /usr
drwxr-xr-x 1 root root     120 2011-10-12 16:11 /usr/lib
drwxr-xr-x 3 root root      50 2011-10-12 16:09 /usr/lib/xorg
drwxr-xr-x 6 root root     264 2011-10-12 16:09 /usr/lib/xorg/modules
drwxr-xr-x 2 root root     557 2011-10-12 16:09 /usr/lib/xorg/modules/drivers
-rw-r--r-- 1 root root    5552 2011-08-11 19:47 /usr/lib/xorg/modules/drivers/ati_drv.so
-rw-r--r-- 1 root root   34584 2011-03-18 10:44 /usr/lib/xorg/modules/drivers/cirrus_alpine.so
-rw-r--r-- 1 root root   14112 2011-03-18 10:44 /usr/lib/xorg/modules/drivers/cirrus_drv.so
-rw-r--r-- 1 root root   26744 2011-03-18 10:44 /usr/lib/xorg/modules/drivers/cirrus_laguna.so
-rw-r--r-- 1 root root   18240 2011-03-18 10:47 /usr/lib/xorg/modules/drivers/fbdev_drv.so
-rw-r--r-- 1 root root  255484 2011-09-01 15:41 /usr/lib/xorg/modules/drivers/geode_drv.so
-rw-r--r-- 1 root root  327752 2011-08-09 12:25 /usr/lib/xorg/modules/drivers/intel_drv.so
-rw-r--r-- 1 root root  193016 2011-05-25 09:37 /usr/lib/xorg/modules/drivers/mach64_drv.so
-rw-r--r-- 1 root root  163548 2011-03-18 10:56 /usr/lib/xorg/modules/drivers/mga_drv.so
-rw-r--r-- 1 root root   73312 2011-08-11 14:01 /usr/lib/xorg/modules/drivers/neomagic_drv.so
-rw-r--r-- 1 root root  242560 2011-05-26 01:41 /usr/lib/xorg/modules/drivers/nouveau_drv.so
-rw-r--r-- 1 root root  354916 2011-05-05 12:46 /usr/lib/xorg/modules/drivers/openchrome_drv.so
-rw-r--r-- 1 root root  129068 2011-08-11 19:41 /usr/lib/xorg/modules/drivers/qxl_drv.so
-rw-r--r-- 1 root root  106484 2011-05-25 09:25 /usr/lib/xorg/modules/drivers/r128_drv.so
-rw-r--r-- 1 root root 1079508 2011-08-11 19:47 /usr/lib/xorg/modules/drivers/radeon_drv.so
-rw-r--r-- 1 root root   64356 2011-05-24 16:30 /usr/lib/xorg/modules/drivers/s3_drv.so
-rw-r--r-- 1 root root  134844 2011-03-18 11:05 /usr/lib/xorg/modules/drivers/savage_drv.so
-rw-r--r-- 1 root root  118916 2011-08-11 12:22 /usr/lib/xorg/modules/drivers/siliconmotion_drv.so
-rw-r--r-- 1 root root  589436 2011-05-24 16:31 /usr/lib/xorg/modules/drivers/sis_drv.so
-rw-r--r-- 1 root root   76032 2011-05-24 16:32 /usr/lib/xorg/modules/drivers/sisusb_drv.so
-rw-r--r-- 1 root root   68640 2011-05-24 16:32 /usr/lib/xorg/modules/drivers/tdfx_drv.so
-rw-r--r-- 1 root root  156860 2011-05-24 16:32 /usr/lib/xorg/modules/drivers/trident_drv.so
-rw-r--r-- 1 root root   26504 2011-06-16 11:33 /usr/lib/xorg/modules/drivers/vesa_drv.so
-rw-r--r-- 1 root root    5608 2011-05-24 16:34 /usr/lib/xorg/modules/drivers/vmware_drv.so
-rw-r--r-- 1 root root   51628 2011-05-24 16:34 /usr/lib/xorg/modules/drivers/vmwlegacy_drv.so
-rw-r--r-- 1 root root   26832 2011-09-01 15:41 /usr/lib/xorg/modules/drivers/ztv_drv.so

And here's a reality check on the startx-fails Arch:

drwxr-xr-x 22 root root    4096 Nov  1 12:41 /
drwxr-xr-x  9 root root    4096 Nov  1 11:49 /usr
drwxr-xr-x 39 root root   24576 Nov  2 09:03 /usr/lib
drwxr-xr-x  3 root root    4096 Nov  2 08:59 /usr/lib/xorg
drwxr-xr-x  7 root root    4096 Nov  2 17:50 /usr/lib/xorg/modules
drwxr-xr-x  2 root root    4096 Nov  2 18:41 /usr/lib/xorg/modules/drivers
-rwxr-xr-x  1 root root    5588 Aug 29 01:01 /usr/lib/xorg/modules/drivers/ati_drv.so
-rwxr-xr-x  1 root root   18312 Aug 25 01:28 /usr/lib/xorg/modules/drivers/fbdev_drv.so
-rwxr-xr-x  1 root root  193044 Aug 25 02:44 /usr/lib/xorg/modules/drivers/mach64_drv.so
-rwxr-xr-x  1 root root 1073776 Aug 29 01:01 /usr/lib/xorg/modules/drivers/radeon_drv.so
-rwxr-xr-x  1 root root   26520 Oct 17 02:43 /usr/lib/xorg/modules/drivers/vesa_drv.so

The slightly different sizes for all five files are undoubtedly explained as slightly different versions; the only other difference I see is more liberal use of the execute bit, and that can't matter. So I don't see it (whatever "it" is), so far. Thus I'm inclined to consider this an issue within either pacman or the kernel (the loading of modules). But alas I don't (yet) know how to evaluate either of these.

There's one more puzzle that I don't seem to yet understand. Before I loaded pacman -S xf86-video-mach64 I was failing to load "mach64"; after I added it I was failing to load "ati". But the reference to "mach64" seems to have disappeared, a fate that didn't befall either "vesa" or "fbdev". Perhaps this is a valuable clue....

Last edited by truebuilder (2011-11-05 16:23:12)

Offline

#10 2011-11-05 17:24:40

Gusar
Member
Registered: 2009-08-25
Posts: 3,605

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

mach64 is definitely the right driver to use. So install xf86-video-mach64 and remove all other x86-video-* packages. Then post Xorg.0.log again.

Last edited by Gusar (2011-11-05 17:25:25)

Offline

#11 2011-11-06 22:54:07

truebuilder
Member
Registered: 2011-11-02
Posts: 12

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

So many tinkerings, so little time.

Thanks for your faith, Gusar. I've tried it without the "ati", with only the "mach64", with all four. I tried to install everything that Lubuntu had attempted LoadModule. And I even located ati-dri and tried with that. Nothing seems to get me further than X seeming to start, big grey screen, hung forever, and when I Control+Alt+Backspace out, I see a variation on failures already posted.

Note Big Grey is not new behavior; sometimes I've seen text failures, sometimes I've had to exit from Greyness to see same / similar text failures. I'm sure that there's a pattern here, but I'm not getting it.....

This seems harder than it should. So I'm going to suspect that my installation has diverged from "normal" (Who's to say what's normal..? tongue), and hit the Big Red Button, just do a fresh netinstall. That will allow me to repartition slash anyway, move /home to a spare partition on another drive. Then I'll return to the history here, and see what jells out.

Will followup with X status by Monday hopefully. Thanks all for your attention. cool

Offline

#12 2011-11-09 18:32:34

truebuilder
Member
Registered: 2011-11-02
Posts: 12

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

ALL RIGHT! Resolved!!! The fourth time was the charm.

We all missed it, that there might be another configuration file, some place to tell the kernel which video driver to use. Two days of Googling turned up that ArchLinux's own Xorg Getting Started knows. When I created (the default is apparently no such) /etc/X11/xorg.conf.d/10-monitor.conf with just its example:

Section "Monitor"
    Identifier    "Monitor0"
EndSection

Section "Device"
    Identifier    "Device0"
    Driver        "vesa" #Choose the driver used for this monitor
EndSection

Section "Screen"
    Identifier    "Screen0"  #Collapse Monitor and Device section to Screen section
    Device        "Device0"
    Monitor       "Monitor0"
    DefaultDepth  16 #Choose the depth (16||24)
    SubSection "Display"
        Depth     16
        Modes     "1024x768_75.00" #Choose the resolution
    EndSubSection
EndSection

I could get twm up on vesa; changing vesa to mach64 got me up on that. Apparently fbdev is just not necessary, ditto ati.

I like a full-feature desktop, but Gnome 3 refused (no doubt balking at my fossil video card), and Gnome 2 seemed kinda rough around the edges. So I went for KDE here (my Gentoo runs Gnome, I like both).  Here's my complete recipe (that others might benefit from my hardfought knowledge):

pacman -Syy ; pacman -Syu # 20111109T0745-08
pacman -S sudo wgetpaste
pacman -S alsa-utils alsa-plugins
pacman -S xorg-server xorg-xinit xorg-utils xorg-server-utils
pacman -S mesa mesa-demos
pacman -S xf86-video-vesa xf86-video-mach64
pacman -S xorg-twm xorg-xclock xterm
pacman -S dbus ; rc.d start dbus
# cp to /etc/rc.conf # dbus DAEMONS
# cp to /etc/fstab # /dos vfat noauto,noexec,nosuid,nodev,users,flush 0 0
# cp to /etc/inittab # 5:initdefault x:5:respawn:/usr/bin/kdm -nodaemon
# cp to /boot/grub/menu.lst # X11 Multi-user Fallback WinXP
# cp to /etc/X11/xorg.conf.d/10-evdev.conf # terminate:ctrl_alt_bksp
# cp nu /etc/X11/xorg.conf.d/10-monitor.conf # mach64 .OR. vesa
startx # twm
pacman -S kde-meta
adduser archie # audio,lp,optical,storage,video,wheel,games,power,scanner
pacman -Syu
reboot # KDE

Here are the copied files:
/etc/rc.conf
/etc/fstab
/etc/inittab
/boot/grub/menu.lst
/etc/X11/xorg/conf.d/10-evdev.conf
/etc/X11/xorg/conf.d/10-monitor.conf

And here are my timings in minutes:

00     boot NetInistall (from cold)
13     boot (newly installed) Arch
21     up on twm
45     up on KDE

Time for a break; later I'll return to consider firefox, chromium, opera, and stellarium.

I'll leave this not-yet-SOLVED in case throwing that switch shuts down further replies (someone might want to comment...). And incidentally, it's not obvious to me (yet) how to mark this as SOLVED (so if someone might advise...).

Thank you all for your advice and attention.

cool

Offline

#13 2011-11-09 18:55:02

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

You need to edit your first post and add '[solved]' to the thread's title.

Offline

#14 2011-11-09 19:25:34

truebuilder
Member
Registered: 2011-11-02
Posts: 12

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

Thanks karol. Hmmm. Editing the first post (and I'm logged in...) allows me to change the "Message" but not the "Subject". (BTW, this is a "Quick post" rather than my normal "Post Reply").

Offline

#15 2011-11-09 19:26:43

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

Are you sure you clicked 'Edit' on this post: https://bbs.archlinux.org/viewtopic.php … 3#p1011433 ?

Offline

#16 2011-11-09 19:27:45

truebuilder
Member
Registered: 2011-11-02
Posts: 12

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

Yup! Indeed, I just added [SOLVED] to the Message itself....

Offline

#17 2011-11-09 20:08:01

bernarcher
Forum Fellow
From: Germany
Registered: 2009-02-17
Posts: 2,281

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

truebuilder wrote:

Yup! Indeed, I just added [SOLVED] to the Message itself....

Sorry, no. That way this is not of much use for others who search the forums. Add that [SOLVED] to the title (as everyone does).

It is easily done. Just edit your first post, there you (and only you) will get access to the title line ("Subject"). Prepend [SOLVED] there and done.

Thank you very much.


To know or not to know ...
... the questions remain forever.

Offline

#18 2011-11-10 00:44:50

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,339

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

bernarcher wrote:

Just edit your first post, there you (and only you) will get access to the title line ("Subject"). Prepend [SOLVED] there and done.

I see the problem.  The subject line is full and the browser will not accept additional keystrokes.  Unless someone has a better idea, I'd say we should just let this one go by the wayside smile


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#19 2011-11-10 01:12:28

Gusar
Member
Registered: 2009-08-25
Posts: 3,605

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

I'm curious about the actual fix though. I had to take a good look at what the code actually does differently from what is default. The only thing I see is setting depth to 16bit. Does it mean this graphic card is so old it can't handle 24bit? And if that's the case, how come Ubuntu picks up on that automatically and Arch doesn't? I'll have to carefully look at the logs.

Edit: Hmm, Ubuntu uses 24bit:

[    82.315] (--) Depth 24 pixmap format is 32 bpp

@truebuilder: Could you post an Xorg.0.log from Arch now that it's working?

Last edited by Gusar (2011-11-10 01:18:56)

Offline

#20 2011-11-10 04:32:02

truebuilder
Member
Registered: 2011-11-02
Posts: 12

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

bernarcher & ewaller ---

To make it easier for others to search the forums (the main reason that I went into such detail was so that others might benefit), I've removed that [SOLVED] from the first message then changed the thread's subject line from

startx ---> (EE) Failed to load module "mach64" ... "vesa" ... "fbdev"

to

[SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

Gusar ---

Here are both current and old Xorg.0.log files:

Xorg.0.log
Xorg.0.log.old

I'm typing this from WinXP Pro; Display Properties / Settings tells me Rage XL PCI (correct, and FWIW I believe an 8MB card), 1024 X 768 (native & highest resolution for the formerly rackmounted LCD "Samsung SyncMaster 570S/580S TFT", so also correct), and Color quality "Highest (32 bit)" (I don't know how to tell if this is correct, so I'm merely reporting it).

I'll look forward to your careful review (please echo what you consider relevant).

And thank you three and karol; this seems a rich forum, I'm glad I'm here.

cool

Offline

#21 2011-11-10 11:52:41

Gusar
Member
Registered: 2009-08-25
Posts: 3,605

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

Yep, you're definitely using 16bit in Arch, but 24/32bit in Ubuntu. From your Arch log:

[    22.564] (**) MACH64(0): Depth 16, (--) framebuffer bpp 16

Compare that with the code snippet I posted above from the Ubuntu log.

Further from the Arch log:

[    22.669] (II) MACH64(0): Not using mode "1024x768_75.00" (no mode of this name)

Which means the mode you've set up in your 10-monitor.conf does nothing. I actually suspected so. Which means that part of the configuration is not what contributes to the "fix".

The only other difference between the logs is this:
Ubuntu:

[    82.191] (II) MACH64(0): Maximum clock: 125.00 MHz

Arch:

[    22.668] (II) MACH64(0): Maximum clock: 230.00 MHz

Try this: Reduce 10-monitor.conf to just the Device section, remove the other parts.

Last edited by Gusar (2011-11-10 11:59:39)

Offline

#22 2011-11-11 02:23:34

truebuilder
Member
Registered: 2011-11-02
Posts: 12

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

Gunar ---

With a /etc/X11/xorg.conf.d/10-monitor.conf composed only of

Section "Device"
    Identifier    "Device0"
    Driver        "mach64" #Choose the driver used for this monitor
EndSection

I get this /var/log/Xorg.0.log. I see (line 111 in the URL)

[    23.005] (==) MACH64(0): Depth 24, (--) framebuffer bpp 32

--- that's what you meant, right? I'm now doing 24-bit (or perhaps 32-bit) color, whereas I was before doing 16-bit (I'm not sure that I can detect the distinction, but it's nice to get what the system can deliver). And in "System Settings" / "Display & Monitor" (or something like that, this is from memory) I could see the Monitor listed as 1024X768 (75Hz), which is just what the Win XP I'm typing on shows.

Regarding that maximum clock, (line 233 in the URL)

[    23.109] (II) MACH64(0): Maximum clock: 125.00 MHz

is a mystery to me, but you'll know. Thanks again for the suggestion, Gunar. I'm satisfied in all particulars except mildly mystified as to why this is called "10-monitor.conf" neutral (mine now looks more like a 10-videodriver.conf smile ).

Offline

#23 2011-11-12 15:05:42

Gusar
Member
Registered: 2009-08-25
Posts: 3,605

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

truebuilder wrote:

I'm now doing 24-bit (or perhaps 32-bit) color, whereas I was before doing 16-bit (I'm not sure that I can detect the distinction, but it's nice to get what the system can deliver)

Trust me, it's noticeable. Particularly with gradients.

truebuilder wrote:

Regarding that maximum clock, (line 233 in the URL)

[    23.109] (II) MACH64(0): Maximum clock: 125.00 MHz

is a mystery to me, but you'll know.

I think I get it now. Higher bit depth, lower maximum clock. Could affect which resolutions are available.

truebuilder wrote:

I'm satisfied in all particulars except mildly mystified as to why this is called "10-monitor.conf" neutral (mine now looks more like a 10-videodriver.conf smile ).

The name is irrelevant pretty much, it only matters that it has a .conf extension. You can name the file grblj.conf if you want smile

Can you do one final test? Remove the file completely. If it won't work, we will have the final fix, and thus gain full enlightenment smile: ATi Rage cards require explicit driver assignment. Ok, we still won't know why Arch requires this and Ubuntu doesn't...

Last edited by Gusar (2011-11-12 15:28:05)

Offline

#24 2011-11-14 19:52:13

truebuilder
Member
Registered: 2011-11-02
Posts: 12

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

Gusar ---

Per your request, I ran additional testing. With the four-line version of /etc/X11/xorg.conf.d/10-monitor.conf absent I received the following results:

TEST Runlevel 3 / root / startx ---> twm (oops, no ~/.xinitrc) ---> /var/log/Xorg.0.log

I'm no twm fan, but FWIW it looked OK....

TEST Runlevel 3 / root / startx ---> (with ~/.xinitrc that execs startkde) ---> /var/log/Xorg.0.log

Results were identical to the Runlevel 5 that I've outlined below (experimentation and note composition just aren't synchronized tongue - this was chronologically the third of the three tests, "5" was the second).

TEST Runlevel 5 / non-root ---> Abbey-normal KDE, here's the /var/log/Xorg.0.log; what I noticed that seemed, well, interesting (note that _all_ of these were eliminated by returning the 10-monitor.conf):

* Taskbar stretched from the lower-left corner to about 70% of the way across (yet the peanut thingie was indeed in the upper-right corner).

* Icons off the K-button seem to have a cross-hatching and colorless aspect to them.

* System Settings / Display and Monitor showed:

Default
1,024x768 (0.0 Hz)

With reboot based upon the four-line 10-monitor.conf that would be 75.0 Hz....

* Mousing for a reboot..., the mouse pointer had to be a full icon to the right of where the action seemed to be occurring. That is, if I put the pointer on the shutdown icon, KDE wouldn't then offer the shutdown / reboot / {others} actions, but would instead show me the results of the recently-used icon.

* Ctrl+Alt+F2 got me to a command prompt, in order to do some wgetpaste-ing. But Ctrl+Alt+F7 took me ~back to the twilight zone. The display was (I believe) both dim and low-contrast. It was almost impossible to use, I couldn't even perform a reboot (I had to do that from the F2 console instead). Note that after rebooting with four-line 10-monitor.conf, this works perfectly; I can Ctrl+Alt+F2 then Ctrl+Alt+F7, and the display is as it was before, as it should be.

I hope that this gives you the clues you were hoping for, Gusar. And me? I'm going to just enjoy using Arch for a while smile but also lurk around the forums (perhaps something I know can be useful, payback & payforward both).

Offline

#25 2011-11-14 20:10:36

Gusar
Member
Registered: 2009-08-25
Posts: 3,605

Re: [SOLVED] startx --> (EE) Failed to load module "mach64" ... "vesa" ...

I would have preferred logs when xf86-video-vesa is not installed. I think I'll need to start prefixing all my requests for X logs with "uninstall xf86-video-vesa".

Despite that, I think I got what I wanted: it seems one needs to explicitly specify mach64 on Arch, whereas this is not needed on Ubuntu. Either Ubuntu patches X (similar to how Arch does if for Nvidia cards) or they some extra magic before starting X.

Last edited by Gusar (2011-11-14 20:12:10)

Offline

Board footer

Powered by FluxBB