You are not logged in.

#1 2011-11-07 20:00:59

bmanuel
Member
Registered: 2011-10-06
Posts: 103

gnome-terminal: how to *really* disable F10 key?

That's frustrating: although disabled via edit->keyboard shortcuts, also removed via both gconf-editor and dconf-editor, still Gnome3 catch it and open the right-click contextual menu.. any way to really disable this behavior?

Offline

#2 2011-11-07 20:12:25

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: gnome-terminal: how to *really* disable F10 key?


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#3 2011-11-07 20:38:45

bmanuel
Member
Registered: 2011-10-06
Posts: 103

Re: gnome-terminal: how to *really* disable F10 key?

Thank you for the link!
I thought it was a gnome shell bug acting strangely with keys, since i also seems to not be able to get my CTRL and/or SHIFT keys captured correctly: SHIFT+F5 doesn't work in both thunderbird-7 and Eclipse O_o

<edit> Thunderbird8 solved the SHIFT+F5 issue.
<edit2> gnome-control-center 3.2.2 update did solve the issue also in other apps (bugfix: Fixed handling of <Primary>)

Last edited by bmanuel (2011-11-10 20:12:27)

Offline

#4 2011-11-07 20:39:40

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: gnome-terminal: how to *really* disable F10 key?

same bug i guess


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#5 2011-11-08 16:49:56

bmanuel
Member
Registered: 2011-10-06
Posts: 103

Re: gnome-terminal: how to *really* disable F10 key?

wonder wrote:

same bug i guess

Mmm i tried applying the mentioned patch, but the problem persists..

Last edited by bmanuel (2011-11-08 16:50:04)

Offline

#6 2011-11-16 19:08:19

twouters
Member
Registered: 2010-04-01
Posts: 23

Re: gnome-terminal: how to *really* disable F10 key?

Just tried to fix this by inserting the following line in ~/.gtkrc-2.0

gtk-menu-bar-accel = ""

Did the same with ~/.config/gtk-3.0/settings.ini

[Settings]
gtk-menu-bar-accel = ""

But F10 keeps popping up the menu. (even after a reboot)

Last edited by twouters (2011-11-16 19:08:56)

Offline

#7 2011-11-16 19:19:38

Kilzool
Member
From: Ireland
Registered: 2010-08-04
Posts: 228

Re: gnome-terminal: how to *really* disable F10 key?

Question: If you open your gnome-terminal, and then right click on a blank spot within the gnome-terminal, does it bring up a Preferences window?
   >>  Now if it does bring up a Preferences window when right clicking on a blank spot within the gnome-terminal, does the Preferences window have a Shortcuts tab?
         >>  Now does the Shortcuts menu have any options to disable functions keys, ie F10, etc?
                 >> Hope this solves your issue.

Sorry if it does not solve your issue, I tried.

Offline

#8 2011-11-16 19:53:04

twouters
Member
Registered: 2010-04-01
Posts: 23

Re: gnome-terminal: how to *really* disable F10 key?

Fixed it for me, don't know if it's a correct solution.
For gtk-2 apps add this in ~/.gtkrc-2.0

binding "NoKeyboardNavigation" {
        unbind "<shift>F10"
}

class * binding "NoKeyboardNavigation"

For gtk-3 apps like gnome-terminal and nautilus I created a new file: ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation {
	unbind "<shift>F10"
}

* {
	gtk-key-bindings: NoKeyboardNavigation
}

[edit]I did have to close _all_ terminal windows before these changes were in effect.[/edit]

Last edited by twouters (2011-11-16 19:58:02)

Offline

#9 2011-11-16 19:56:30

twouters
Member
Registered: 2010-04-01
Posts: 23

Re: gnome-terminal: how to *really* disable F10 key?

Kilzool wrote:

Question: If you open your gnome-terminal, and then right click on a blank spot within the gnome-terminal, does it bring up a Preferences window?
   >>  Now if it does bring up a Preferences window when right clicking on a blank spot within the gnome-terminal, does the Preferences window have a Shortcuts tab?
         >>  Now does the Shortcuts menu have any options to disable functions keys, ie F10, etc?
                 >> Hope this solves your issue.

Sorry if it does not solve your issue, I tried.

That wasn't the issue I'm experiencing.
I disabled those options, but GTK translates <shift>+F10 to a right click, which brings up the "right click" menu.
It seems that since a certain version of xkeyboard-config pressing F10 is seen as <shift>+F10 by GTK. (Which I think is reported as FS#26408)

Offline

#10 2012-01-13 12:41:27

thesofty
Member
From: Nuremberg, Germany
Registered: 2011-05-09
Posts: 46

Re: gnome-terminal: how to *really* disable F10 key?

twouters:
Your proposal (the gtk-3.0-version) solved my gnome-terminal F10 - poblem too.
Thank you very much for that big_smile.

Offline

#11 2012-02-15 16:55:01

sigmund
Member
From: Milano, Italy, EU
Registered: 2009-12-06
Posts: 50

Re: gnome-terminal: how to *really* disable F10 key?

twouters wrote:

For gtk-3 apps like gnome-terminal and nautilus I created a new file: ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation {
	unbind "<shift>F10"
}

* {
	gtk-key-bindings: NoKeyboardNavigation
}

Thank you so much!!! cool
I was very annoyed by this F10 misbehavior when running Midnight Commander.


Definitely moving to GNU/Linux made me trust Computer Science once again.
Definitely moving to Arch made me enjoy and understand GNU/Linux once again.

Offline

#12 2012-02-26 06:34:46

pntruongan
Member
Registered: 2011-01-31
Posts: 41

Re: gnome-terminal: how to *really* disable F10 key?

twouters wrote:

Fixed it for me, don't know if it's a correct solution.
For gtk-2 apps add this in ~/.gtkrc-2.0

binding "NoKeyboardNavigation" {
        unbind "<shift>F10"
}

class * binding "NoKeyboardNavigation"

For gtk-3 apps like gnome-terminal and nautilus I created a new file: ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation {
	unbind "<shift>F10"
}

* {
	gtk-key-bindings: NoKeyboardNavigation
}

[edit]I did have to close _all_ terminal windows before these changes were in effect.[/edit]

Worked beautifully for me. This problem has been haunted me for years until somebody point me to this thread recently, thank you very much.

Last edited by pntruongan (2012-02-26 06:35:06)

Offline

#13 2012-02-26 06:45:44

Avant-texte
Member
Registered: 2012-02-13
Posts: 136

Re: gnome-terminal: how to *really* disable F10 key?

pntruongan wrote:
twouters wrote:

Fixed it for me, don't know if it's a correct solution.
For gtk-2 apps add this in ~/.gtkrc-2.0

binding "NoKeyboardNavigation" {
        unbind "<shift>F10"
}

class * binding "NoKeyboardNavigation"

For gtk-3 apps like gnome-terminal and nautilus I created a new file: ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation {
	unbind "<shift>F10"
}

* {
	gtk-key-bindings: NoKeyboardNavigation
}

[edit]I did have to close _all_ terminal windows before these changes were in effect.[/edit]

Worked beautifully for me. This problem has been haunted me for years until somebody point me to this thread recently, thank you very much.

Well, you can't be faulted for trying to disable this with the general settings facilities. The point of GNOME is an integrated environment. If that is the only solution, it is an oversight on the part of the GNOME devs in terms of said integration.

Last edited by Avant-texte (2012-02-26 06:46:24)

Offline

#14 2012-03-24 15:52:09

k2s
Member
Registered: 2012-03-24
Posts: 9

Re: gnome-terminal: how to *really* disable F10 key?

Correct solution for GTK2:

I am using XFCE4 which is using GTK2. Solution posted  #8 was not working for me until I found out that there are missing quotes.

This is working modification of ~/.gtkrc-2.0:

binding "NoKeyboardNavigation" {
    unbind "<shift>F10"
}

class "*" binding "NoKeyboardNavigation"

Credits go to http://askubuntu.com/a/105023/51887.

Offline

#15 2012-03-26 23:02:00

skinnyvoice
Member
From: London, UK
Registered: 2011-07-04
Posts: 17
Website

Re: gnome-terminal: how to *really* disable F10 key?

twouters wrote:

For gtk-3 apps like gnome-terminal and nautilus I created a new file: ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation {
	unbind "<shift>F10"
}

* {
	gtk-key-bindings: NoKeyboardNavigation
}

[edit]I did have to close _all_ terminal windows before these changes were in effect.[/edit]

Genius, thanks!

Offline

#16 2012-11-07 12:36:37

okcomputer44
Member
Registered: 2012-11-07
Posts: 1

Re: gnome-terminal: how to *really* disable F10 key?

twouters wrote:

Fixed it for me, don't know if it's a correct solution.
For gtk-2 apps add this in ~/.gtkrc-2.0

binding "NoKeyboardNavigation" {
        unbind "<shift>F10"
}

class * binding "NoKeyboardNavigation"

For gtk-3 apps like gnome-terminal and nautilus I created a new file: ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation {
	unbind "<shift>F10"
}

* {
	gtk-key-bindings: NoKeyboardNavigation
}

[edit]I did have to close _all_ terminal windows before these changes were in effect.[/edit]

Nice one!
Helped me too, thanks mate!

Offline

#17 2013-04-13 12:15:24

pavlikva
Member
Registered: 2013-04-13
Posts: 1

Re: gnome-terminal: how to *really* disable F10 key?

twouters wrote:

Fixed it for me, don't know if it's a correct solution.
For gtk-2 apps add this in ~/.gtkrc-2.0

binding "NoKeyboardNavigation" {
        unbind "<shift>F10"
}

class * binding "NoKeyboardNavigation"

For gtk-3 apps like gnome-terminal and nautilus I created a new file: ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation {
	unbind "<shift>F10"
}

* {
	gtk-key-bindings: NoKeyboardNavigation
}

[edit]I did have to close _all_ terminal windows before these changes were in effect.[/edit]

Thanks a lot! This solved my problem. I wonder why the thickbox is still not working properly in Ubuntu 12.04...

Offline

Board footer

Powered by FluxBB