You are not logged in.

#1 2011-11-09 16:02:21

kekules_dream
Member
Registered: 2009-05-19
Posts: 100

[SOLVED] firefox 8 not starting

Since I upgraded to firefox 8 yesterday on my x86_64 install it won't start:

$ firefox
XPCOMGlueLoad error for file /usr/lib/libxpcom.so:
/usr/lib/libxpcom.so: cannot open shared object file: No such file or directory
Couldn't load XPCOM.

/usr/lib # ln -s firefox/libxpcom.so libxpcom.so

$ firefox
Couldn't read application.ini

/usr/lib # ln -s firefox/application.ini application.ini

$ firefox
Segmentation fault

reverting to firefox 7 and it goes again.

nspr is installed.

Was wondering if anyone else is experiencing this or if any suggestions.

Thanks

Last edited by kekules_dream (2011-11-09 20:23:23)

Offline

#2 2011-11-09 16:20:56

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [SOLVED] firefox 8 not starting

remove all the symlinks you did because they are plain wrong and do:

LD_DEBUG=files firefox > firefoxlog 2>&1

then paste firefoxlog


Give what you have. To someone, it may be better than you dare to think.

Offline

#3 2011-11-09 17:19:15

kekules_dream
Member
Registered: 2009-05-19
Posts: 100

Re: [SOLVED] firefox 8 not starting

Offline

#4 2011-11-09 17:22:06

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [SOLVED] firefox 8 not starting

paste pacman -Qo /usr/lib/libxpcom.so


Give what you have. To someone, it may be better than you dare to think.

Offline

#5 2011-11-09 17:58:09

kekules_dream
Member
Registered: 2009-05-19
Posts: 100

Re: [SOLVED] firefox 8 not starting

There is no /usr/lib/libxpcom.so

$ pacman -Qo /usr/lib/libxpcom.so
error: failed to read file '/usr/lib/libxpcom.so': No such file or directory
$ pacman -Qo /usr/lib/firefox/libxpcom.so
/usr/lib/firefox/libxpcom.so is owned by firefox 8.0-1

Offline

#6 2011-11-09 18:18:35

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [SOLVED] firefox 8 not starting

2275:     file=/usr/lib/libxpcom.so [0];  needed by firefox [0]
XPCOMGlueLoad error for file /usr/lib/libxpcom.so:

it tries to load this file.

can you paste the output of:

$ type firefox

Give what you have. To someone, it may be better than you dare to think.

Offline

#7 2011-11-09 18:28:03

kekules_dream
Member
Registered: 2009-05-19
Posts: 100

Re: [SOLVED] firefox 8 not starting

I get the same thing regardless if firefox 7 or 8 is installed:

$ type firefox
firefox is /usr/bin/firefox

Offline

#8 2011-11-09 18:32:51

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [SOLVED] firefox 8 not starting

i don't get it

LD_DEBUG=all firefox > firefoxlog 2>&1


Give what you have. To someone, it may be better than you dare to think.

Offline

#9 2011-11-09 19:08:57

kekules_dream
Member
Registered: 2009-05-19
Posts: 100

Re: [SOLVED] firefox 8 not starting

Two halves:
http://pastebin.com/BHnh0Zbp
http://pastebin.com/uMwUzX2A

Thanks a lot for looking at these.  I did delete the symlinks, logged out and in, rebooted.  It is as if firefox 8 wants to find the libraries in /usr/lib/ rather than /usr/lib/firefox/ while firefox 7 is happy to have them in /usr/lib/firefox-7.0/

Offline

#10 2011-11-09 19:16:37

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [SOLVED] firefox 8 not starting

just to be sure, paste env output

for me the log is  file=/usr/lib/firefox/libxpcom.so [0];  needed by firefox [0]

Last edited by wonder (2011-11-09 19:20:27)


Give what you have. To someone, it may be better than you dare to think.

Offline

#11 2011-11-09 19:55:43

kekules_dream
Member
Registered: 2009-05-19
Posts: 100

Re: [SOLVED] firefox 8 not starting

Sorry not sure what you mean.  What is the command?

Offline

#12 2011-11-09 20:01:06

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [SOLVED] firefox 8 not starting

env

Give what you have. To someone, it may be better than you dare to think.

Offline

#13 2011-11-09 20:06:35

kekules_dream
Member
Registered: 2009-05-19
Posts: 100

Re: [SOLVED] firefox 8 not starting

I now have some new weird information.  I normally use Window Maker.  I also have fluxbox and KDE installed.  I get the same error in fluxbox as I do Window Maker.  Right now I am using KDE and in KDE, firefox 8 started.  I went back to see if it would start in window maker now that it had done its initial start, but still I get the error message.  Here is the relevant line in my .xinitrc for kde:

exec ck-launch-session startkde

and wmaker:

exec ck-launch-session dbus-launch wmaker

I previously did not have the dbus-launch, it has no effect on the problem whether it is there or not.

Hopefully this gives some kind of clue.

Offline

#14 2011-11-09 20:11:37

kekules_dream
Member
Registered: 2009-05-19
Posts: 100

Re: [SOLVED] firefox 8 not starting

Offline

#15 2011-11-09 20:16:25

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [SOLVED] firefox 8 not starting

PATH=/usr/lib/:/usr/lib/firefox-4.0:/usr/local/bin:/home/matt/bin:/usr/lib/:/usr/lib/firefox-4.0:/usr/local/bin:/home/matt/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/usr/bin/vendor_perl:/usr/lib/perl5/vendor_perl/bin:/usr/bin/core_perl

why is /usr/lib and /usr/lib/firefox-4.0 in there? and some duplicates

Last edited by wonder (2011-11-09 20:17:02)


Give what you have. To someone, it may be better than you dare to think.

Offline

#16 2011-11-09 20:23:04

kekules_dream
Member
Registered: 2009-05-19
Posts: 100

Re: [SOLVED] firefox 8 not starting

I don't know how that stuff got in there.  Cleaned up my .bashrc and alls well.  Thanks again.

Offline

#17 2011-11-09 20:24:06

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [SOLVED] firefox 8 not starting

now works?


Give what you have. To someone, it may be better than you dare to think.

Offline

#18 2011-11-09 20:54:29

kekules_dream
Member
Registered: 2009-05-19
Posts: 100

Re: [SOLVED] firefox 8 not starting

Yes works perfectly.  I have modified the original post as solved.  I now know the value of env. Sometimes I have noticed people make a new user to try to chase down a problem.  I always save the original .bashrc in a new install.  The first thing I did after I saw the light (thanks to your guidance) was rename my .bashrc and mv .bashrc-orig .bashrc.  That solved it.  Thanks so much for your time.

Offline

Board footer

Powered by FluxBB