You are not logged in.

#1 2011-11-12 19:24:48

ssri
Member
Registered: 2010-02-16
Posts: 213

[Solved] SMplayer / MPlayer crash, exit code: 127

Everything worked just prior to the pacman update this morning (first in two weeks), then this happened:

/usr/bin/mplayer: error while loading shared libraries: libx264.so.118: cannot open shared object file: No such file or directory

x264, mplayer (build date: 10/15/11) and smplayer (build date: 11/11/10) installed from extra and community repos accordingly from a pretty up-to-date mirror (mirror @ rit.edu).  VLC, unsurprisingly, appears to be fine.

Last edited by ssri (2011-11-12 19:34:14)

Offline

#2 2011-11-12 19:29:58

karol
Archivist
Registered: 2009-05-06
Posts: 25,432

Re: [Solved] SMplayer / MPlayer crash, exit code: 127

The x264 package has just been updated http://www.archlinux.org/packages/?name=x264 - mirrors may need some more time to sync (if in doubt, check the version).
It's a similar issue to https://bbs.archlinux.org/viewtopic.php?id=130192
You can download the package directly from the mirror by clicking the 'Download From Mirror' link on the top right http://www.archlinux.org/packages/extra/i686/x264/ (for32-bit)

Last edited by karol (2011-11-12 19:35:32)

Offline

#3 2011-11-12 19:33:59

ssri
Member
Registered: 2010-02-16
Posts: 213

Re: [Solved] SMplayer / MPlayer crash, exit code: 127

Hi Karol,

You are right, apparently mplayer [testing] is moving into [extra] (build date: 10/31/11) today.  I installed testing/mplayer from the repo I use right before I saw your message and everything appears to be fine.  Thanks for the help!

Offline

#4 2011-11-12 19:35:25

karol
Archivist
Registered: 2009-05-06
Posts: 25,432

Re: [Solved] SMplayer / MPlayer crash, exit code: 127

You should check 'Last Updated' and not 'Build Date'. Many packages go through [testing] and they may be deceivingly "old", but they have been moved to the non-testing repos only recently, like in this case: Last Updated:  2011-11-12

Last edited by karol (2011-11-12 19:36:11)

Offline

#5 2011-11-14 23:15:51

moetunes
Member
From: A comfortable couch
Registered: 2010-10-09
Posts: 1,024

Re: [Solved] SMplayer / MPlayer crash, exit code: 127

I had to make a link from libx264.so.119 to libx264.so.118 to get things working today. Updating and grabbing the package both didn't work.


You're just jealous because the voices only talk to me.

Offline

#6 2011-11-22 22:36:08

pablokal
Member
From: Nijmegen, Holland
Registered: 2010-03-07
Posts: 96
Website

Re: [Solved] SMplayer / MPlayer crash, exit code: 127

I had to make a link from libx264.so.119 to libx264.so.118 to get things working today.

Where did you find libx264.so.118? I couldn't locate it anymore on my system.
Found it out: in the previous version of x264 in var/cache/pacman/pkg.

Last edited by pablokal (2011-11-22 22:46:28)


GNu/Linux: Nu nog schoner: http://linuxnogschoner.blogspot.com/

Offline

#7 2011-12-01 10:28:19

ennui
Member
Registered: 2010-08-23
Posts: 21

Re: [Solved] SMplayer / MPlayer crash, exit code: 127

Anyone get this to work yet?
I was getting the same error as the original poster after updating mplayer. I then updated x264 from the repos and now I get this error:


MPlayer interrupted by signal 6 in module: preinit_libvo

Any ideas?

Offline

#8 2011-12-01 11:41:39

SS4
Member
From: !Rochford, Essex
Registered: 2010-12-05
Posts: 699

Re: [Solved] SMplayer / MPlayer crash, exit code: 127

ennui wrote:

Anyone get this to work yet?
I was getting the same error as the original poster after updating mplayer. I then updated x264 from the repos and now I get this error:


MPlayer interrupted by signal 6 in module: preinit_libvo

Any ideas?

Working here with the [testing] version of mplayer and x264


Rauchen verboten

Offline

Board footer

Powered by FluxBB