You are not logged in.

#1 2011-11-13 15:39:11

hadiyazdi
Member
Registered: 2011-11-13
Posts: 14

[SOLVED] iwconfig change mode to master gives error

Trying wireless connection to a router, when I try to change the mode of wlan0 to master I get this error:

iwconfig wlan0 mode master

Error for wireless request "Set Mode" (8B06) :
SET failed on device wlan0 ; Invalid argument.

Last edited by hadiyazdi (2011-11-13 17:23:16)

Offline

#2 2011-11-13 16:02:27

b4data
Member
Registered: 2010-12-14
Posts: 141

Re: [SOLVED] iwconfig change mode to master gives error

Are you trying connect to a router, or are you trying to set up your wireless connection as a router?

More information on the latter here.

What wireless nic/driver are you using? Have you researched whether or not master mode is supported in your setup?

Offline

#3 2011-11-13 16:22:34

hadiyazdi
Member
Registered: 2011-11-13
Posts: 14

Re: [SOLVED] iwconfig change mode to master gives error

I need to connect to a router... I have just installed arch linux and I need to connect to the internet to install additional packages.

from lspci:
- Network controller: Interl Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)

Offline

#4 2011-11-13 16:37:15

Gusar
Member
Registered: 2009-08-25
Posts: 3,472

Re: [SOLVED] iwconfig change mode to master gives error

You don't need master mode for that. Just use one of the many managers (netcg, wicd, networkmanager) to connect.

Offline

#5 2011-11-13 16:39:53

b4data
Member
Registered: 2010-12-14
Posts: 141

Re: [SOLVED] iwconfig change mode to master gives error

Gusar is correct, follow his advice.

Also, a quick search revealed this wiki entry which might help you:

https://wiki.archlinux.org/index.php/Wi … 000-series

Last edited by b4data (2011-11-13 16:41:26)

Offline

#6 2011-11-13 16:42:26

hadiyazdi
Member
Registered: 2011-11-13
Posts: 14

Re: [SOLVED] iwconfig change mode to master gives error

I know, I need to connect first to intsall a network manager since they are not available in arch linux local packages

Offline

#7 2011-11-13 16:50:17

b4data
Member
Registered: 2010-12-14
Posts: 141

Re: [SOLVED] iwconfig change mode to master gives error

Have you read this?

https://wiki.archlinux.org/index.php/Wi … _available

Also, this:

https://wiki.archlinux.org/index.php/Wi … nual_setup

Last edited by b4data (2011-11-13 16:53:43)

Offline

#8 2011-11-13 17:16:56

hadiyazdi
Member
Registered: 2011-11-13
Posts: 14

Re: [SOLVED] iwconfig change mode to master gives error

yes I did

the guide uses ad-hoc mode, but this mode cannot connect to a router, i need master mode

I can use ad-hoc and managed modes but not master nor auto!!

Offline

#9 2011-11-13 17:22:44

hadiyazdi
Member
Registered: 2011-11-13
Posts: 14

Re: [SOLVED] iwconfig change mode to master gives error

I disabled router password, used managed mode and it worked!!

Sorry for any disturbance

Offline

Board footer

Powered by FluxBB