You are not logged in.

#1 2005-06-17 19:49:15

Karma XXL
Member
From: Budapest, Hungary
Registered: 2005-06-13
Posts: 91

[SOLVED] Bitstream Vera missing characters under Qt

Hey everyone!

I've installed some KDE apps (including the whole KDE on my smaller desktop), and I've met a strange and very annoying glitch. Under every Qt app the letters used in the hungarian language (ő,ű) show up as rectangles when I'm using the Bitstream Vera fonts.

On the other hand, these fonts work fine under GTK2, under gedit for example.

What could be wrong here? Have I missed an option regarding my locale, fonts or something?

BTW, my LANG variable is set to "hu_HU".

Thanks for the help!


Ailen:
Kernel: Linux 2.6.14-rc4-ck1 #1 PREEMPT
Built on: Mon Oct 17 14:51:37 CEST 2005
Hardware: Mobile AMD Sempron(tm) Processor 2800+ AuthenticAMD
WM: E17 snapshot 20051016

Offline

#2 2005-06-17 21:37:53

Karma XXL
Member
From: Budapest, Hungary
Registered: 2005-06-13
Posts: 91

Re: [SOLVED] Bitstream Vera missing characters under Qt

Solved it!

The Bitstream fonts don't have ő and ű... I've found fixed fonts here:
http://office.fsf.hu/work/fonts/fsfhu-ljuba/truetype/

After installing them and changing the default fonts in KDE Control Center, amaroK works fine.


Ailen:
Kernel: Linux 2.6.14-rc4-ck1 #1 PREEMPT
Built on: Mon Oct 17 14:51:37 CEST 2005
Hardware: Mobile AMD Sempron(tm) Processor 2800+ AuthenticAMD
WM: E17 snapshot 20051016

Offline

#3 2005-06-18 09:42:38

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

Re: [SOLVED] Bitstream Vera missing characters under Qt

You also might wanna look at the DejaVu Fonts:
http://dejavu.sourceforge.net/wiki/index.php/Main_Page

though they address mainly the Chech and Polish language. I dunno if
Hungarian is covered in Iso8859-2? which is I think the target of DejaVu.

-neri
----------------------------------EDIT---------------------------
some people might find that useful
http://dejavu.sourceforge.net/wiki/inde … erivatives

Offline

#4 2005-06-18 10:16:56

Karma XXL
Member
From: Budapest, Hungary
Registered: 2005-06-13
Posts: 91

Re: [SOLVED] Bitstream Vera missing characters under Qt

Thanks for the link. Yes, hungarian is ISO8859-2 too.


Ailen:
Kernel: Linux 2.6.14-rc4-ck1 #1 PREEMPT
Built on: Mon Oct 17 14:51:37 CEST 2005
Hardware: Mobile AMD Sempron(tm) Processor 2800+ AuthenticAMD
WM: E17 snapshot 20051016

Offline

Board footer

Powered by FluxBB