You are not logged in.

#1 2005-06-19 03:11:37

fdac
Member
From: Brisbane, Australia
Registered: 2005-06-19
Posts: 96

startx blanks screen for ~60seconds then loads normally?!

Hi,

I've recently moved to Arch 0.7 and love it so far.  I installed xorg and am using fluxbox-devel as a window manager.

When I startup X using 'startx' the screen blanks and the machine seems to freeze for a period of time, varying between about 20 seconds and over 1 minute.

After this 'freeze', I get the Nvidia splash screen for about 1 second then fluxbox comes up as it should.  Once loaded everything is fast as normal.

Any ideas on what might be causing this?  I had previously tried Mandrake 10 with KDE and although this was a much more resource-intensive environment it didn't take anywhere near as long to load.

I've posted the following files in the hope somebody can help:

http://web.aanet.com.au/francis/xorg.conf
http://web.aanet.com.au/francis/Xorg.0.log

Cheers
Francis

Offline

#2 2005-06-19 07:22:43

CyberTron
Member
From: Gotland ,Sweden
Registered: 2005-03-17
Posts: 645
Website

Re: startx blanks screen for ~60seconds then loads normally?!

Hi!

Do you have two displays? and using both?

(WW) NVIDIA(0): Multiple displays connected, but only one display allowed;
(WW) NVIDIA(0):      using first display
(--) NVIDIA(0): CRT-0: maximum pixel clock: 350 MHz

Because it could be that it is looking for the other (and tryes to start it but fails because your config does not allow it..)

Another possibility could be that you haven't set any specifik nvidia options (like these NvAGP=3)

Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"
        VendorName  "NVidia"
        BoardName   "NVIDIA GeForce 4200 Go"
        Option      "NoLogo" "true"
        Option      "NvAGP" "3"
        BusID       "PCI:1:0:0"
    VideoRam 65536
    Option "DPMS" "true"
    BusID  "PCI:1:0:0"
    Option "RenderAccel" "true"
    Option "NoRenderExtension" "false"
#    Option "FlatPanelProperties" "Scaling = aspect-scaled"
    Option "NoPowerConnectorCheck" "true"
    Option "dpms"
    Option "UseEdidFreqs"   "yes"
    Option "IgnoreEDID" "false"
    Option "AllowDDCCI" "true"
    Option "Coolbits" "1"
    Option "AllowGLXWithComposite" "true"
    Option "NoFlip" "false"
    Option "RandRRotation" "false"
#    Option "DigitalVibrance" "2"
#               Option "SWCursor" "0"
#               Option "HWCursor" "1"
#               Option "CursorShadow" "1"
#               Option "CursorShadowAlpha" "64"
#               Option "CursorShadowXOffset" "4"
#               Option "CursorShadowYOffset" "2"
     Option "ConnectedMonitor" "DFP"
#    Option "TwinView" "1"
#    Option "TwinViewOrientation" "Clone"
#    Option "MetaModes" "1024x768, 1024x768; 800x600, 800x600; 640x480, 640x480"#    Option "MetaModes" "DFP-0: 1680x1024, TV-0: 1024x768"
#    Option "NoTwinViewXineramaInfo" "1"
#    Option "TVStandard" "PAL-B"
#    Option "TVOutFormat" "SVIDEO"
#    Option "ConnectedMonitor" "DFP-0, TV-0"
#    Option "HorizSync" "DFP-0: 15-100; TV-0: 30-100"
#    Option "VertRefresh" "DFP-0: 15-120; TV-0: 30-100"
#    Option "TVOverScan" "0.6"
EndSection

You might wanna post your .xinitrc as well, since you might be trying to start multiple wm's...
[/code]


http://www.linuxportalen.com  -> Linux Help portal for Linux and ArchLinux (in swedish)

Dell Inspiron 8500
Kernel 2.6.14-archck1  (selfcompiled)
Enlightenment 17

Offline

#3 2005-06-19 09:12:54

fdac
Member
From: Brisbane, Australia
Registered: 2005-06-19
Posts: 96

Re: startx blanks screen for ~60seconds then loads normally?!

G'day,

Definitely only one display.  I have a single 17" CRT hooked up to the Geforce 2 MX 400.  The card doesn't have a TV out or anything else.

I'm not on my linux box at the moment so can't post the xinitrc but there is nothing unusual in there, it just starts fluxbox.  All other WM lines are commented out.

What specific NVidia options should I be considering?

Francis

Offline

#4 2005-06-19 10:11:27

CyberTron
Member
From: Gotland ,Sweden
Registered: 2005-03-17
Posts: 645
Website

Re: startx blanks screen for ~60seconds then loads normally?!

Hmm...strange..

your xorg.log says:

(II) NVIDIA(0): Connected display device(s): CRT-0, TV-0
(WW) NVIDIA(0): Multiple displays connected, but only one display allowed;
(WW) NVIDIA(0):      using first display
(--) NVIDIA(0): CRT-0: maximum pixel clock: 350 MHz

So this might be a problem...

I would recommend trying this setup (instead of your device)

Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"
        VendorName  "NVidia"
        BoardName   "NVIDIA GeForce 4200 Go"
        Option      "NvAGP" "3"
    Option "RenderAccel" "true"
    Option "NoRenderExtension" "false"
    Option "NoPowerConnectorCheck" "true"
    Option "dpms"
    Option "UseEdidFreqs"   "yes"
    Option "IgnoreEDID" "false"
    Option "AllowDDCCI" "true"
    Option "AllowGLXWithComposite" "true"
     Option "ConnectedMonitor" "CRT" 

EndSection 

But the most important option for you is Option "Connected...."
that line might be wrong, (since I use dual monitors)...it might be:
Option ConnectedMonitor "CRT-0"

(notice the different -0 (zero))

try that big_smile

good luck[/code]


http://www.linuxportalen.com  -> Linux Help portal for Linux and ArchLinux (in swedish)

Dell Inspiron 8500
Kernel 2.6.14-archck1  (selfcompiled)
Enlightenment 17

Offline

#5 2005-06-19 15:13:28

freakyc
Member
Registered: 2004-03-28
Posts: 89

Re: startx blanks screen for ~60seconds then loads normally?!

Option "ConnectedMonitor" likely will work as well, but I remember they put in Option "IgnoreDisplayDevices" which at one point specifically stated in the README it fixed that problem.  I finally just flashed my vidcards BIOS so I wouldn't have to worry about it anymore.  Not sure if that'd be an option on your laptop, and definetly a "use at your own risk" thing.

Option "IgnoreDisplayDevices" "string"

    This option tells the NVIDIA kernel module to completely ignore the
    indicated classes of display devices when checking what display
    devices are connected. You may specify a comma-separated list
    containing any of "CRT", "DFP", and "TV". For example:
    
    Option "IgnoreDisplayDevices" "DFP, TV"
    
    will cause the NVIDIA driver to not attempt to detect if any
    flatpanels or TVs are connected. This option is not normally
    necessary; however, some video BIOSes contain incorrect information
    about what display devices may be connected, or what i2c port should
    be used for detection. These errors can cause long delays in starting
    X. If you are experiencing such delays, you may be able to avoid this
    by telling the NVIDIA driver to ignore display devices which you know
    are not connected. NOTE: anything attached to a 15 pin VGA connector
    is regarded by the driver as a CRT. "DFP" should only be used to refer
    to flatpanels connected via a DVI port

Offline

#6 2005-06-19 17:04:58

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: startx blanks screen for ~60seconds then loads normally?!

do you have your hostname in /etc/hosts? mine looks like this:

127.0.0.1   localhost.localdomain   localhost animus

X is a networked protocol... when it first sees "I need to connect to 'animus'", it basically tries to resolve that url... which will fail just fine, but after a while... putting your hostname in /etc/hosts will auto-resolve the hostname to the localhost.

Offline

#7 2005-06-20 12:29:45

fdac
Member
From: Brisbane, Australia
Registered: 2005-06-19
Posts: 96

Re: startx blanks screen for ~60seconds then loads normally?!

Thanks for the replies so far.

@phrakture: My /etc/hosts was slightly different, so I changed it to match your syntax:

127.0.0.1   localhost.localdomain    localhost crumpet

Didn't seem to make any difference, unfortunately.

@freakyc:  I then tried your suggestion of

 Option "IgnoreDisplayDevices" "DFP, TV"

This seemed to speed things up a bit, with about a 10-15 second wait between issuing "startx" and seeing the NVidia splash logo.  It also stopped those warning messages popping up in the X log.

I'll now quit X and try the other options suggested by CyberTron.

Cheers
Francis

Offline

#8 2005-06-20 12:47:09

fdac
Member
From: Brisbane, Australia
Registered: 2005-06-19
Posts: 96

Re: startx blanks screen for ~60seconds then loads normally?!

CyberTron,

I tried out the other Nvidia options you suggested but they didn't seem to make a huge difference one way or the other.

A couple brought up new warnings in the X log so I disabled them.

I think the "IgnoreDisplayDevices" option has worked; I'm consistently getting X startup times around 10 seconds now.

I am not expecting lightning fast speeds -  it's a 500MHz Pentium 3, and the GPU is an old GeForce 2 MX with a glorious 64MB RAM. 

However, it still seems a bit on the slow side, compared to how quickly I remember KDE loading up under Mandrake!

I've posted the new conf and log files:
http://web.aanet.com.au/francis/xorg.conf.20Jun2005
http://web.aanet.com.au/francis/Xorg.0.log.20Jun2005

Would appreciate any further thoughts - has anybody else had this problem (and resolved it!) ?

Cheers
Francis

Offline

Board footer

Powered by FluxBB