You are not logged in.

#1 2005-06-20 08:53:08

Skyscraper
Member
Registered: 2005-06-20
Posts: 72

Cannot burn with K3B-0.12-1 and kernel 2.6.11.10-1 ?

Hello smile

Recently (18-19.06.2005) I've upgraded my Archlinux system with the newest packages (almost 400MB). Everything went fine and I had no problems BUT yesterday I tried (several times) to burn an ISO image to CDR and it fails all the time after a few seconds. Here is the recording log:

System
-----------------------
K3b Version: 0.12

KDE Version: 3.4.1
QT Version:  3.3.4
Kernel:      2.6.11.10-ARCH
Devices
-----------------------
TEAC CD-W516EB 1.0B (/dev/hdb, ) at /mnt/cdrom [CD-R; CD-RW; CD-ROM] [Error] [SAO; TAO; RAW; SAO/R96P; SAO/R96R; RAW/R16; RAW/R96P; RAW/R96R]

Used versions
-----------------------
cdrecord: 2.1

cdrecord
-----------------------
/usr/bin/cdrecord: Warning: Running on Linux-2.6.11.10-ARCH
/usr/bin/cdrecord: There are unsettled issues with Linux-2.5 and newer.
/usr/bin/cdrecord: If you have unexpected problems, please try Linux-2.4 or Solaris.
/usr/bin/cdrecord: Cannot allocate memory. WARNING: Cannot do mlockall(2).
/usr/bin/cdrecord: WARNING: This causes a high risk for buffer underruns.
/usr/bin/cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
/usr/bin/cdrecord: Permission denied. WARNING: Cannot set priority using setpriority().
/usr/bin/cdrecord: WARNING: This causes a high risk for buffer underruns.
scsidev: '/dev/hdb'
devname: '/dev/hdb'
scsibus: -2 target: -2 lun: -2
Warning: Open by 'devname' is unintentional and not supported.
Linux sg driver version: 3.5.27
/usr/bin/cdrecord: Warning: using inofficial libscg transport code version (warly-scsi-linux-sg.c-1.83 '@(#)scsi-linux-sg.c 1.83 04/05/20 Copyright 1997 J. Schilling').
SCSI buffer size: 64512
Cdrecord-Clone 2.01 (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
TOC Type: 1 = CD-ROM
Using libscg version 'schily-0.8'.
Driveropts: 'burnfree'
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'TEAC    '
Identifikation : 'CD-W516EB       '
Revision       : '1.0B'
Device seems to be: Generic mmc CD-RW.
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC SWABAUDIO BURNFREE
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P RAW/R96R
Drive buf size : 1674624 = 1635 KB
FIFO size      : 4194304 = 4096 KB
/usr/bin/cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
/usr/bin/cdrecord: Permission denied. WARNING: Cannot set priority using setpriority().
/usr/bin/cdrecord: WARNING: This causes a high risk for buffer underruns.
Track 01: data   693 MB
Total size:      797 MB (78:57.69) = 355327 sectors
Lout start:      797 MB (78:59/52) = 355327 sectors
Current Secsize: 2048
ATIP info from disk:
  Indicated writing power: 6
  Is not unrestricted
  Is not erasable
  Disk sub type: Medium Type B, low Beta category (B-) (4)
  ATIP start of lead in:  -11625 (97:27/00)
  ATIP start of lead out: 359849 (79:59/74)
Disk type:    unknown dye (old id code)
Manuf. index: 81
Manufacturer: ILLEGAL OLD CODE: Old Ritek Co.???
Blocks total: 359849 Blocks current: 359849 Blocks remaining: 4522
Starting to write CD/DVD at speed 12 in dummy SAO mode for single session.
Last chance to quit, starting dummy write in 2 seconds.
   1 seconds.
   0 seconds.
Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
BURN-Free is OFF.
Turning BURN-Free on
Sending CUE sheet...
/usr/bin/cdrecord: WARNING: Drive returns wrong startsec (0) using -150
Writing pregap for track 1 at -150
Starting new track at sector: 0
Track 01:    0 of  693 MB written.
/usr/bin/cdrecord: Success. write_g1: scsi sendcmd: no error
CDB:  2A 00 00 00 00 3E 00 00 1F 00
status: 0x1 (GOOD STATUS)
cmd finished after 0.057s timeout 200s
/usr/bin/cdrecord: A write error occured.
/usr/bin/cdrecord: Please properly read the error message above.
write track data: error after 126976 bytes
Writing  time:   19.984s
Average write speed 237.5x.
Fixating...
WARNING: Some drives don't like fixation in dummy mode.
Fixating time:    3.294s
/usr/bin/cdrecord: fifo had 66 puts and 3 gets.
/usr/bin/cdrecord: fifo was 0 times empty and 1 times full, min fill was 96%.

cdrecord command:
-----------------------
/usr/bin/cdrecord -v gracetime=2 dev=/dev/hdb speed=12 -dao -dummy driveropts=burnfree -data /home/jancio/temp

and /etc/fstab if it is needed:

# /etc/fstab: static file system information
# <file system>        <dir>         <type>    <options>          <dump> <pass>
none                   /dev/pts      devpts    defaults            0      0
#none                   /dev/shm      tmpfs     defaults            0      0
#tmpfs                  /tmp          tmpfs     defaults            0      0
usbfs                  /proc/bus/usb usbfs     defaults            0      0

/dev/hdb     /mnt/cdrom   iso9660   ro,user,noauto,unhide   0      0
#/dev/cdroms/cdrom0     /mnt/dvd  udf       ro,user,noauto,unhide   0      0
/dev/floppy/0          /mnt/fl   vfat      user,noauto             0      0
/dev/discs/disc0/part5 / reiserfs defaults 0 0

After upgrading the system I Was still using my own kernel 2.6.10.5 and there was the same problem, that's why I've decided to change to the newest ARCH one. I did the same with DEVFS. I've changed it to UDEV. I even tried to downgrade the K3B and cdrtools to earlier versions - no effect hmm

What happend?
maybe these lines in fstab

#none                   /dev/shm      tmpfs     defaults            0      0
#tmpfs                  /tmp          tmpfs     defaults            0      0

should be unhashed ?
I'm even thinkig about going back to kernel 2.4.30 but there were no problems with 2.6.x.x series recently... sad

Thank You for Your help !
Best regards smile

Offline

#2 2005-06-20 09:38:38

Skyscraper
Member
Registered: 2005-06-20
Posts: 72

Re: Cannot burn with K3B-0.12-1 and kernel 2.6.11.10-1 ?

I forgot. I have udev-058-4 installed if it means something smile

Offline

#3 2005-06-20 09:56:48

Karma XXL
Member
From: Budapest, Hungary
Registered: 2005-06-13
Posts: 91

Re: Cannot burn with K3B-0.12-1 and kernel 2.6.11.10-1 ?

I think those lines in your /etc/fstab should be enabled, but IMO that's not the source of the problem. Enable them anyway...

Did you try burning as root?
Are you sure that the disc isn't bad? Try writing an RW disc, just in case.


Ailen:
Kernel: Linux 2.6.14-rc4-ck1 #1 PREEMPT
Built on: Mon Oct 17 14:51:37 CEST 2005
Hardware: Mobile AMD Sempron(tm) Processor 2800+ AuthenticAMD
WM: E17 snapshot 20051016

Offline

#4 2005-06-20 10:07:41

Skyscraper
Member
Registered: 2005-06-20
Posts: 72

Re: Cannot burn with K3B-0.12-1 and kernel 2.6.11.10-1 ?

Karma XXL wrote:

I think those lines in your /etc/fstab should be enabled, but IMO that's not the source of the problem. Enable them anyway...

I disabled these lines in the past when i had problems with to little temporary space or something like that. I don't even remember what was it smile but after disabling everything is fine.

Karma XXL wrote:

Did you try burning as root?
Are you sure that the disc isn't bad? Try writing an RW disc, just in case.

Yes I tried as root. Same problem. After a few seconds K3B is closing session and says that i should try burning with TAO hmm (even when I'm doing it).
And i tried with several different CDRs. I'm doing a simulation to not to loose CDRs wink

Offline

#5 2005-06-20 10:54:25

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,432
Website

Re: Cannot burn with K3B-0.12-1 and kernel 2.6.11.10-1 ?

Karma XXL wrote:

I think those lines in your /etc/fstab should be enabled, but IMO that's not the source of the problem. Enable them anyway...

bad advice! they're disabled for good reason

Offline

#6 2005-06-20 11:06:18

Skyscraper
Member
Registered: 2005-06-20
Posts: 72

Re: Cannot burn with K3B-0.12-1 and kernel 2.6.11.10-1 ?

maybe there is something wrong with UDEV? I've just downgraded to udev-056-1 - the same problem. Maybe udev-054-1?
what a Sh...t .. hmm

Offline

#7 2005-06-20 14:49:26

Skyscraper
Member
Registered: 2005-06-20
Posts: 72

Re: Cannot burn with K3B-0.12-1 and kernel 2.6.11.10-1 ?

Well, I've just noticed strange thing.
I had my HDD and CDRW on the same IDE controller (hda, hdb) so I moved CDRW to secondary slave (hdd) and guess what. I can burn more data on CD ! I was happy until... until I've noticed that it is only maximum 7MB !! I can't burn no more.
Mmm what do You think about it? It seems like it could be a buffer underrun problem. But how to solve it? Any ideas?
Oh and my hardware is OK - I checked it in Windows XP and it went fine even on 1 controller.

I'll be grateful for any ideas smile

Offline

#8 2005-06-20 16:21:38

Skyscraper
Member
Registered: 2005-06-20
Posts: 72

Re: Cannot burn with K3B-0.12-1 and kernel 2.6.11.10-1 ?

Skyscraper: - Anybody?
Skyscraper: - OK, I will help You smile
Skyscraper: - Thank You smile
Skyscraper is helping himself wink
...

well It's working now smile
And here is the answer http://bbs.archlinux.org/viewtopic.php?t=12071 (thanks lanrat)
OPTIONS="last_rule"      - was the key added to the end of the line in...
/etc/udev/rules.d/udev.rules

# permissions for IDE CD devices
BUS="ide", KERNEL="hd[a-z]", SYSFS{removable}="1", PROGRAM="/bin/cat /proc/ide/%k/media", RESULT="cdrom*", NAME="%k", GROUP="optical", OPTIONS="last_rule"

smile thank You, thank You... no problem wink

Offline

#9 2005-06-20 18:32:06

Karma XXL
Member
From: Budapest, Hungary
Registered: 2005-06-13
Posts: 91

Re: Cannot burn with K3B-0.12-1 and kernel 2.6.11.10-1 ?

dibblethewrecker wrote:

Bad advice! they're disabled for good reason

Sorry... Could you explain what that reason is? Low memory?


Ailen:
Kernel: Linux 2.6.14-rc4-ck1 #1 PREEMPT
Built on: Mon Oct 17 14:51:37 CEST 2005
Hardware: Mobile AMD Sempron(tm) Processor 2800+ AuthenticAMD
WM: E17 snapshot 20051016

Offline

#10 2005-06-20 23:40:51

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,432
Website

Re: Cannot burn with K3B-0.12-1 and kernel 2.6.11.10-1 ?

Skyscraper wrote:

Skyscraper: - Anybody?
Skyscraper: - OK, I will help You smile
Skyscraper: - Thank You smile
Skyscraper is helping himself wink

smile thank You, thank You... no problem wink

Um, no-one is going to think this is funny, they'll just ignore you in the future but you figured it out - well done, I'm genuinely pleased for you.

Karma XXL - I don't know what the reason is but it is fixed now - which is the main thing

Offline

#11 2005-06-21 00:07:06

khazdar
Member
From: ohio
Registered: 2003-11-06
Posts: 123

Re: Cannot burn with K3B-0.12-1 and kernel 2.6.11.10-1 ?

I cannot burn in K3b either. Just sits there saying 'preparing data'. I hit cancel and try to kill the process, but k3b stays open. Have to relog to get rid of it. any ideas ?




UPDATE - went back to previous package, 11.24-2, and it burns fine.

Offline

Board footer

Powered by FluxBB