You are not logged in.

#1 2011-12-23 21:50:36

Alber
Member
From: Spain - España
Registered: 2011-11-11
Posts: 174

[Solved] Two screens in a monitor

Hi

At boot I get to a tty.
Once in my session, I do startx to Openbox.
The screen resolution isn't the best, so I use xrandr
   output LVDS1 1280x1024* (max resolution)
   output VGA01 1920x1080 (max resolution)
To get better resolution I turn on VGA01
   xrandr --output VGA01 --mode 1920x1080
Then I have two screen in one monitor so I turn off one.
   xrandr --output LVDS1 --off
How I don't want write it every time I put it openbox's autostart.

It's solved, but it's a poor solution. I think that it would be done by xorg.conf
Any ideas?

---------------------------------------------------
Sorry if I don't understand you right. I'm no English speaker.
Thankyou every one for you time.

Last edited by Alber (2011-12-30 12:35:25)

Offline

#2 2011-12-23 21:59:58

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: [Solved] Two screens in a monitor

Have you tried adding it to your .xinitrc?

Not sure what are you getting this problem. What kind of screen is it - notebook?

Last edited by karol (2011-12-23 22:01:35)

Offline

#3 2011-12-23 22:17:35

Alber
Member
From: Spain - España
Registered: 2011-11-11
Posts: 174

Re: [Solved] Two screens in a monitor

It's not a notebook. A normal screen.

I have a similar problem with Fedora. Fedora 14 is allright. But Fedora 15 and 16, is similar to this problem. I get at the graphic login with two screens, but one is at the left, and it's out my monitor (with the graphic login, I drag it with alt+click mouse).
When get a console I managed it with xrandr.

I'll try .xinitrc.

Maybe important, at tty, in my session before X, the screen no fill up the monitor.
But I think that X must get the good one, I want to know how to tell X "get this one, no that", and no change it afterwards with xrandr.

Last edited by Alber (2011-12-23 23:10:47)

Offline

#4 2011-12-30 12:33:51

Alber
Member
From: Spain - España
Registered: 2011-11-11
Posts: 174

Re: [Solved] Two screens in a monitor

Hi

Two solutions.
* Using .xinitrc (pointed by Karol), I think it is better than using openbox's autostart. Because the resolution is changed before loading the window manager.

* Another, is using xorg.conf. This solution is more static and difficult to change configuration afterwards. This solution is based in disabling (some scripts could enable again) or ignoring outputs.
Option    "Enable" "false"
Option    "Ignore" "true"

My xorg.conf. Would be helpful to someone:

	Section "Device"
	        Identifier      "GMA 3150"
	        Driver          "intel"
	        Option          "monitor-VGA1" "Alta"
	        Option          "monitor-LVDS1" "Baja"
	EndSection
	
	Section "Monitor"
	        Identifier      "Alta"
	        Option          "PreferredMode" "1920x1080"
	EndSection
	
	Section "Monitor"
	        Identifier      "Baja"
	        #Option          "Enable" "false"
	        Option          "Ignore" "true"
	EndSection
	
	Section "Screen"
	        Identifier      "Default Screen"
	        Device          "GMA 3150"
	        Monitor         "Alta"
	        DefaultDepth    24

ref. links:
http://intellinuxgraphics.org/dualhead.html

Thankyou everyone by your time.

Last edited by Alber (2012-01-25 17:22:57)

Offline

Board footer

Powered by FluxBB