You are not logged in.

#1 2011-12-26 16:43:30

From: Cheyenne, WY
Registered: 2007-10-05
Posts: 101

[Solved] Cannot open display :0.0

Yup, the xhost thing fixed it (although I had to use localhost rather than local).  Thanks!

I sometimes use secondary accounts by way of profile control, that is if I want to try programs with different settings I'll su to a different shell account.  Up until this week when I upgraded to the latest everything, I could open an xterm, su to my secondary login, and start firefox or whatever just fine.

Now suddenly I can't do that; I get two lines of
No protocol specified

and then
Error: Cannot open display:  :0.0

And one more
No protocol specified

I'm sure it's a permissions issue, and probably fixes a security hole from previous versions; root can still do this but not my non-root accounts.  Any idea which device files I need to modify to allow account B to open a window on account A's desktop?

Last edited by WyoPBS (2011-12-29 04:15:59)

Peter B. Steiger
Cheyenne, WY


#2 2011-12-26 18:03:52

From: New York
Registered: 2009-09-14
Posts: 65

Re: [Solved] Cannot open display :0.0


xhost +local:

in your primary account.

Also check these topics:


Board footer

Powered by FluxBB