You are not logged in.

#1 2012-01-02 17:41:24

JJ.Eastwood
Member
Registered: 2011-05-26
Posts: 17

[SOLVED] XPCOMGlueLoad Error with Firefox and Thunderbird

When I update xcb-util from 0.3.6-2 to 0.3.8-1 I get the following error when starting firefox or (in this case) thunderbird:

XPCOMGlueLoad error for file /usr/lib/thunderbird/libxpcom.so:
libxcb-aux.so.0: cannot open shared object file: No such file or directory
Couldn't load XPCOM.

There is no libxcb-aux-so.0 in my system but if I downgrade back to 0.3.6-2 then it installs in /usr/lib/libxcb-aux.so.0. If I copy this file and then update and paste it back in then thunderbird and firefox start fine with no errors but that doesn't feel like the proper way of doing things and it might lead to conflicts.

I wouldn't mind that much but I can't upgrade things like xf86-video-intel without the newer version of xcb-util.

Any help would be appreciated.

Last edited by JJ.Eastwood (2012-01-02 18:05:08)

Offline

#2 2012-01-02 17:46:40

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [SOLVED] XPCOMGlueLoad Error with Firefox and Thunderbird

be sure you are fully up to date and everything will be all right.

you got problems like that because you partially updated some packages.


Give what you have. To someone, it may be better than you dare to think.

Offline

#3 2012-01-02 18:02:05

JJ.Eastwood
Member
Registered: 2011-05-26
Posts: 17

Re: [SOLVED] XPCOMGlueLoad Error with Firefox and Thunderbird

Yep my bad. I had updated everything but I made it skip xcb-util and xf86-video-intel so that I could run thunderbird, but then for some reason when I updated xcb-util just to check the problem was still there it didn't update libxcb. Could have been my mirrors were out of date. Thanks for your help.

Offline

#4 2012-01-02 18:05:03

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [SOLVED] XPCOMGlueLoad Error with Firefox and Thunderbird

do not skip xcb-util or any other package. just fully update everything and no, is not about libxcb is all about xcb-util

thunderbird links to startup-notification, which links to new xcb-util.

if you use a xf86-video-intel from aur, you must recompile after fully updating your system

Last edited by wonder (2012-01-02 18:05:28)


Give what you have. To someone, it may be better than you dare to think.

Offline

Board footer

Powered by FluxBB