You are not logged in.

#1 2012-01-07 23:47:13

Registered: 2012-01-02
Posts: 10

[Solved] Inconsistency detected by ../sysdeps/x86_64/...

I just did a fresh install of Arch, ran "pacman -Syy" and it returned the error:
Inconsistency detected by ../sysdeps/x86_64/dl-machine.h: 466: elf_machine_rela_relative: Assertion `((reloc->r_info) & 0xffffffff) == 8' failed!
Any Ideas? The only relevant thread I found was this one in German (which I don't speak):

Last edited by Thal3s (2012-01-08 00:19:48)


#2 2012-01-08 00:18:11

Registered: 2012-01-02
Posts: 10

Re: [Solved] Inconsistency detected by ../sysdeps/x86_64/...

People of the future:
I think I found a solution. Make sure your internet connection is configured properly (and connected) and restart your system. That seemed to be what fixed the error for me. My internet wasn't connected when I started the system. I got it connected (and restarted the network daemon) but when I ran pacman i got the above error until I rebooted.

Last edited by Thal3s (2012-01-08 00:21:08)


#3 2013-03-28 02:13:43

From: Toronto, Canada
Registered: 2011-04-26
Posts: 71

Re: [Solved] Inconsistency detected by ../sysdeps/x86_64/...

I had this same problem after a fresh install. Barely had anything installed apart from xorg, awesome, xf86-video-ati, luakit, chromium, vim, and deja-fonts. I reinstalled all packages (see: and it seems to have fixed it. Not sure if this is hardware related or not, I haven't had a chance to test yet. hope this helps someone.


#4 2015-11-17 21:48:39

Registered: 2015-10-05
Posts: 1

Re: [Solved] Inconsistency detected by ../sysdeps/x86_64/...

four year later, i've encountered the same problem, but at line 497...
"Inconsistency detected by ../sysdeps/x86_64/dl-machine.h: 497: elf_machine_rela_relative: Assertion "

I'm actually on skylake Pentium G4400 architechture (in prevision to buy an i5 6600),
hardware support is enabled to avoid some bugs with integrated gpu, for now, i'm forced to use ati radeon hd4550 to use two hdmi/dvi screen.

I have not the bug, when i don't use the "rotate" function of xrandr
Seem's my ati gpu make my wm to be extremly slow in horizontal orientation, and impossible (but it works) in vertical.

What can we think from that :
you have ati, me too.. ?
or may be a xorg origin

note: i only post my modest contribution to future people smile
i hope kernel 4.3 will fix the issue !


#5 2015-11-17 21:53:34

Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 6,395

Re: [Solved] Inconsistency detected by ../sysdeps/x86_64/...

This is a very old thread, I think it's high time it was put out of it's misery..

Please don't necrobump, mtroy.


Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Making lemonade from lemons since 2015.


Board footer

Powered by FluxBB