You are not logged in.

#1 2012-01-08 03:16:22

Registered: 2008-09-15
Posts: 11

[SOLVED] Problem with murmur after upgrading to 1.2.3-4

I've been running Murmur on my server for a long time without problems. The last version I had running was 1.2.3-3. After upgrading to 1.2.3-4, the already-running murmurd process crashed after a while (some hours after the upgrade, after constant use) and I'm unable to restart it. The message I get is:

:: Starting murmur                                                                                          [BUSY] 
<W>2012-01-07 22:06:11.133 Initializing settings from /etc/murmur.ini (basepath /etc)
<W>2012-01-07 22:06:11.134 OpenSSL: OpenSSL 1.0.0f 4 Jan 2012
<W>2012-01-07 22:06:11.134 SSL: Adding recommended CA StartCom Certification Authority
<W>2012-01-07 22:06:11.134 SSL: Adding recommended CA AAA Certificate Services
<W>2012-01-07 22:06:11.135 SSL: Adding recommended CA UTN-USERFirst-Client Authentication and Email
<C>2012-01-07 22:06:11.135 Successfully switched to uid 1007
<F>2012-01-07 22:06:11.230 ServerDB: Failed initialization: unable to open database file Error opening database

and in murmur.log nothing gets written. Downgrading to 1.2.3-3 works, but I thought I'd look for the cause of the problem.

After poking around a bit, I noticed that my murmur database (/var/lib/murmur/murmur.sqlite) belongs to a nonexistent user with a UID of 86 and a GID of 86, as well as the whole /var/log/murmur/ directory. I also noticed that a new murmur user and group with UID and GID of 1007 and 1000 exists on the system now. It seems that running:

sudo chown -R murmur:murmur /var/lib/murmur/ /var/log/murmur/ 

fixes the problem. Perhaps the update deleted my pre-existing murmur user and group and recreated them?

Edit: Guess I should mark this as [SOLVED].

Edit edit:
Also turns out the whole /var/lib/murmur/ directory has to belong to murmur, not just the sqlite file.

Last edited by n17ikh (2012-01-08 03:22:39)


#2 2012-01-08 11:34:50

From: Germany
Registered: 2010-05-13
Posts: 377

Re: [SOLVED] Problem with murmur after upgrading to 1.2.3-4

I had the same problem and fixed it like you. wink


#3 2012-01-09 13:05:45

Registered: 2011-08-19
Posts: 97

Re: [SOLVED] Problem with murmur after upgrading to 1.2.3-4

Thanks for posting.  Resolved my issue too.


Board footer

Powered by FluxBB