You are not logged in.

#1 2012-01-08 11:16:46

KlavKalashj
Member
Registered: 2008-10-09
Posts: 359

Linux 3.2 sound plays through HDMI and laptop speakers simultaneously

As topic says, laptop speakers is not muted when activating sound through HDMI. Downgrading to 3.1 solves the problem. The laptop is an Asus UL30a.

Last edited by KlavKalashj (2012-01-20 08:52:49)

Offline

#2 2012-01-20 15:46:00

natestar13
Member
From: Tampa, FL
Registered: 2012-01-16
Posts: 54

Re: Linux 3.2 sound plays through HDMI and laptop speakers simultaneously

Are you using Alsa or PulseAudio to configure your audio settings?  The Arch Wiki has extensive tips for both.  You might need to set a default audio output

https://wiki.archlinux.org/index.php/Ad … chitecture

https://wiki.archlinux.org/index.php/Pulseaudio


Machine:  Gateway NV55C Dual core Intel Pentium CPU P6100

Offline

#3 2012-01-20 18:18:57

KlavKalashj
Member
Registered: 2008-10-09
Posts: 359

Re: Linux 3.2 sound plays through HDMI and laptop speakers simultaneously

natestar13 wrote:

Are you using Alsa or PulseAudio to configure your audio settings?  The Arch Wiki has extensive tips for both.  You might need to set a default audio output

https://wiki.archlinux.org/index.php/Ad … chitecture

https://wiki.archlinux.org/index.php/Pulseaudio

I am using Pulse Audio (and KDE). It's all correctly setup, it has been working for several months and it works if I downgrade kernel to 3.1, so it's a regression with the new kernel. Also, if any mods are reading this, maybe thread should be moved since 3.2 is out of testing.

Edit: It's quite weird. If I go to KDE sound settings and change them around a couple of times, after a while it works like it should. There is no consistency in this and I have no idea how to troubleshoot tongue

Edit2: Could this be related? I know it's for Nvidia cards, but in the first comment he mentions hda_intel.chttps://bugzilla.kernel.org/show_bug.cgi?id=42567 I should probably have mentioned in the first post that my laptop is all Intel:

oscar@arch-laptop: [~] >>> lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

Last edited by KlavKalashj (2012-01-20 18:35:26)

Offline

Board footer

Powered by FluxBB