You are not logged in.

#1 2012-01-15 11:22:27

Registered: 2008-07-23
Posts: 11

Installing on G4 errors

It wasn't terribly hard to figure out but in case someone else comes across this problem...

I was having issues with the latest archppc .iso's so I got … pc-ftp.iso which worked great except that it's a bit dated now.  It wouldn't work using the cd as source so I restarted install after editing /arch/setup, /etc/pacman.conf and /etc/pacman.d/mirrorlist to replace all instances of to  Otherwise downloads just barely work. 

Then I ran into another little problem installing the kernel.  Setup offers kernel26-pmac or kernel26-pmac64 which are both outdated now.  Back to editing /arch/setup with nano ctl+w to find "kernel26" and ctl+k to cut the line then ctl+u twice to put it back in and add one to work with.  Edited the first line from kernel26-pmac to linux-pmac and further on that line changed vmlinux26 to vmlinux3.1.

At the next step the bootloader install fails complaining that I need to provide a line ofboot=<ofboot path to /dev/hda2>.  Through some T&E I found some lines from another yaboot.conf and some info from Ubuntu.  I managed to reboot back in to the live Cd, chrooted, edited files and got mkofboot to complete happily.

Rebooted to the error unable to determine major minor number of /dev/hda4.  Re-chrooted with live CD to reinstall yaboot changed hda4 to sda4 with the same error except /dev/sda4.

At every step I thought this was going to be a success and it would be great to have an ArchPPC that worked but I think I'm beaten and headed back to DebianPPC which never fails me at install but is always a bit behind in the latest and greatest.

I'd love any suggestions to help fix the Arch side.  I think I'll leave the HD with failed Arch in there and try Debian on a different HD so that I might enjoy a little success for a change.  Then come back to Arch if I or someone can think of any solutions.

Last edited by curlynostrill (2012-01-16 11:16:07)


#2 2012-02-12 00:59:22

Registered: 2012-01-11
Posts: 32

Re: Installing on G4 errors


I did encounter some of the problems you describe, and I have posted solutions here: … 2#p1056272
Hope this helps



Board footer

Powered by FluxBB