You are not logged in.

#1 2012-01-17 20:57:50

kjozsa
Member
Registered: 2008-06-05
Posts: 110

[SOLVED] USB mouse problems since 3.1.9

Hi,

I'm running a full uptodate arch64 on my HP 8560w notebook. My mouse is a Logitech MX Anywhere (2 months old, perfect condition), and I'm also using my touchpad occasionally.

Since about upgrading from kernel 3.1.8 to 3.1.9, I met two USB related problems. First, the 2 USB ports on the right side of my notebook stopped working completely. Second, plugging my mouse's receiver into one of the two slots on the left side, any mouse movement has about 50% chance to not move the mouse at all. In that case, it does not matter how long I try to move the mouse continuously, it will not. Stopping for a moment (milliseconds) and trying again moves it fine.

While this happens, dmesg has the following repeating messages:

[  347.420874] ehci_hcd 0000:00:1d.0: BAR 0: set to [mem 0xd1528000-0xd15283ff] (PCI address [0xd1528000-0xd15283ff])
[  347.420919] ehci_hcd 0000:00:1d.0: restoring config space at offset 0xf (was 0x100, writing 0x10a)
[  347.420951] ehci_hcd 0000:00:1d.0: restoring config space at offset 0x1 (was 0x2900000, writing 0x2900002)
[  347.420991] ehci_hcd 0000:00:1d.0: PME# disabled
[  347.421004] ehci_hcd 0000:00:1d.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[  347.421013] ehci_hcd 0000:00:1d.0: setting latency timer to 64
[  354.515990] ehci_hcd 0000:00:1d.0: PCI INT A disabled
[  354.516067] ehci_hcd 0000:00:1d.0: PME# enabled
[  378.381450] ehci_hcd 0000:00:1d.0: BAR 0: set to [mem 0xd1528000-0xd15283ff] (PCI address [0xd1528000-0xd15283ff])
[  378.381486] ehci_hcd 0000:00:1d.0: restoring config space at offset 0xf (was 0x100, writing 0x10a)
[  378.381528] ehci_hcd 0000:00:1d.0: restoring config space at offset 0x1 (was 0x2900000, writing 0x2900002)
[  378.381581] ehci_hcd 0000:00:1d.0: PME# disabled
[  378.381602] ehci_hcd 0000:00:1d.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[  378.381615] ehci_hcd 0000:00:1d.0: setting latency timer to 64
[  385.505893] ehci_hcd 0000:00:1d.0: PCI INT A disabled
[  385.505971] ehci_hcd 0000:00:1d.0: PME# enabled
[  386.052383] ehci_hcd 0000:00:1d.0: BAR 0: set to [mem 0xd1528000-0xd15283ff] (PCI address [0xd1528000-0xd15283ff])
[  386.052419] ehci_hcd 0000:00:1d.0: restoring config space at offset 0xf (was 0x100, writing 0x10a)
[  386.052460] ehci_hcd 0000:00:1d.0: restoring config space at offset 0x1 (was 0x2900000, writing 0x2900002)
[  386.052513] ehci_hcd 0000:00:1d.0: PME# disabled
[  386.052533] ehci_hcd 0000:00:1d.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[  386.052546] ehci_hcd 0000:00:1d.0: setting latency timer to 64
[  392.507103] ehci_hcd 0000:00:1d.0: PCI INT A disabled
[  392.507181] ehci_hcd 0000:00:1d.0: PME# enabled
[  448.123448] ehci_hcd 0000:00:1d.0: BAR 0: set to [mem 0xd1528000-0xd15283ff] (PCI address [0xd1528000-0xd15283ff])
[  448.123488] ehci_hcd 0000:00:1d.0: restoring config space at offset 0xf (was 0x100, writing 0x10a)
[  448.123531] ehci_hcd 0000:00:1d.0: restoring config space at offset 0x1 (was 0x2900000, writing 0x2900002)
[  448.123591] ehci_hcd 0000:00:1d.0: PME# disabled
[  448.123613] ehci_hcd 0000:00:1d.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[  448.123626] ehci_hcd 0000:00:1d.0: setting latency timer to 64

I'm not sure where to turn to with this.. any ideas?
Also, is it possible to temporarily downgrade my kernel to the previous kernel to examine if it's really causing the problem?

Last edited by kjozsa (2012-01-17 21:35:43)

Offline

#2 2012-01-17 21:08:32

kjozsa
Member
Registered: 2008-06-05
Posts: 110

Re: [SOLVED] USB mouse problems since 3.1.9

hmm maybe it's that one: https://bbs.archlinux.org/viewtopic.php?id=114077, but I really wonder how it appeared right now on my arch?

Last edited by kjozsa (2012-01-17 21:09:01)

Offline

#3 2012-01-17 21:36:57

kjozsa
Member
Registered: 2008-06-05
Posts: 110

Re: [SOLVED] USB mouse problems since 3.1.9

ok looks it's the same issue with the same resolution, setting CONTROL_USB_AUTOSUSPEND="1" in /etc/laptop-mode/conf.d/usb-autosuspend.conf seems to get this issue resolved completely.

The only remaining question is how this old issue appeared right now?

Offline

Board footer

Powered by FluxBB