You are not logged in.

#1 2012-01-19 16:05:41

Evilandi666
Member
Registered: 2010-10-28
Posts: 105

HDMI Audio broken since kernel 3.2.1 on nvidia cards

Hi,

does anyone has the same problem on hdmi audio and nvidia cards since the 3.2.1 kernel upgrade?

Everything is setup fine, everything is unmuted, but hdmi audio output does not work anymore. It worked 5 minutes ago before I upgraded my machine ... hmm.

Hdmi audio is such a pita ..

Edit: Also posted that bug on nvnews, some user reporting it works on debian with 3.2.1.

Last edited by Evilandi666 (2012-01-19 22:55:33)

Offline

#2 2012-01-19 16:21:57

Evilandi666
Member
Registered: 2010-10-28
Posts: 105

Re: HDMI Audio broken since kernel 3.2.1 on nvidia cards

After downgrade to linux 3.1.9 (you need also to downgrade nvidia and lirc), it works fine again...

Offline

#3 2012-01-19 19:50:27

bitcero
Member
Registered: 2011-11-03
Posts: 6

Re: HDMI Audio broken since kernel 3.2.1 on nvidia cards

Same Here,

Nvidia Geforce GTX 460
Board Asus P6t Deluxe

Audio Lost after last update of Kernel and Nvidia driver

Everything seems ok  kmix,  pavucontrol, aplay -l   .....    but no sound.

Last edited by bitcero (2012-01-19 19:50:48)

Offline

#4 2012-01-19 20:47:39

nzeh
Member
Registered: 2011-12-20
Posts: 3

Re: HDMI Audio broken since kernel 3.2.1 on nvidia cards

I am not using any HDMI audio output.  However, I am also running an NVIDIA GeForce GTX 460 on a dual-Opteron Asus board.  After the upgrade, my X server failed to start, saying something about not being able to initialize the GPU.  The downgrade solved the problem.

Offline

#5 2012-01-20 13:06:25

Evilandi666
Member
Registered: 2010-10-28
Posts: 105

Re: HDMI Audio broken since kernel 3.2.1 on nvidia cards

Here is the official bug report: https://bugzilla.kernel.org/show_bug.cgi?id=42567

Seems to be some problem with alsa's dmix.

Offline

#6 2012-01-22 14:13:17

knedlyk
Member
From: L'viv, Ukraine
Registered: 2009-04-14
Posts: 161
Website

Re: HDMI Audio broken since kernel 3.2.1 on nvidia cards

Same here, Zotac HD id11-E with Nvidia GT218, HDMI output is broken when on kernel 3.2. After downgrading to 3.1.9-2 kernel HDMI works well.

Offline

#7 2012-01-23 20:43:59

knedlyk
Member
From: L'viv, Ukraine
Registered: 2009-04-14
Posts: 161
Website

Re: HDMI Audio broken since kernel 3.2.1 on nvidia cards

Patch released : https://bugzilla.kernel.org/attachment.cgi?id=72174 . Tested, it works. Probably it will be included into the next kernel release.

Offline

#8 2012-01-26 11:48:08

Jonhoo
Member
Registered: 2009-05-23
Posts: 118

Re: HDMI Audio broken since kernel 3.2.1 on nvidia cards

Any chance this patch could be included in the Arch kernel, since the next kernel release is probably quite far off, and this basically ruins audio for those of us using HDMI on nVidia cards?
I realize I could just patch it myself with ABS, but seems like this is something that could benefit quite a few, and since it's already approved upstream, a shortcut wouldn't be too bad?

Offline

#9 2012-01-26 12:37:52

Gusar
Member
Registered: 2009-08-25
Posts: 3,605

Re: HDMI Audio broken since kernel 3.2.1 on nvidia cards

The patch is in 3.2.2, so you won't need to wait long. Edit: Err, scratch that, I thought I saw it in the list for 3.2.2 but I've checked again, it's not there. Oh well, compiling your own kernel it is then. Or open a bug on the bugtracker, see what Arch devs have to say.

Last edited by Gusar (2012-01-26 12:40:42)

Offline

#10 2012-01-26 12:38:47

Jonhoo
Member
Registered: 2009-05-23
Posts: 118

Re: HDMI Audio broken since kernel 3.2.1 on nvidia cards

Ah, great! In that case, never mind smile

Offline

#11 2012-01-26 18:24:15

knedlyk
Member
From: L'viv, Ukraine
Registered: 2009-04-14
Posts: 161
Website

Re: HDMI Audio broken since kernel 3.2.1 on nvidia cards

I filled the bug report https://bugs.archlinux.org/task/28074 , please vote. It is very strange that patch is not included into 3.2.2. I noticed several patches in changelogs from Takashi Iwai, I thought that the patch already sent to upstream. Well, it is easy but it takes long to compile own patched kernel.

Offline

#12 2012-01-26 18:33:17

Gusar
Member
Registered: 2009-08-25
Posts: 3,605

Re: HDMI Audio broken since kernel 3.2.1 on nvidia cards

I think the patch is too new for 3.2.2. Maybe it'll make 3.2.3

Offline

#13 2012-02-15 07:39:58

cleanrock
Member
Registered: 2008-11-17
Posts: 108

Re: HDMI Audio broken since kernel 3.2.1 on nvidia cards

Is HDMI audio working on 3.2.5 ?

Offline

#14 2012-02-15 09:27:23

Gusar
Member
Registered: 2009-08-25
Posts: 3,605

Re: HDMI Audio broken since kernel 3.2.1 on nvidia cards

The patch made 3.2.3, like I predicted it would. So unless there's some other issues as well, it should work now.

Offline

#15 2012-02-25 17:50:01

Zverik
Member
Registered: 2012-02-25
Posts: 1

Re: HDMI Audio broken since kernel 3.2.1 on nvidia cards

I've upgraded to kernel 3.2.7 (from 3.1.7), and HDMI audio stopped working. aplay -l displays HDMI device, but when I play anything via aplay, mplayer2 or xbmc, there is nothing on HDMI, but also there is a loud noise in the laptop speakers.

Last edited by Zverik (2012-02-25 17:50:17)

Offline

#16 2012-02-26 15:41:31

Ralgo
Member
From: Chile
Registered: 2011-09-30
Posts: 13

Re: HDMI Audio broken since kernel 3.2.1 on nvidia cards

Zverik wrote:

I've upgraded to kernel 3.2.7 (from 3.1.7), and HDMI audio stopped working. aplay -l displays HDMI device, but when I play anything via aplay, mplayer2 or xbmc, there is nothing on HDMI, but also there is a loud noise in the laptop speakers.

3.2.7 here, HDMI audio works ok.

Offline

Board footer

Powered by FluxBB