You are not logged in.

#1 2012-01-28 13:44:14

hifi25nl
Member
Registered: 2011-05-07
Posts: 220
Website

KDE 4.8: Back to virtuoso high CPU and akonadi errors....

With the installation of KDE 4.8 virtuoso is back to use most of CPU, also when file indexing is idle (!!).

Akonadi always coherent...error messages like "unable to fetch item" are present in this version also, with the joy of users.

Offline

#2 2012-01-28 15:14:46

Rokixz
Member
From: Šiauliai, Lithuania
Registered: 2007-04-21
Posts: 251
Website

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

4.8 works very fine for me, try to backup your .kde4 directory and start a new desktop, maybe some configs conflicts and that's it.


http://ispconfig.lt - ISPConfig 3 based hosting. Coming Soon!

Offline

#3 2012-01-28 17:59:11

mythus
Member
From: MS Gulf Coast
Registered: 2008-05-15
Posts: 509
Website

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

Agreed. Works fine here as well. Even at first log-in, I didn't have the high CPU usage that virtuoso typically gave. And, akonadi works good as well... the searching/filtering in Dolphin even worked.

I'm thinking you might have some odd config errors. I'd suggest renaming the kde4 directory to .kde4bak and see how it runs for you anew.


Legends of Nor'Ova - role playing community devoted to quality forum-based and table-top role play, home of the Legends of Nor'Ova Core Rule Book and Legends of Nor'Ova: Saga of Ablution steam punk like forum based RPG

Offline

#4 2012-01-28 19:13:54

dimitar
Member
Registered: 2011-01-27
Posts: 59

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

I have the same problem. If I start akonadi, virtuoso-t starts consuming 100% CPU. I'm 99% sure, that akonadi is sending data to nepomuk to re-index, because if I remove "Akonadi Nepomuk Feeder" from akonadiconsole, virtuoso-t calms down. I guess, I'll leave it for one night to re-index my emails and contacts, and if it still causes high CPU usage in virtuoso, I'll have to do without the nepomuk indexing.

Offline

#5 2012-01-28 19:52:10

Evert_L
Member
Registered: 2011-09-05
Posts: 2

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

Here the same problem switching Nepomuk off does the trick here, maybe tomorrow I will start a new desktop

Offline

#6 2012-01-28 20:00:25

panosk
Member
From: Athens, Greece
Registered: 2008-10-29
Posts: 241

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

I had the same issue, very high CPU usage even with idle strigi. I turned off and on all related stuff (nepomuk, strigi) in System Settings and now all work as expected. CPU usage is very low even with strigi indexing. Also, this made the search panel in Dolphin active again (before that, all options in it were dimmed).

Hope this helps.

Edit: nope, sorry. This doesn't cure the problem. After a day, the problem reappeared. However, this happened only to my laptop installation. My desktop KDE upgrade seems very smooth so far with no excessive CPU usage so far.

Last edited by panosk (2012-01-30 18:50:01)

Offline

#7 2012-01-28 20:07:50

finex
Member
Registered: 2009-11-02
Posts: 10

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

Even with a new user account with nepomuk disabled, akonadi/mysql use more than 50% of CPU... it is very disappointing :-(

I'll report it on bugs.kde.org

:-(

Offline

#8 2012-01-28 21:26:32

ssri
Member
Registered: 2010-02-16
Posts: 212

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

I had the same problem with the OP with nepomuk's database backend using 90% of my CPU.  My ~/.kde4 harkens back to days of 4.4.x.  I moved it and restarted kde to let it populate a new ~./kde4.  Finally nepokmuk and virtuoso are usually around single or the low double digits.  The highest they reached was 40%.

Offline

#9 2012-01-29 19:51:03

diegoviola
Member
Registered: 2010-12-16
Posts: 124

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

I've had this problem also.

There seems to be a bug report about the issue here:

https://bugs.kde.org/show_bug.cgi?id=289932

After disabling Strigi/Nepomuk and killing the process (virtuoso-t) the problem went away for me.

Offline

#10 2012-01-29 20:41:38

dimitar
Member
Registered: 2011-01-27
Posts: 59

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

Well, killing, enabling/disabling nepomuk, akonadi, virtuoso, etc. did not work in my case sad The only solution, which works for me was to remove the virtuoso database from ~/.kde4/share/apps/nepomuk/repository/main/data/virtuosobackend and let nepomuk re-index my files, emails and contacts. Now everything works, including full-text search in emails, but my tags, keywords, and ratings are gone hmm

Offline

#11 2012-01-29 20:46:36

student975
Member
From: Russian Federation
Registered: 2011-03-05
Posts: 603

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

Yesterday I have deleted ~/.kde4/share/apps/nepomuk also and have not any problems during a day. Moving ~/.kde4 is too strong cure for me smile


"I exist" is the best myth I know..

Offline

#12 2012-01-29 21:03:27

oboedad55
Member
From: Baku
Registered: 2011-04-05
Posts: 389

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

student975 wrote:

Yesterday I have deleted ~/.kde4/share/apps/nepomuk also and have not any problems during a day. Moving ~/.kde4 is too strong cure for me smile

Ditto, worked for me too. Thanks for the suggestion!


Registered Linux user #436067

Offline

#13 2012-01-29 23:05:50

thebelial
Member
Registered: 2012-01-15
Posts: 3

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

Once upgraded from 4.7.4 to 4.8 there was a noticeable slow down with KWin effects. After backing up ~/.kde4 and deleting it to start new, everything is working fine. Low cpu usage, memory usage, and kwin is fast again.

The window resizing seems to be the biggest improvement in speed for kwin that I've noticed over 4.7.x.

Offline

#14 2012-01-30 18:38:18

boast
Member
Registered: 2010-09-28
Posts: 219

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

student975 wrote:

Yesterday I have deleted ~/.kde4/share/apps/nepomuk also and have not any problems during a day. Moving ~/.kde4 is too strong cure for me smile

woohoo! thanks.


Asus M4A785TD-V ;; Phenom II X4 @ 3.9GHz ;; Ripjaws 12GB DDR3-1600 ;; 128GB Samsung 830 ;; MSI GTX460 v2 w/ blob ;; Arch Linux + KDE 4.x

Offline

#15 2012-01-30 20:45:13

diegoviola
Member
Registered: 2010-12-16
Posts: 124

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

There was a virtuoso update recently, so I've re-enabled nepomuk in systemsettings and I don't see virtuoso-t taking 100% CPU anymore.

Maybe the last update fixed something?

Offline

#16 2012-01-30 20:55:49

panosk
Member
From: Athens, Greece
Registered: 2008-10-29
Posts: 241

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

diegoviola wrote:

There was a virtuoso update recently, so I've re-enabled nepomuk in systemsettings and I don't see virtuoso-t taking 100% CPU anymore.

Maybe the last update fixed something?

That's good news. I've checked on the virtuoso site and, although I have no clue about the inner workings, I saw some fixes related to deadlocks and leaks.

Waiting for the package to appear in my mirrors and will upgrade and report back. Thanks.

Offline

#17 2012-01-30 21:57:09

hifi25nl
Member
Registered: 2011-05-07
Posts: 220
Website

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

I also  I have deleted ~/.kde4/share/apps/nepomuk.

Now it seems fine.

The upgrade to new virtuoso did not fix the problem.

Offline

#18 2012-01-30 22:18:51

laloch
Member
Registered: 2010-02-04
Posts: 176

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

For me the problem was that the "Enable Email Indexer" checkbox does nothing. The fulltext mail indexing is always on. You can watch the Akonadi Nepomuk Feeder indexing progress in Akonadi Console. I have *huge* archive of several mailing lists and commit and crash logs (hudreds of thousands of emails), so the indexing took about eight hours. Once finished the Akonadi behavior is back to normal.

Offline

#19 2012-01-31 09:34:38

panosk
Member
From: Athens, Greece
Registered: 2008-10-29
Posts: 241

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

The new virtuoso update doesn't remedy the situation. Deleting the nepomuk database shouldn't be an option because then all tags will be gone. I guess I will have strigi and friends disabled until a fix comes up.

Offline

#20 2012-01-31 09:39:05

oboedad55
Member
From: Baku
Registered: 2011-04-05
Posts: 389

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

panosk wrote:

The new virtuoso update doesn't remedy the situation. Deleting the nepomuk database shouldn't be an option because then all tags will be gone. I guess I will have strigi and friends disabled until a fix comes up.

After I deleted the database it was re-created and the CPU was normal.


Registered Linux user #436067

Offline

#21 2012-02-01 10:53:07

giddie
Member
From: Birmingham, UK
Registered: 2009-03-25
Posts: 87

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

In case anyone else falls into this trap: I discovered that nepomuk was actually using an old directory left over from kdemod days; I was a little surprised when I deleted the database and found that it wasn't recreating it...  I had to tweak /home/dannpg/.kde4/share/config/nepomukserverrc to get it to use ~/.kde4 instead of ~/.kdemod4, and deleted the old database.  It seems to be behaving itself now, so it does seem that these problems are caused by stale databases.

Offline

#22 2012-02-02 15:12:54

vagvaz
Member
From: Chania
Registered: 2011-10-03
Posts: 8

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

I had the same problem with virtuoso, I tried to track the problem and I conclude that the problem was with akonadi. I had a google calendar agent. The calendar had way too many items. I removed them and everything worked just fine.

Offline

#23 2012-02-08 03:51:51

sam
Member
Registered: 2008-05-23
Posts: 82

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

Deleting ~/.kde4/share/apps/nepomuk worked for me as well.  Afterwards, it will rebuild your index (with cpu-frequency around 10%) ; however, you DON'T need to redownload your emails.  The other thing I noticed is if you click on the search icon in the task bar (icon with 4 circles) I only have 6 files in the index, whereas before I had several thousand (each one perhaps corresponding to a single item in my /home/user?).

Offline

#24 2012-02-08 08:31:31

nwoki
Member
Registered: 2010-09-14
Posts: 48

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

Please read this blog post

http://vhanda.in/blog/2012/02/virtuoso-going-crazy-/

and help debug the situation smile

Offline

#25 2012-02-17 14:26:20

diegoviola
Member
Registered: 2010-12-16
Posts: 124

Re: KDE 4.8: Back to virtuoso high CPU and akonadi errors....

This issue seems to have been fixed for KDE 4.8.1?

https://bugs.kde.org/show_bug.cgi?id=289932

Offline

Board footer

Powered by FluxBB