You are not logged in.

#1 2012-02-05 15:46:24

Thralas
Member
Registered: 2007-06-26
Posts: 32

xfce4-panel still shown during VLC fullscreen

Hi,

This is a problem I've been having for a while - whenever I switch to fullscreen display in VLC, my XFCE panel remains visible. mplayer on the other hand works just fine.

Does anyone have an idea how to debug this? I've tried unchecking the hardware acceleration option and switching output driver, but neither seems to help

Offline

#2 2012-02-05 16:07:07

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: xfce4-panel still shown during VLC fullscreen

Do you have the XFCE panel set to "Always on top"?

I do not see this problem with VLC and XFCE on my machine.

Offline

#3 2012-02-05 17:49:29

Jindur
Member
Registered: 2011-09-29
Posts: 184

Re: xfce4-panel still shown during VLC fullscreen

I have the same problem in VLC while in mplayer it's fine.
Also the panel does not have an "always on top" option. (And I didn't modify it in any way anyway, except for adding more quicklaunch icons to it.)

Offline

#4 2012-02-06 00:43:46

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: xfce4-panel still shown during VLC fullscreen

I wasn't booted into Arch earlier.  I see 2 solutions.

1) Did you know that you can press the F key while VLC is playing to make it go fullscreen?
2) Right click on an open area of the lower XFCE panel and choose: Panel > Panel Preferences > and check "Automatically show and hide the panel" for both panel 1 (top) and panel 2 (bottom).

Offline

#5 2012-02-06 15:18:19

Jindur
Member
Registered: 2011-09-29
Posts: 184

Re: xfce4-panel still shown during VLC fullscreen

That's odd, after I rebooted the F key in VLC will hide the xfce4 panel again. Cannot reproduce the problem now. Before this the fullscreen mode would only work correctly in mplayer not in VLC (although I know that it used to work fine in both, as it does again now..).

Offline

#6 2012-02-06 18:51:52

Thralas
Member
Registered: 2007-06-26
Posts: 32

Re: xfce4-panel still shown during VLC fullscreen

David Batson wrote:

I wasn't booted into Arch earlier.  I see 2 solutions.

1) Did you know that you can press the F key while VLC is playing to make it go fullscreen?

That's just a hotkey.

2) Right click on an open area of the lower XFCE panel and choose: Panel > Panel Preferences > and check "Automatically show and hide the panel" for both panel 1 (top) and panel 2 (bottom).

I've been doing that occasionally, but it's pretty annoying.

Offline

#7 2012-02-06 23:51:32

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: xfce4-panel still shown during VLC fullscreen

Thralas wrote:

That's just a hotkey.

True enough, but the effect is different than maximize window.

Offline

#8 2012-02-07 08:19:08

Jindur
Member
Registered: 2011-09-29
Posts: 184

Re: xfce4-panel still shown during VLC fullscreen

F key suddenly glitched again in VLC wink ie keeps showing the xfce4 panel again..

Offline

#9 2012-02-07 13:42:29

acidrain
Member
Registered: 2012-02-06
Posts: 9

Re: xfce4-panel still shown during VLC fullscreen

I have the same problem.  However, it happens only when vlc was maximized before going fullscreen.  If it wasn't maximized, then the panels won't show in fullscreen.  That's why it started glitching again I guess.

Offline

#10 2012-02-08 09:56:52

Thralas
Member
Registered: 2007-06-26
Posts: 32

Re: xfce4-panel still shown during VLC fullscreen

Great find! I cannot reproduce it in eg. xine, so it's still related to the way VLC handles going fullscreen.

Offline

#11 2012-02-15 13:48:38

Thralas
Member
Registered: 2007-06-26
Posts: 32

Re: xfce4-panel still shown during VLC fullscreen

Update: although the issue is pretty specific to VLC due to the way it requests fullscreen mode (using low-level Qt functionality), it doesn't seem to be the cause. Which narrows it down to Qt (used by VLC) or Xfce (xfwm).

I'm not at all familiar with X11/Xfce/Qt, so I've documented it on the bugtracker, hoping someone is able to narrow it down even further: https://bugs.archlinux.org/task/28450

Offline

#12 2012-02-19 10:35:16

rr0hit
Member
From: Kharagpur, West Bengal, India
Registered: 2011-11-12
Posts: 3
Website

Re: xfce4-panel still shown during VLC fullscreen

It has got something to do with Qt on xfce4. A quick work around is to switch to vlc's minimal view (ctrl + H) before switching to full screen.

It is being discussed upstream. http://forum.videolan.org/viewtopic.php?f=13&t=97996

Offline

#13 2012-08-23 18:19:24

jaseemabid
Member
Registered: 2012-08-23
Posts: 1

Re: xfce4-panel still shown during VLC fullscreen

Offline

#14 2013-01-13 11:25:24

TuxLyn
Member
From: United States
Registered: 2011-10-26
Posts: 283

Re: xfce4-panel still shown during VLC fullscreen

You can also set any window in xfce to "Always on Top". This works very well with vlc to be on top of everything else.


::: Using Arch Linux Since October 25, 2011 :::
::: Tutorials: http://distrogeeks.com/ :::

Offline

#15 2013-07-18 01:48:13

TuxLyn
Member
From: United States
Registered: 2011-10-26
Posts: 283

Re: xfce4-panel still shown during VLC fullscreen

Found few more workarounds to have this by default.

1. To have VLC always on top of your panels, tested in XFCE.
Open VLC and go to menu "Tools" => "Preferences" (or press CTRL+P) then switch to "Video" tab on the left options panel. Check "Always on top" and click "Save" button.

2. Turn off subs by default on MKV files.
Open VLC and go to menu "Tools" => "Preferences" (or press CTRL+P) then under "Show settings" select "All" option. Then select "Video" =>"Subtitles/OSD"and check "On Screen Display" option. This will disable mkv subs by default. If you want to manually turn them on durring video playback simply "Right-Click" mouse button on VLC video and look for "Subtitles" menu.


::: Using Arch Linux Since October 25, 2011 :::
::: Tutorials: http://distrogeeks.com/ :::

Offline

#16 2013-09-14 08:01:09

jakub
Member
Registered: 2013-09-14
Posts: 131

Re: xfce4-panel still shown during VLC fullscreen

acidrain wrote:

I have the same problem.  However, it happens only when vlc was maximized before going fullscreen.  If it wasn't maximized, then the panels won't show in fullscreen.  That's why it started glitching again I guess.

Same situation!  Thanks for the tip.


Archlinux on Thinkpad T61

Offline

#17 2014-11-28 04:45:04

Omarbeat
Member
Registered: 2014-11-28
Posts: 1
Website

Re: xfce4-panel still shown during VLC fullscreen

acidrain wrote:

I have the same problem.  However, it happens only when vlc was maximized before going fullscreen.  If it wasn't maximized, then the panels won't show in fullscreen.  That's why it started glitching again I guess.

Thanks for the tip big_smile

Offline

#18 2015-02-01 12:49:05

Thralas
Member
Registered: 2007-06-26
Posts: 32

Re: xfce4-panel still shown during VLC fullscreen

Nearly three years later, a fix appears to have made it to xfwm's git: http://git.xfce.org/xfce/xfwm4/commit/? … ca15eba7fa

The very same panel still overlaps whenever my mouse cursor is on another screen (dual head setup). Sigh.

Offline

#19 2016-02-06 23:04:21

keevitaja
Member
Registered: 2015-08-22
Posts: 17

Re: xfce4-panel still shown during VLC fullscreen

Hello!

I still encounter this problem, but only if i am using a custom VLC skin. Tried with

http://esnooze.deviantart.com/art/UNITY … -583808323
https://www.deviantart.com/art/Audience … -573082041

Any idea how to fix this?

Edit: i also tried a skin that comes with the vlc installation. the same thing, xfce panel (taskbar) does not hide when vlc goes fullscreen.

Last edited by keevitaja (2016-02-08 13:33:43)

Offline

Board footer

Powered by FluxBB