You are not logged in.

#1 2012-02-05 16:43:03

knuckles
Member
Registered: 2008-01-24
Posts: 13

[SOLVED] Unable to locate libpng14.so.14

After full system upgrade and reboot, starting X fails with the following error:

"awesome: error while loading shared libraries: libpng14.so.14: cannot open shared object file: No such file or directory."

If I switch to gnome, I get an identical error:

"gnome-session: error while loading shared libraries: libpng14.so.14: cannot open shared object file: No such file or directory."

When I first attempted to open vim, I also received the same error:

"vim: error while loading shared libraries: libpng14.so.14: cannot open shared object file: No such file or directory."

but was able to fix vim it by uninstalling gvim and installing vim. An uninstall/install for awesome did not help.

Last edited by knuckles (2012-02-05 17:21:42)

Offline

#2 2012-02-05 17:01:40

Hspasta
Member
Registered: 2011-12-24
Posts: 187
Website

Re: [SOLVED] Unable to locate libpng14.so.14

Always check for announcements.

Offline

#3 2012-02-05 17:04:45

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,934

Re: [SOLVED] Unable to locate libpng14.so.14

When you use crud from aur you have to keep it up to date and rebuild when there are bumps to deps it has yourself.
Rebuild cairo-xcb etc. (there are many threads about this btw if you had used the search function)

Also read
https://bbs.archlinux.org/viewtopic.php?id=57205

As for vim/gvim, just -Syu from an up to date mirror and gvim will work just fine, after you have rebuilt cairo-xcb.

Last edited by Mr.Elendig (2012-02-05 17:06:13)


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#4 2012-02-05 17:06:52

knuckles
Member
Registered: 2008-01-24
Posts: 13

Re: [SOLVED] Unable to locate libpng14.so.14

Thanks. I see this..

I am not an Arch noob, but this is over my head. How do I recompile cairo-xcb? Do I use ABS?

Offline

#5 2012-02-05 17:10:37

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,934

Re: [SOLVED] Unable to locate libpng14.so.14

knuckles wrote:

Thanks. I see this..

I am not an Arch noob, but this is over my head. How do I recompile cairo-xcb? Do I use ABS?

Exact same way as you installed it in the first place. (unless you used [archlinuxfr], which you should not use, because it is always full of outdated and broken stuff)

https://wiki.archlinux.org/index.php/AUR

Last edited by Mr.Elendig (2012-02-05 17:10:53)


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#6 2012-02-05 17:21:21

knuckles
Member
Registered: 2008-01-24
Posts: 13

Re: [SOLVED] Unable to locate libpng14.so.14

Hahaha, ok thanks.

For anyone else who has these issues, rebuild cairo-xcb by following these steps: https://wiki.archlinux.org/index.php/AU … g_packages

Offline

#7 2012-02-09 02:39:59

fsckd
Forum Fellow
Registered: 2009-06-15
Posts: 4,173

Re: [SOLVED] Unable to locate libpng14.so.14

Off-topic/hijacking split to its own thread: https://bbs.archlinux.org/viewtopic.php?id=135388


aur S & M :: forum rules :: Community Ethos
Resources for Women, POC, LGBT*, and allies

Offline

#8 2012-05-11 21:15:32

kstenger
Member
From: Uruguay
Registered: 2011-05-09
Posts: 15

Re: [SOLVED] Unable to locate libpng14.so.14

This topic kind of helped me find the final solution with my X server not starting (it was crashing after 2.5 seconds after the last pacman -Syu done past monday).
But in my case I had no packages from aur that were related to cairo.
I checked the news then and read the problem was "libpng and libtiff have required a rebuild of all packages that depend on them" and I supposedly had to rebuild them if they were from aur or otherwise reinstall librsvg.
Even when my packages weren't from aur I thought I could try reinstalling them.

When I tried it with cairo-tee I found it does not exist anymore at the repositories, so I guessed I could try installing cairo... finally it asked to replace cairo-tee and now everything works fine.

I have to say I did a Syu today before trying any of this... so I find strange that pacman -Syu hadn't found by itself that it should have replaced cairo-tee with cairo.

Just thought about telling (a part of) my story in case it is of use to someone else or it can help fix something with the upgrades.

Cheers.

Offline

#9 2012-05-12 19:21:08

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,934

Re: [SOLVED] Unable to locate libpng14.so.14

pacman and the packaging in the repos can not and will not cover all corner cases where people have custom packages from aur. It is just an impossible task.

You will avoid almost all problems by following the advices in this thread though: https://bbs.archlinux.org/viewtopic.php?id=57205


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

Board footer

Powered by FluxBB