You are not logged in.

#1 2012-02-14 20:31:51

LordOfInsomnia
Member
Registered: 2011-10-13
Posts: 69

[SOLVED]Completely disable ati hdmi audio

Since last update of kernel I have problems with my sound.

I have Audigy SE, sound card on motherboard is disabled. But my Ati 4850 (with open source drivers) gives me a headache.
It has a sound card which I cannot disable.

I have tried
this
https://wiki.archlinux.org/index.php/Al … on_Startup

file /etc/asound.conf added this

ctl.dmixer {
    type hw
    card CA0106
}

this
http://www.thinkdigit.com/forum/856740-post4.html

in file /etc/modprobe.d/alsa-base I have added

options snd_ca0106 index=0
options snd_hda_intel index=1

this
http://www.thinkdigit.com/forum/857294-post8.html

in file /etc/modprobe.d/blacklist I have added

blacklist snd_hda_intel

Before update intervention was simple

/boot/grub/menu.lst

kernel /vmlinuz-linux root=/dev/sda6 ro radeon.audio=0

I added "radeon.audio=0" and sound problem was gone, but this tweak does not work any more...

I want to completely disable ati audio driver, does anybody knows how?

Thanks.

Last edited by LordOfInsomnia (2012-02-14 21:12:56)

Offline

#2 2012-02-14 20:42:00

Roken
Member
From: UK
Registered: 2012-01-16
Posts: 1,077

Re: [SOLVED]Completely disable ati hdmi audio

You're close. In your blacklist:

blacklist snd_hda_intel
blacklist snd_hda_codec_hdmi

[img=Speedtest]http://www.speedtest.net/my-result/5145583518[/img]

Ryzen 1800x 8 core/16 thread - GTX 1070 8Gb, Asus ROG STRIX B350-F, 16Gb Corsair DDR4, Cooler Master N300 chassis, 6 HD (1 NvME PCI, 2SSD, 3Spinners) + 1 x optical.
Linux user #545703

Offline

#3 2012-02-14 20:50:48

LordOfInsomnia
Member
Registered: 2011-10-13
Posts: 69

Re: [SOLVED]Completely disable ati hdmi audio

I have added  snd_hda_codec_hdmi as you suggested, but did not work. sad

output for cat /proc/asound/modules is:

0 snd_hda_intel
1 snd_ca0106

Offline

#4 2012-02-14 20:56:03

Gusar
Member
Registered: 2009-08-25
Posts: 3,605

Re: [SOLVED]Completely disable ati hdmi audio

Files in /etc/modprobe.d need to end in .conf. That's why your configuration attempts don't take. Your alsa-base example will work, as long as the file is named alsa-base.conf. Hmm, and now that I think of it, even blacklisting snd_hda_intel will work, but again, the file needs to be blacklist.conf

Offline

#5 2012-02-14 21:12:33

LordOfInsomnia
Member
Registered: 2011-10-13
Posts: 69

Re: [SOLVED]Completely disable ati hdmi audio

It works! smile

Thank you all! smile

Offline

Board footer

Powered by FluxBB