You are not logged in.

#1 2012-02-21 16:40:22

6ng4n
Member
Registered: 2012-02-07
Posts: 78

[SOLVED] Soundcard numbers mixing

I've got 3 soundcards a onboard, a pci and a usb. Every boot up their numbers are changing.

I've tryed write down these lines to /etc/modprobe.d/modprobe.conf. But didn't worked.

option snd_cmipci index=0
option snd_hda_intel index=1
option snd_usb_audio index=2

And created udev rules. Still not working..

SUBSYSTEM=="sound", ATTR{id}=="CMI8768", ATTR{number}="0"
SUBSYSTEM=="sound", ATTR{id}=="SB", ATTR{number}="1"

It causes an error when boot up

Tue Feb 21 19:35:22 2012: :: Triggering UDev uevents    [BUSY]    [DONE] 
Tue Feb 21 19:35:22 2012: :: Waiting for UDev uevents to be processed    [BUSY] udevd[168]: error opening ATTR{/sys/devices/pci0000:00/0000:00:14.4/0000:03:05.0/sound/car
Tue Feb 21 19:35:22 2012: 
Tue Feb 21 19:35:22 2012: udevd[170]: error opening ATTR{/sys/devices/pci0000:00/0000:00:14.2/sound/card1/number} for writing: Permission denied
Tue Feb 21 19:35:22 2012: 
Tue Feb 21 19:35:22 2012: udevd[167]: error opening ATTR{/sys/devices/pci0000:00/0000:00:14.4/0000:03:05.0/sound/card0/number} for writing: Permission denied
Tue Feb 21 19:35:22 2012: 
Tue Feb 21 19:35:22 2012: udevd[167]: error opening ATTR{/sys/devices/pci0000:00/0000:00:14.2/sound/card1/number} for writing: Permission denied

Last edited by 6ng4n (2012-02-21 21:51:14)

Offline

#2 2012-02-21 19:44:56

bjackman
Member
Registered: 2011-12-27
Posts: 32

Re: [SOLVED] Soundcard numbers mixing

I'm in a similar situation to you, I originally solved the problem but didn't write dow how to do it, then somehow lost my asoundrc, but I'm working on it as we speak.

Assuming you're using ALSA, this and this should be helpful. I don't fully understand it - the alsa configuration style is quite hardcore so I suspect it's  one of those things you need to understand "from the bottom up". I'll let you know if I have any progress.

Offline

#3 2012-02-21 21:23:17

6ng4n
Member
Registered: 2012-02-07
Posts: 78

Re: [SOLVED] Soundcard numbers mixing

First of all I know neither asoundrc nor asound.conf will work without setting an index.Because every boot time the indexes changing and sometimes hw:0 becomes hw:1. So i have to set the indexes before alsa detects them at the boot sequence.

Last edited by 6ng4n (2012-02-21 21:24:19)

Offline

#4 2012-02-21 21:50:49

6ng4n
Member
Registered: 2012-02-07
Posts: 78

Re: [SOLVED] Soundcard numbers mixing

I've solved the problem. It's just syntax error tongue . It must be "options foo_bar index=0" instead of "option foo_bar index=0". One "s" makes difference.

Thanks

Offline

Board footer

Powered by FluxBB