You are not logged in.

#1 2012-02-23 18:46:13

mralby
Member
Registered: 2012-02-23
Posts: 5

[SOLVED] ldconfig: /usr/lib32/libusbpp-0.1.so.4 is not a symbolic link

Hello;
I've been using Arch for about three months now (previously used Debian Sid for roughly 10 ten years). I am a teacher in the U.S. I needed to install the SMART Board (TM) and SMART Notebook (TM) software to use in my classes. I had to download and unpack libusb-0.1.12-3-i686.pkg.tar.gz, from the Arch rollback machine, into it's own directory in my home directory. I then tried to symlink the files to /usr/lib32/ but kept getting a too many symlinks error. I finally just copied the files into /usr/lib32/. I now get "ldconfig: /usr/lib32/libusbpp-0.1.so.4 is not a symbolic link", and "ldconfig: /usr/lib32/libusb-0.1.so.4 is not a symbolic link" everytime I upgrade or install anything else to my system. My system seems to be running fine and I can connect to and use the SMART Board (TM) and SMART Notebook (TM) software without a hitch. I'm attempting to do things the "Arch way" but fear I may have messed up. Any thoughts and suggestions are keenly appreciated. Thank you very much for your time.
MrAlby

Last edited by mralby (2012-02-24 19:29:25)

Offline

#2 2012-02-24 11:43:58

Gcool
Member
Registered: 2011-08-16
Posts: 1,456

Re: [SOLVED] ldconfig: /usr/lib32/libusbpp-0.1.so.4 is not a symbolic link

Could you post the output of the following commands?

# ls -lah /usr/lib | grep libusb
# ls -lah /usr/lib32 | grep libusb

Last edited by Gcool (2012-02-24 11:45:20)


Burninate!

Offline

#3 2012-02-24 16:40:41

mralby
Member
Registered: 2012-02-23
Posts: 5

Re: [SOLVED] ldconfig: /usr/lib32/libusbpp-0.1.so.4 is not a symbolic link

Here you go:

[mystuff]$ ls -lah /usr/lib | grep libusb
lrwxrwxrwx   1 root root    19 Nov  3 18:49 libusb-0.1.so.4 -> libusb-0.1.so.4.4.4
-rwxr-xr-x   1 root root   19K Nov  3 18:49 libusb-0.1.so.4.4.4
-rw-r--r--   1 root root   84K Nov  3 16:11 libusb-1.0.a
lrwxrwxrwx   1 root root    19 Nov  3 16:11 libusb-1.0.so -> libusb-1.0.so.0.0.0
lrwxrwxrwx   1 root root    19 Nov  3 16:11 libusb-1.0.so.0 -> libusb-1.0.so.0.0.0
-rwxr-xr-x   1 root root   55K Nov  3 16:11 libusb-1.0.so.0.0.0
-rw-r--r--   1 root root   19K Nov  3 18:49 libusb.a
lrwxrwxrwx   1 root root    15 Aug  4  2011 libusbmuxd.so -> libusbmuxd.so.1
lrwxrwxrwx   1 root root    19 Aug  4  2011 libusbmuxd.so.1 -> libusbmuxd.so.1.0.7
-rwxr-xr-x   1 root root   19K Aug  4  2011 libusbmuxd.so.1.0.7
lrwxrwxrwx   1 root root    19 Nov  3 18:49 libusb.so -> libusb-0.1.so.4.4.4
[mystuff]$ ls -lah /usr/lib32 | grep libusb
-rwxr-xr-x  1 root   root   32K Feb 15 12:35 libusb-0.1.so.4
-rwxr-xr-x  1 root   root   32K Feb 15 12:35 libusb-0.1.so.4.4.4
-rw-r--r--  1 root   root   32K Feb 15 12:35 libusb.a
-rwxr-xr-x  1 root   root   27K Feb 15 12:35 libusbpp-0.1.so.4
-rwxr-xr-x  1 root   root   27K Feb 15 12:35 libusbpp-0.1.so.4.4.4
-rw-r--r--  1 root   root   21K Feb 15 12:35 libusbpp.a
-rwxr-xr-x  1 root   root   27K Feb 15 12:35 libusbpp.so
-rwxr-xr-x  1 root   root   32K Feb 15 12:35 libusb.so

Thanks for any insight.
MrAlby

Offline

#4 2012-02-24 17:57:35

Gcool
Member
Registered: 2011-08-16
Posts: 1,456

Re: [SOLVED] ldconfig: /usr/lib32/libusbpp-0.1.so.4 is not a symbolic link

Doing the following should take care of those warnings for you:

cd /usr/lib32
rm libusbpp-0.1.so.4
rm libusb-0.1.so.4
ln -s libusbpp-0.1.so.4.4.4 libusbpp-0.1.so.4
ln -s libusb-0.1.so.4.4.4 libusb-0.1.so.4

Burninate!

Offline

#5 2012-02-24 18:23:24

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [SOLVED] ldconfig: /usr/lib32/libusbpp-0.1.so.4 is not a symbolic link

Gcool wrote:

Doing the following should take care of those warnings for you:

cd /usr/lib32
rm libusbpp-0.1.so.4
rm libusb-0.1.so.4
ln -s libusbpp-0.1.so.4.4.4 libusbpp-0.1.so.4
ln -s libusb-0.1.so.4.4.4 libusb-0.1.so.4

imo the package that owns those files is broken and needs to be fixed.


Give what you have. To someone, it may be better than you dare to think.

Offline

#6 2012-02-24 19:25:19

mralby
Member
Registered: 2012-02-23
Posts: 5

Re: [SOLVED] ldconfig: /usr/lib32/libusbpp-0.1.so.4 is not a symbolic link

Yes, that works. Thank you very much!
MrAlby

Offline

Board footer

Powered by FluxBB