You are not logged in.

#1 2012-03-01 06:41:18

rsmb
Member
Registered: 2012-02-09
Posts: 8

Screen hangs after installing proprietary nvidia drivers (without X)

Edit for clarity: I am trying to install the proprietary nvidia drivers. I have a working console with the nouveau driver but would like to use the proprietary driver.

Edit 2: the problem might be caused by an incompatibility between the proprietary nvidia drivers and EFI? but this has been disputed.

After installing the proprietary nvidia drivers on a console-only setup, my screen locks up after the initial loading screen (i.e. after 'Loading Linux linux..., Loading initial ramdisk...'). The system is still running: for example, I can 'blindly' log in, uninstall the drivers, reboot, and things work again.

I've tried looking through the log files, but can't seem to find anything that would indicate any kind of error. This problem happens regardless of whether I have one or two monitors plugged in (and I've tried both ports for the single monitor case).

Here are the relevant results of 'grep -i nvidia /var/log/*.log' (excluding everything.log):

dmesg.log:

    dmesg.log:[    4.194787] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input7
    dmesg.log:[    4.194895] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input8
    dmesg.log:[    4.194996] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input9
    dmesg.log:[    4.195117] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input10

kernel.log: http://pastebin.com/v7b7BjG4

messages.log: http://pastebin.com/L7LN4EMm

And the contents of pacman.log for the full session (installing nvidia, rebooting, 'blindly' uninstalling, and rebooting again):

[2012-03-01 01:05] Running 'pacman -S nvidia'
[2012-03-01 01:08] Running 'pacman -Rdd libgl'
[2012-03-01 01:08] removed libgl (7.11.2-1)
[2012-03-01 01:10] Running 'pacman -Sy'
[2012-03-01 01:10] synchronizing package lists
[2012-03-01 01:10] Running 'pacman -S nvidia'
[2012-03-01 01:10] installed nvidia-utils (295.20-1)
[2012-03-01 01:10] In order to use nvidia module, reboot the system.
[2012-03-01 01:10] installed nvidia (295.20-2)
[2012-03-01 01:12] Running 'pacman -R nvidia'
[2012-03-01 01:12] removed nvidia (295.20-2)

My video card is a GTX 460, and I'm plugged in to DVI ports (this particular session was with a two-monitor setup). I'd like to eventually have X working, but I'm trying to debug this in the console to minimize potential sources of error.

Thanks!

Last edited by rsmb (2012-12-19 02:50:11)

Offline

#2 2012-03-01 11:54:33

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: Screen hangs after installing proprietary nvidia drivers (without X)

How are you booting into Arch? Post your /boot/grub/menu.lst.

Did you try the open source driver too? https://wiki.archlinux.org/index.php/Nouveau


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#3 2012-03-01 12:35:02

lifeafter2am
Member
From: .........
Registered: 2009-06-10
Posts: 1,325
Website

Re: Screen hangs after installing proprietary nvidia drivers (without X)

Are you sure your NVidia module is loading? Here is my dmesg:

$ dmesg | grep -i nvidia
[    5.076943] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:02.0/0000:01:00.1/sound/card1/input8
[    5.077132] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:02.0/0000:01:00.1/sound/card1/input9
[    5.077202] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:02.0/0000:01:00.1/sound/card1/input10
[    5.077270] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:02.0/0000:01:00.1/sound/card1/input11
[  550.677305] nvidia: module license 'NVIDIA' taints kernel.
[  550.721537] nvidia 0000:01:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[  550.721544] nvidia 0000:01:00.0: setting latency timer to 64
[  550.721790] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  295.20  Mon Feb  6 21:07:30 PST 2012

#binarii @ irc.binarii.wtf
-------------
Allan -> ArchBang is not supported because it is stupid.

Offline

#4 2012-03-01 15:59:00

rsmb
Member
Registered: 2012-02-09
Posts: 8

Re: Screen hangs after installing proprietary nvidia drivers (without X)

I'm using the GRUB2 UEFI bootloader. As per the instructions on the GRUB2 wiki page ('Multiboot in UEFI' section), here's my <EFI partition>/efi/grub/grub.cfg :

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
insmod part_gpt
insmod part_msdos
if [ -s $prefix/grubenv ]; then
  load_env
fi
set default="0"
if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function load_video {
true
}

set menu_color_normal=light-blue/black
set menu_color_highlight=light-cyan/blue

insmod part_gpt
insmod ext2
set root='(hd0,gpt2)'
search --no-floppy --fs-uuid --set=root dc41d789-e383-4fe6-a7e1-9e70dac7ac7d
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
fi
terminal_input console
terminal_output gfxterm
set timeout=50
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Arch Linux, with Linux linux' --class archlinux --class gnu-linux --class gnu --class os {
	load_video
	set gfxpayload=keep
	insmod gzio
	insmod part_gpt
	insmod ext2
	set root='(hd0,gpt2)'
	search --no-floppy --fs-uuid --set=root dc41d789-e383-4fe6-a7e1-9e70dac7ac7d
	echo	'Loading Linux linux ...'
	linux	/boot/vmlinuz-linux root=UUID=dc41d789-e383-4fe6-a7e1-9e70dac7ac7d ro  quiet
	echo	'Loading initial ramdisk ...'
	initrd	/boot/initramfs-linux.img
}
menuentry 'Arch Linux, with Linux linux Fallback' --class archlinux --class gnu-linux --class gnu --class os {
	load_video
	set gfxpayload=keep
	insmod gzio
	insmod part_gpt
	insmod ext2
	set root='(hd0,gpt2)'
	search --no-floppy --fs-uuid --set=root dc41d789-e383-4fe6-a7e1-9e70dac7ac7d
	echo	'Loading Linux linux ...'
	linux	/boot/vmlinuz-linux root=UUID=dc41d789-e383-4fe6-a7e1-9e70dac7ac7d ro  quiet
	echo	'Loading initial ramdisk ...'
	initrd	/boot/initramfs-linux-fallback.img
}
menuentry 'Windows 7' {
	  insmod part_gpt
	  insmod fat
	  insmod search_fs_uuid
	  insmod chain
	  search --fs-uuid --no-floppy --set=root ec51-2ac1
	  chainloader (${root})/efi/Microsoft/Boot/bootmgfw.efi
}

### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###

The nouveau drivers seem to work (at least, installing them doesn't seem to cause the same hanging).

Last edited by rsmb (2012-03-01 16:00:38)

Offline

#5 2012-03-01 16:38:50

Blµb
Member
Registered: 2008-02-10
Posts: 223

Re: Screen hangs after installing proprietary nvidia drivers (without X)

Have you added the module to the initramfs for some reason? (don't)
If not, try to find out where it is auto-loaded. If you don't boot into X there's no reason for the module to be loaded at all. It should be loaded only when you actually start X.
Though this will only delay the hanging... but at least you'll have a usable console then.
(eg. try adding !nvidia in the MODULES list in rc.conf)


You know you're paranoid when you start thinking random letters while typing a password.
A good post about vim
Python has no multithreading.

Offline

#6 2012-03-03 00:15:35

mandog
Member
From: Peru
Registered: 2008-09-17
Posts: 204

Re: Screen hangs after installing proprietary nvidia drivers (without X)

sounds like you did not blacklist nouveau as it loads with the kernel and kills nvidia.
you do not need to add nvidia to rc.local as it rebuilds the kernel for the driver unless you forget to blacklist nouveau  drivers.


I'm dyslexic Please do not complain about puntuation or spelling and remember most dyslexic people have above average iq.

Offline

#7 2012-03-04 17:54:13

pquiney
Member
Registered: 2010-09-12
Posts: 9

Re: Screen hangs after installing proprietary nvidia drivers (without X)

I think your problem is due to the nouveau module being in your initrd.

If you can get the system to the point where you can re-install the nvidia driver, then before you reboot, rebuild the initrd (using mkinitcpio -p linux).

The nvidia package blacklists 'nouveau' and 'nvidiafb' modules (see /lib/modprobe.d/nvidia.conf), so when you rebuild the initrd it will no longer include nouveau. Then you should be able to reboot and all should work fine.

Offline

#8 2012-09-15 15:38:08

rsmb
Member
Registered: 2012-02-09
Posts: 8

Re: Screen hangs after installing proprietary nvidia drivers (without X)

Everything below was tried on a fully-updated system (as of 2012/09/15).

pquiney wrote:

If you can get the system to the point where you can re-install the nvidia driver, then before you reboot, rebuild the initrd (using mkinitcpio -p linux).

Unfortunately, rebuilding initramfs didn't help. I uninstalled the drivers, rebooted, reinstalled, ran 'mkinitcpio -p linux', rebooted, and still had the same problem (screen hanging). Whenever I ran mkinitcpio, though, it complained about not being able to find /{etc,var}/modprobe.d/modprobe.conf . I've pasted the full output at http://pastebin.com/GTYJqdbs . Also, running modprobe with -v produced no output involving 'nouveau' or 'nvidia'. I tried creating /etc/modprobe.d/modprobe.conf and adding the blacklist commands myself, but that didn't change anything.

I noticed that nvidia.conf doesn't blacklist nvidiafb, so I tried the process again after reinstalling and adding 'blacklist nvidiafb' to /lib/modprobe.d/nvidia.conf/ (both with and without running mkinitcpio before rebooting). To sum up, here's what I tried:

uninstall -> reboot -> reinstall -> reboot
uninstall -> reboot -> reinstall -> mkinitcpio -> reboot

uninstall -> reboot -> reinstall -> blacklist nvidiafb in /lib/modprobe.d/nvidia.conf -> reboot
uninstall -> reboot -> reinstall -> blacklist nvidiafb in /lib/modprobe.d/nvidia.conf -> mkinitcpio -> reboot

uninstall -> reboot -> reinstall -> blacklist nouveau+nvidiafb in /etc/modprobe.d/modprobe.conf -> reboot
uninstall -> reboot -> reinstall -> blacklist nouveau+nvidiafb in /etc/modprobe.d/modprobe.conf -> mkinitcpio -> reboot
mandog wrote:

sounds like you did not blacklist nouveau as it loads with the kernel and kills nvidia.

/lib/modprobe.d/nvidia.conf contains 'blacklist nouveau', so I'm assuming it's being blacklisted. I also tried blacklisting it myself in /etc/modprobe.d/modprobe.conf with no luck (see above).


Blµb wrote:

Though this will only delay the hanging... but at least you'll have a usable console then. (eg. try adding !nvidia in the MODULES list in rc.conf)

I can successfully uninstall the module and have a working console (by blindly logging in and typing 'pacman -R nvidia<RET>y<RET>reboot<RET>').

Offline

#9 2012-09-15 16:05:13

ixnine
Member
Registered: 2008-11-01
Posts: 60

Re: Screen hangs after installing proprietary nvidia drivers (without X)

https://wiki.archlinux.org/index.php/Ke … _KMS_start

Try this first, I suspect it's just KMS

Offline

#10 2012-09-15 18:27:37

rsmb
Member
Registered: 2012-02-09
Posts: 8

Re: Screen hangs after installing proprietary nvidia drivers (without X)

ixnine wrote:

https://wiki.archlinux.org/index.php/Ke … _KMS_start

Try this first, I suspect it's just KMS

Adding ' MODULES="nouveau" ' to mkinitcpio.conf worked perfectly! Thanks!

I don't quite understand why, though: the wiki article says

Intel, Nouveau and ATI drivers already enable KMS automatically for all chipsets. So you need not install it manually.

The proprietary NVIDIA and ATI Catalyst drivers do not use the open driver stack. In order to use KMS you should replace them with open source drivers.

If that's the case, then how can enabling it cause nvidia to work?

Last edited by rsmb (2012-09-15 18:29:00)

Offline

#11 2012-09-15 18:45:16

Gusar
Member
Registered: 2009-08-25
Posts: 3,472

Re: Screen hangs after installing proprietary nvidia drivers (without X)

rsmb wrote:

If that's the case, then how can enabling it cause nvidia to work?

It doesn't. Using nouveau specifically prevents the nvidia driver to work.

Offline

#12 2012-09-15 19:43:46

ixnine
Member
Registered: 2008-11-01
Posts: 60

Re: Screen hangs after installing proprietary nvidia drivers (without X)

rsmb wrote:

Adding ' MODULES="nouveau" ' to mkinitcpio.conf worked perfectly! Thanks!

Glad to see it worked for you. Don't forget to put [Solved] at the start of the topic title.

Offline

#13 2012-09-15 22:09:20

rsmb
Member
Registered: 2012-02-09
Posts: 8

Re: Screen hangs after installing proprietary nvidia drivers (without X)

Gusar wrote:
rsmb wrote:

If that's the case, then how can enabling it cause nvidia to work?

It doesn't. Using nouveau specifically prevents the nvidia driver to work.

Oh. But I'm trying to get nvidia (proprietary) to work, so I suppose now I'm back to square one.

Or does nvidia just plain not work with the console?

To summarize: the free nouveau drivers work with no problems whatsoever before any of this, but I can't get the nvidia drivers to work. Reading over my first post, I think this wasn't clear before - sorry about that!

Last edited by rsmb (2012-09-15 22:11:36)

Offline

#14 2012-09-15 22:45:06

Gusar
Member
Registered: 2009-08-25
Posts: 3,472

Re: Screen hangs after installing proprietary nvidia drivers (without X)

The nvidia driver does nothing to the console, it only comes into play when you start X. So if your console goes blank before X is started, the issue is not the nvidia driver, but elsewhere. If you don't have the nouveau module in the initramfs and it's blacklisted in the actual system, then you should be getting a classic VGA text console.

Hey wait, I see you're using EFI. The nvidia driver doesn't support that yet, you need to boot the machine in BIOS mode.

Offline

#15 2012-09-15 23:15:58

rsmb
Member
Registered: 2012-02-09
Posts: 8

Re: Screen hangs after installing proprietary nvidia drivers (without X)

Gusar wrote:

Hey wait, I see you're using EFI. The nvidia driver doesn't support that yet, you need to boot the machine in BIOS mode.

That's too bad, but thanks for letting me know. I've updated the wiki article accordingly.

Is there a tag other than "[SOLVED]" that I should edit in for this thread?

Offline

#16 2012-12-19 02:45:41

rsmb
Member
Registered: 2012-02-09
Posts: 8

Re: Screen hangs after installing proprietary nvidia drivers (without X)

As obliquely hinted at in the KMS wiki page and suggested by a helpful wiki editor, I tried adding 'nomodeset' to the kernel parameters. Unfortunately, this led to the black-screen problem, both with and without the proprietary drivers installed.

This problem persists with the latest kernel (3.6.10-1) and the latest nvidia drivers (310.19-2) as of 12/18/12.

Offline

Board footer

Powered by FluxBB