You are not logged in.

#1 2012-03-05 23:32:05

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,104

[solved] acroread suddenly fails silently

I think I must be missing something obvious but I can't think what and searching the wiki and forums hasn't helped. (Probably I'm searching for the wrong things.)

acroread was working fine a couple of days ago. I am using the AUR PKGBUILD file, updated for 9.4.7 according to the instructions in the AUR comments. (9.4.7 is a security update but the package hasn't been updated in a long time.)

The most recent things I've done which might have affected things involve font configuration. I've been working my way through the font config wiki. In particular, I've replaced the default freetype2, fontconfig, libxft with infinality/lcd versions. I've done the same for the lib32- versions of these packages, where applicable.

I have tried rebuilding and reinstalling acroread and the system-wide installation of acroread fonts (just in case). I've also updated the font cache list and the fonts.dir and fonts.scale files.

I first noticed that acroread wasn't working in firefox. Usually, the kpartsplugin opens pdf in acroread in the browser. Now I just get an empty space. (Not a blank page but the grey background behind the page which you don't usually see, I think.) But no sign of acroread. I then tried opening some pdf files on disk from the cli with acroread. I get a general error about not being able to find oxygen-gtk:

(acroread:14245): Gtk-WARNING **: Unable to locate theme engine in module_path: "oxygen-gtk",

However, I always get this and acroread works fine. (I've tried to solve this following hints found on the forums by installing lib32-libxslt and lib32-xcb-util but this didn't make any difference.) oxygen-gtk2 is installed just fine.

Apart from this, the OS switches to the appropriate virtual desktop as though acroread was starting but acroread never starts. I don't get an error message. I just get left at the empty desktop.

No errors are logged in ~/.xsession-errors and I can't find anything in the system log files either (errors.log, everything.log, dmesg, Xorg.0.log etc.).

I tried acroread -info so I could check paths etc. but this also fails silently.

What have I missed? Or how can I obtain more useful error messages from acroread? (i.e. any error messages at all!)

In the meantime, I've also been unable to find out how kpartsplugin decides which applications to use. I wondered if I might persuade it to use okular (the system default for pdfs) instead...

Last edited by cfr (2012-03-06 18:30:30)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#2 2012-03-05 23:37:17

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: [solved] acroread suddenly fails silently

Have you read the comments? The workaround suggested there works fine.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#3 2012-03-06 00:43:25

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,104

Re: [solved] acroread suddenly fails silently

Thanks for the quick reply. Do you mean installing the older versions of the packages?

lib32-freetype2-2.4.8-1-x86_64.pkg.tar.xz
lib32-gtk2-2.24.8-1-x86_64.pkg.tar.xz
freetype2-2.4.8-1-x86_64.pkg.tar.xz
gtk2-2.24.8-2-x86_64.pkg.tar.xz

I'm the person who asked if that kludge was compatible with having the standard versions installed on the system. No, I haven't tried that.

I think this is a different issue because acroread isn't even starting. I get the crashes usually but not before it even starts.

I'll definitely try this, though, if somebody can tell me what (if anything) I'd need to uninstall to use this...

OK. So this does seem to have worked. Thanks very much for suggesting it. I just hadn't made the connection with the sporadic crashes or remembered that suggestion.

What I did was find these files:

lib32-freetype2-2.4.8-1-x86_64.pkg.tar.xz
lib32-gtk2-2.24.8-1-x86_64.pkg.tar.xz
freetype2-2.4.8-1-x86_64.pkg.tar.xz
gtk2-2.24.8-1-x86_64.pkg.tar.xz

(I used 2.24.8-1 for all of them - don't know if that is bad?) and the corresponding signatures. Downloaded them, checked the signatures and unpacked them. I then ran the post install instructions for the gtk packages. This didn't work for lib32 and I don't think it was necessary for either of them. I copied the corresponding file from the system for lib32 just in case.

I stuck all this in a directory under my home directory. I then adjusted the KDE launcher with an appropriately modified form of the command from the comments, thus creating ~/.local/share/applications/acroread.desktop. (I tried doing this manually but couldn't get KDE to use it.) I then created a sh function along similar lines which will get sourced in all my sh/bash shells. Won't get propagated to tcsh without intervention but I hardly ever use tcsh anyhow....

So I hope most stuff should use the kludge automatically.

Sure would be nice to see this package getting a little attention from somebody who knows what they're doing!

Thanks very much. Unfortunately I rely heavily on acroread as I can't find a replacement so fixing acroread tends to have a depressingly high priority when it (frequently) breaks.

I don't understand what made it so much worse. Presumably infinality versions of freetype are even less to its liking than the current official versions!

Last edited by cfr (2012-03-06 02:21:04)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#4 2012-03-06 01:15:36

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: [solved] acroread suddenly fails silently

Yep, just try doing this literally, putting the right files in your $HOME/opt (or any folder of your choice -- just remember to modify your launcher / alias accordingly so that it points the right libs). You don't have to touch any working freetype2 / gtk2 libs: those older ones are intended to do the job only for Acrobat. If it were possible to recompile Acrobat, we wouldn't probably have any issues now. Alas...


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#5 2012-03-06 02:18:05

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,104

Re: [solved] acroread suddenly fails silently

Thanks. I edited my post before seeing your response.

Should I have used the later version of gtk2? I used the earlier one as it matched the version of everything else. That seems to work but I haven't actually tried opening a file with it yet (just checked I can open the app!).

Yes, acroread is a complete pain. PDF viewers and editors are definitely the weakest part of my linux experience so far. Other issues have more to do with specific pieces of hardware or something but this seems so general and basic. The fact that acroread is currently my best option only demonstrates the poor quality of the competition.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#6 2012-03-06 02:33:49

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: [solved] acroread suddenly fails silently

cfr wrote:

Should I have used the later version of gtk2?

No. You don't have to install or downgrade (with pacman) anything. Use your regular gtk2 & freetype libraries (both x86_64 & i686) as found in the official repos with all the apps except Acrobat. For Acrobat you should simply create a fakeroot in your home directory, e.g. /home/cfr/opt (or wherever you wish) and extract the archives there (versions: 2.4.8-1 & 2.24.8-1 respectively). Then you should create a launcher or alias pointing Acrobat to your fakeroot, e.g.

alias acroread="LD_LIBRARY_PATH=$HOME/opt/acroread_libs/usr/lib32:$HOME/opt/acroread_libs/usr/lib /usr/bin/acroread"

in your .bashrc. This way when you launch Acrobat, it looks for the obligatory libraries in your home dir rather than /usr/lib, etc.

Last edited by bohoomil (2012-03-06 02:34:47)


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#7 2012-03-06 03:08:21

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,104

Re: [solved] acroread suddenly fails silently

Thanks. I didn't use pacman. I just meant that I'd used 2.24.8-1 for both gtk libs but I realised that the original list used one 2.24.8-1 and one 2.24.8-2. I wasn't sure if that mattered.

I used a function rather than an alias but I don't think that makes any odds:

# Use acroread kludge
acroread () {
        LD_LIBRARY_PATH=${HOME}/path-to-acroread-kludge/usr/lib32:${HOME}/path-to-acroread-kludge/usr/lib /usr/bin/acroread "$@"
}

It's just in a file of functions which gets sourced by ~/.bashrc etc.

Last edited by cfr (2012-03-06 03:10:58)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

Board footer

Powered by FluxBB