You are not logged in.

#1 2012-03-10 21:35:52

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,124

intel integrated graphics: gpu hung, system freezes

Today, I noticed some display corruption. It appeared on only one virtual desktop but it persisted despite switching back and forth and running xrefresh. It consisted of a rectangular area of static-like appearance on a black background. I tried to take a screenshot but this rendered my machine completely non-responsive. (ctrl+alt+del/backspace had no effect; ctrl+alt+f1 etc. had no effect) So I had to switch off at the power button and cold reboot.

Examining the logs, I see this:

Mar 10 14:57:03 localhost kernel: [ 4232.490910] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
Mar 10 14:57:03 localhost kernel: [ 4232.509642] [drm:i915_wait_request] *ERROR* i915_wait_request returns -11 (awaiting 120527 at 120524, next 120528)

I'm booting with the following options:

i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1

These have not previously caused me any problems. However, I just updated to kernel 3.2.9 and I am running with 2G rather than 8G of RAM. (The RAM is also a different vendor but it is the original which shipped with the machine and I didn't have any problems with the machine when I ran with just 2G initially. This RAM is known good - memtest gave it a clean bill of health only yesterday.)

Everything seems OK now on reboot but does anybody know if the kernel upgrade and/or any of those video options could be causing the problem, especially if any might be problematic with less RAM? I understand they make a big difference to battery life but I could certainly disable one or more temporarily until I get a replacement for the failed RAM.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#2 2012-03-11 14:06:33

MadTux
Member
Registered: 2009-09-20
Posts: 553

Re: intel integrated graphics: gpu hung, system freezes

I read through the Phoronix article about those three options (http://www.phoronix.com/scan.php?page=a … ower&num=1) and while all three may cause problems, i915.i915_enable_rc6=1 seems to be the one that can make the GPU hang, while i915.i915_enable_fbc=1 can cause screen distortions.
To debug the problem I would start by disabling one of the parameters and see if that changes anything.

Offline

#3 2012-03-11 17:26:40

kazimir
Member
Registered: 2012-01-20
Posts: 79

Re: intel integrated graphics: gpu hung, system freezes

Alternatively you could try to add the i915.semaphores=1 option as suggested in http://intellinuxgraphics.org/2011Q4.html

Offline

#4 2012-03-11 19:20:53

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,124

Re: intel integrated graphics: gpu hung, system freezes

I'll try adding the semaphores option. It's hard to debug since I'm not seeing it all the time. So I can't conclude that something isn't responsible just because including it results in an unproblematic session!

Thanks.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

Board footer

Powered by FluxBB