You are not logged in.

#1 2005-07-13 03:04:02

DeusExLinux
Member
Registered: 2005-03-18
Posts: 98

help, alsa died (SOLVED)

I was running a custom 2.6.9 kernel, and everything was working fine.

I decided to be adventerous and upgrade to the 2.6.12.2 kernel (I grabbed the vanilla source from kernel.org).  I compiled fine, got my madwifi to work fine, and then tried to play a song.

it decided that it wasn't going to work.

I have checked the volume settings (alsamixer, and the mixer I use) and nothing is muted, everything is turned up.  the volume is turned up on my laptop.  The modules are loaded.  No sound.

The sound card in my laptop is the intel8x0, and is loaded at boot.

It acts as if it is playing, but no sound coming out.

I decided to boot back into my old kernel, 2.6.9, and when I did, the sound decided it didn't want to work in there either!!!!  I don't know what happened here, as I didn't do anything to alsa.  The config file I used to config my new kernel is the same as the old kernel.  Is there an error in alsa in the new kernel version?  Or did something magically happen to screw up my sound server?

this is uber-frustrating.

Any help would be much appreciated.


And on the 8th day, God gave the people Google so that all the problems of the universe could be researched from one central place.  And it was good.

Offline

#2 2005-07-13 04:02:08

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: help, alsa died (SOLVED)

Try alsaconf.

Offline

#3 2005-07-13 04:08:47

DeusExLinux
Member
Registered: 2005-03-18
Posts: 98

Re: help, alsa died (SOLVED)

I did, no dice.

I've done it in both kernels.

No dice.

sad

I'm really close to reformatting and reinstalling, which I really don't want to do, but I have NO idea what's the deal with this.  I've tried everything I can think of.

I might try to rebuild the kernel without alsa support, and manually compile and install alsa.


And on the 8th day, God gave the people Google so that all the problems of the universe could be researched from one central place.  And it was good.

Offline

#4 2005-07-13 08:11:13

scarecrow
Member
From: Greece
Registered: 2004-11-18
Posts: 714

Re: help, alsa died (SOLVED)

Do you have sound as root?


Microshaft delenda est

Offline

#5 2005-07-13 16:13:59

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: help, alsa died (SOLVED)

is snd-intel8x0m loaded as well - it's a sound driver for your modem, and, at least on my system, they clash and cancel each other out - if using hotplug, make sure to blacklist the "m" version

Offline

#6 2005-07-13 17:51:46

ozar
Member
From: USA
Registered: 2005-02-18
Posts: 1,681

Re: help, alsa died (SOLVED)

I think he meant blacklist it in /etc/hotplug/blacklist


oz

Offline

#7 2005-07-13 18:47:04

DeusExLinux
Member
Registered: 2005-03-18
Posts: 98

Re: help, alsa died (SOLVED)

No sound as root, either.

Blacklisted, and no deal either.

I thought perhaps it was a module I was runnign (I've stopped using hotplug), so I switched it over to all just hotplug, and it still isn't working (with snd-intel8x0<b>m</b> blacklisted out)...

lsmod

Module                  Size  Used by
i915                   20864  1
drm                    69524  2 i915
lp                     13316  0
serial_cs              10632  1
sr_mod                 19108  0
pcmcia                 28688  3 serial_cs
ohci_hcd               23172  0
parport_pc             29380  0
parport                38984  2 lp,parport_pc
usb_storage            67264  0
pcspkr                  4300  0
yenta_socket           24072  2
rsrc_nonstatic         12672  1 yenta_socket
pcmcia_core            51976  4 serial_cs,pcmcia,yenta_socket,rsrc_nonstatic
e100                   40192  0
mii                     6528  1 e100
ath_pci                64032  0
ath_rate_onoe           9480  1 ath_pci
wlan                  122332  3 ath_pci,ath_rate_onoe
ath_hal               149072  2 ath_pci
snd_intel8x0           35008  3
snd_ac97_codec         84216  1 snd_intel8x0
snd_pcm_oss            55840  0
snd_mixer_oss          20736  1 snd_pcm_oss
snd_pcm                98308  4 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              27140  2 snd_pcm
snd                    57316  10 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              11104  1 snd
snd_page_alloc         10628  2 snd_intel8x0,snd_pcm
i2c_i801                9356  0
i2c_core               23040  1 i2c_i801
tpm_atmel               5632  0
tpm                    12416  1 tpm_atmel
ehci_hcd               37512  0
usbhid                 48800  0
uhci_hcd               34064  0
joydev                 10816  0
tsdev                   8512  0
evdev                  10368  0
ide_scsi               19076  0
usbcore               128252  6 ohci_hcd,usb_storage,ehci_hcd,usbhid,uhci_hcd

relevant portition of my modprobe.conf

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF version 1.0.9a ---
options snd  device_mode=0666
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0
# --- END: Generated by ALSACONF, do not edit. ---

And on the 8th day, God gave the people Google so that all the problems of the universe could be researched from one central place.  And it was good.

Offline

#8 2005-07-13 22:05:48

DeusExLinux
Member
Registered: 2005-03-18
Posts: 98

Re: help, alsa died (SOLVED)

fixed it.

smile

Apparently I'm stupid, and you have to compile ALSA as a module, and not in the kernel.  recompiled it as a module, on a whim, and blammo, works great again

thanks guys for leading me in the right direction!!


And on the 8th day, God gave the people Google so that all the problems of the universe could be researched from one central place.  And it was good.

Offline

Board footer

Powered by FluxBB