You are not logged in.

#1 2012-03-21 03:59:02

spricc
Member
Registered: 2012-03-13
Posts: 3

[SOLVED] Audio setup troubles with usb headphones and built-in sound

Hello,
I Just started using Arch about a month ago after going through many Debian and Ubuntu variants.  After all my frustrations with apt pinning to get working 10bit video playback, only to have everything else uninstalled by crappy dependency checking, I am extremely happy with how easy it was in Arch.

Now I am having difficulties perfecting my audio setup.  Almost everything else is set up to satisfactory levels but I have yet to bring the sound to the same standard.  With just ALSA my built in audio works, but defaults to the unused hdmi on my nvidia graphics.  I have managed to get it to switch at some point but with ALSA alone I could never get my usb headset to work at all.

By using pulseaudio as well I was able to get simutaneous playback, which is ideal, but had choppiness and other issues with just the usb headset.  I followed some instructions found on the arch wiki and other places on the net for choppiness in both ALSA and pulse and tried the fixes listed in various combinations.  I ended up with outcomes such as pulse not starting, no sound at all, creepy ticking in usb and perfect sound on speakers, and my current situation of perfect sound on speaker and acceptable but tinny sound on usb which degrades over time requiring restart.

Is anyone able to give any advice or point me to any guides I may have overlooked?

Setting up sound from scratch is something I have never done before coming to Arch, so I don't know what commands are useful for audio specifically, but learning is one of the reasons I decided on Arch. As for commands I do know, lspci and lsusb, relevant entries are as follows:

spricc ~ $ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
01:00.1 Audio device: NVIDIA Corporation GF104 High Definition Audio Controller (rev a1)
Bus 004 Device 003: ID 1532:000e Razer USA, Ltd

USB device is a Razer Megalodon headset, NVIDIA Audio is of no interest to me, unless it is not what i think it is.

Thanks to anyone who takes the time to read this.

Last edited by spricc (2012-03-23 15:21:11)

Offline

#2 2012-03-21 07:32:38

ngoonee
Forum Fellow
From: Between Thailand and Singapore
Registered: 2009-03-17
Posts: 6,856

Re: [SOLVED] Audio setup troubles with usb headphones and built-in sound

What does pavucontrol show, since you're using pulse? Shows all devices? Try using alsamixer to modify the backend volumes to each device if the only problem is volume currently.


Allan-Volunteer on the (topic being discussed) mailn lists. You never get the people who matters attention on the forums.
jasonwryan-Installing Arch is a measure of your literacy. Maintaining Arch is a measure of your diligence. Contributing to Arch is a measure of your competence.
Griemak-Bleeding edge, not bleeding flat. Edge denotes falls will occur from time to time. Bring your own parachute.

Offline

#3 2012-03-23 15:20:19

spricc
Member
Registered: 2012-03-13
Posts: 3

Re: [SOLVED] Audio setup troubles with usb headphones and built-in sound

I managed to find a solution.

https://wiki.archlinux.org/index.php/Pu … oppy_sound
Following this exactly didnt work before, but setting the sample rate to 192000 instead seems to have done the trick

Offline

Board footer

Powered by FluxBB