You are not logged in.

#1 2012-03-29 17:33:50

lgeek
Member
From: Europe, Portugal
Registered: 2012-03-09
Posts: 70

[SOLVED]Can't get notifications on Fluxbox

I can't get any type of notifications about connections status wicd wicd and nm-applet.
I have installed libnotify and python-notify, and of course I enabled notifications on wicd / nm-applet.
Example notification: http://farm4.staticflickr.com/3599/3468 … 799117.jpg

Last edited by lgeek (2012-03-29 18:38:34)

Offline

#2 2012-03-29 18:06:55

Raynman
Member
Registered: 2011-10-22
Posts: 1,155

Re: [SOLVED]Can't get notifications on Fluxbox

You need something to take the notifications sent by wicd/nm-applet and put them on the screen. Two options in the repos are xfce4-notifyd and notification-daemon.

Last edited by Raynman (2012-03-29 18:07:06)

Offline

#3 2012-03-29 18:29:47

lgeek
Member
From: Europe, Portugal
Registered: 2012-03-09
Posts: 70

Re: [SOLVED]Can't get notifications on Fluxbox

Since I am in Fluxbox, how do I start notification-daemon?
Thanks.

Offline

#4 2012-03-29 18:34:15

Raynman
Member
Registered: 2011-10-22
Posts: 1,155

Re: [SOLVED]Can't get notifications on Fluxbox

The usual way. I don't know if there is a specific method for Fluxbox (I know Openbox has an autostart script), but ~/.xinitrc is a WM-independent option.

Offline

#5 2012-03-29 18:35:29

lgeek
Member
From: Europe, Portugal
Registered: 2012-03-09
Posts: 70

Re: [SOLVED]Can't get notifications on Fluxbox

Solved. I went to https://bugs.archlinux.org/task/23720 and all I have to do is put this "/usr/lib/notification-daemon-1.0/notification-daemon &" in my startup script on Fluxbox, and i tested with notify-send "j" and it worked. I maybe put this "/usr/lib/notification-daemon-1.0/notification-daemon &" in my .xinitrc, this away I could put the command after my WM/DE and it would work to gnome or fluxbox
Thanks.

Last edited by lgeek (2012-03-29 18:38:18)

Offline

Board footer

Powered by FluxBB