You are not logged in.

#1 2005-07-18 03:04:34

Registered: 2005-04-04
Posts: 27

Grub Problems

Hallo alltogether,

after trying install FreeBSD on my machine I've destroyed my GRUB loader in MBR. I've tried to reinstall it by booting from Arch boot CD.

I've looked on this thread: … stall+grub

I tried this one:

mount blah blah blah
chroot /mnt /bin/bash
grub > root (hdx,y)
grub > setup (hdx)
grub > quit
cd /
umount blah blah blah

but It doesn't work. When I type  root (hd0,1) I got this error message:

Error 21: Selected disk does not exist

My root partition is on the first and only hard disk on the partition hda2.

In the grub manuel I've found this description for this error:

21 : Selected disk does not exist

This error is returned if the device part of a device- or full file name refers to a disk or BIOS device that is not present or not recognized by the BIOS in the system. 

But it can't be a problem with my hard disk. If it would be so it wouldn't be possible to mount and to chrot to my root partition, isn't it?


#2 2005-07-18 03:18:42

Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: Grub Problems

you need to mount --bind /dev/ /mnt/blah/dev

where /mnt/blah/dev is where you mounted your / fs.


#3 2006-05-22 06:16:17

From: Rio de Janeiro - Brasil
Registered: 2006-02-16
Posts: 86

Re: Grub Problems

Thank you! this --bind option saved me!

Keep swimming.
Dolly, in Finding Nemo


Board footer

Powered by FluxBB