You are not logged in.

#1 2012-04-03 21:04:27

Zapman
Member
Registered: 2012-04-01
Posts: 42

[Solved]Greek on archlinux

Hello. i generated el.utf-8 encoding through locale.gen and set it as locale in rc.conf. everything seemed normal except that i cant type accented letters like "ή" or "ό" plus filenames typed in greek are shown as "????". what can i do to fix it?

Thank you very much

Last edited by Zapman (2012-04-05 10:22:58)

Offline

#2 2012-04-03 21:14:23

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,742

Re: [Solved]Greek on archlinux

Change the keymap and possibly font.


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#3 2012-04-03 21:20:50

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [Solved]Greek on archlinux

Are you talking about typing in the console or in X?
Using the same font, Terminus, I can see 'ή' in vim in X, but I get a box in the console. I have to use fbterm to get unicode in the console.

Offline

#4 2012-04-03 21:28:44

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,742

Re: [Solved]Greek on archlinux

terminus in tty have several versions for several locales (due to character number limitations and old legacy stuff), so you have to pick the right variant of it. See /usr/share/kbd/consolefonts/README.Lat2-Terminus16

Last edited by Mr.Elendig (2012-04-03 21:31:01)


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#5 2012-04-04 09:40:23

Zapman
Member
Registered: 2012-04-01
Posts: 42

Re: [Solved]Greek on archlinux

I changed keymap and tryed several fonts but no thing changed

# /etc/rc.conf - Main Configuration for Arch Linux
#
# See 'man 5 rc.conf' for more details
#

# LOCALIZATION
# ------------
HARDWARECLOCK="UTC"
TIMEZONE="Europe/Athens"
KEYMAP="gr"
CONSOLEFONT=
CONSOLEMAP=
LOCALE=el_GR.UTF-8
DAEMON_LOCALE="yes"
USECOLOR="yes"

# HARDWARE
# --------
MODULES=(vboxguest vboxsf vboxvideo)
USEDMRAID="no"
USEBTRFS="no"
USELVM="no"

# NETWORKING
# ----------
HOSTNAME="cyanix"

interface=eth0
address=
netmask=
broadcast=
gateway=

NETWORK_PERSIST="no"

# DAEMONS
# -------
#
DAEMONS=(dbus alsa sshd syslog-ng wicd crond)

Offline

#6 2012-04-04 12:46:46

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,742

Re: [Solved]Greek on archlinux

Did you reboot after the change? if no, then you have to use loadkeys. (you might want to use loadkeys anyway to check that the layout applies without errors)

And remember that if you are in X, what layout you have in rc.conf won't matter at all, because X uses different keyboard settings.

Last edited by Mr.Elendig (2012-04-04 12:47:35)


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#7 2012-04-04 13:07:08

Thanoulis
Member
From: Thessaloniki, Greece
Registered: 2009-05-03
Posts: 31
Website

Re: [Solved]Greek on archlinux

1)Edit /etc/locale.gen and uncomment those lines:

el_GR.UTF-8 UTF-8
el_GR ISO-8859-7
en_US.UTF-8 UTF-8
en_US ISO-8859-1

2)Run locale-gen.

3)Edit /etc/rc.conf:

HARDWARECLOCK="UTC"
TIMEZONE="Europe/Athens"
KEYMAP="us"
CONSOLEFONT="ter-v16b" #it's Terminus font for console, just install terminus-font from community
CONSOLEMAP=
LOCALE="en_US.UTF-8"
DAEMON_LOCALE="no"
USECOLOR="yes"

On terminals under X, use Monospace or Dejavu Sans, or any other UTF8 font, or any font with iso8859-7 encoding

4) For keyboard layout toggle, i use

setxkbmap us,gr -option grp:alt_caps_toggle,grp_led:scroll

in my ~/.xinitrc file. Install xorg-setxkbmap from extra. That way, i use Alt+CapsLock to switch layouts.

PS. I'm Greek also and with these settings, i have not trouble reading or writing Greek with any application or terminal.

Last edited by Thanoulis (2012-04-04 13:09:34)


-- Beware of he who would deny you access to information, for in his heart he dreams himself your master.

Offline

#8 2012-04-04 17:21:26

Zapman
Member
Registered: 2012-04-01
Posts: 42

Re: [Solved]Greek on archlinux

Hey thanks! ill try these settings and post back.

Offline

#9 2012-04-05 08:28:55

Zapman
Member
Registered: 2012-04-01
Posts: 42

Re: [Solved]Greek on archlinux

Hey thanks, everything is fixed except that during boot proccess right after locale setting i see a flicker and every character looks like garbage. but the system boots normally and works like a charm. can i get rid or this?

Thanks again

Offline

#10 2012-04-05 09:49:37

birdflesh
Member
From: Greece
Registered: 2010-08-04
Posts: 96

Re: [Solved]Greek on archlinux

I'm not sure if this will fix your new problem, but you can also try CONSOLEFONT="iso07u-16", it is installed by default and works great for me on greek in the console.

Offline

#11 2012-04-05 10:22:35

Zapman
Member
Registered: 2012-04-01
Posts: 42

Re: [Solved]Greek on archlinux

Hey thanks, that did the trick!

Offline

#12 2012-04-05 15:31:26

Thanoulis
Member
From: Thessaloniki, Greece
Registered: 2009-05-03
Posts: 31
Website

Re: [Solved]Greek on archlinux

Zapman wrote:

Hey thanks, everything is fixed except that during boot proccess right after locale setting i see a flicker and every character looks like garbage. but the system boots normally and works like a charm. can i get rid or this?

Sorry about that, you need to add "consolefont" at HOOKS  array in /etc/mkinitcpio.conf and rebuild the ramdisk image as described here: https://wiki.archlinux.org/index.php/Fo … sole_fonts

Last edited by Thanoulis (2012-04-05 15:43:40)


-- Beware of he who would deny you access to information, for in his heart he dreams himself your master.

Offline

#13 2012-04-05 17:17:30

Zapman
Member
Registered: 2012-04-01
Posts: 42

Re: [Solved]Greek on archlinux

nice addition thank you mate smile

Offline

Board footer

Powered by FluxBB