You are not logged in.

#1 2012-04-08 13:51:40

belbo
Member
From: Sydney, Australia
Registered: 2011-02-25
Posts: 51

Can't upgrade because of confilicting files

Good day

I haven't upgraded one of my machines for quite some time, probably a year or more.

I tried upgrading and got a file conflict problem. Here are the commands and output -

[ben@Desktop ~]$ sudo pacman -Suy
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 archlinuxfr is up to date
:: The following packages should be upgraded first :
    pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] 

resolving dependencies...
warning: dependency cycle detected:
warning: udev will be installed before its util-linux dependency
looking for inter-conflicts...
:: kmod and module-init-tools are in conflict. Remove module-init-tools? [y/N] y
:: gnupg and gnupg2 are in conflict. Remove gnupg2? [y/N] y

Targets (57): acl-2.2.51-1  attr-2.4.46-1  bash-4.2.024-2  bzip2-1.0.6-3  ca-certificates-20120212-1  coreutils-8.16-2  cracklib-2.8.18-2  curl-7.25.0-1
              db-5.3.15-1  dirmngr-1.1.0-3  e2fsprogs-1.42.1-1  expat-2.1.0-1  findutils-4.4.2-4  gawk-4.0.1-1  gcc-libs-4.7.0-3  gdbm-1.10-1
              glib2-2.30.2-2  glibc-2.15-10  gmp-5.0.4-1  gnupg-2.0.19-1  gnupg2-2.0.17-1 [removal]  gpgme-1.3.1-4  kmod-7-2  libarchive-3.0.4-1
              libassuan-2.0.3-1  libcap-2.22-2  libffi-3.0.10-1  libgcrypt-1.5.0-1  libgpg-error-1.10-1  libgssglue-0.3-1  libksba-1.2.0-1  libldap-2.4.30-1
              libsasl-2.1.23-9  libssh2-1.4.0-1  libtirpc-0.2.2-2  libusb-1.0.8-2  linux-api-headers-3.3-1  module-init-tools-3.12-2 [removal]
              ncurses-5.9-3  openssl-1.0.1-2  pacman-mirrorlist-20120211-1  pam-1.1.5-2  pciutils-3.1.9-1  pcre-8.30-1  perl-5.14.2-7  pinentry-0.8.1-3
              pth-2.0.7-4  readline-6.2.002-1  run-parts-4.2.1-1  sed-4.2.1-4  tzdata-2012c-1  udev-181-9  usbutils-005-1  util-linux-2.21.1-2  xz-5.0.3-2
              zlib-1.2.6-1  pacman-4.0.2-1

Total Installed Size:   211.99 MiB
Net Upgrade Size:       -1.38 MiB

Proceed with installation? [Y/n] y
(55/55) checking package integrity                                                             [#######################################################] 100%
(55/55) loading package files                                                                  [#######################################################] 100%
(55/55) checking for file conflicts                                                            [#######################################################] 100%
error: failed to commit transaction (conflicting files)
util-linux: /bin/mountpoint exists in filesystem
util-linux: /usr/share/man/man1/mountpoint.1.gz exists in filesystem
Errors occurred, no packages were upgraded.
[ben@Desktop ~]$ pacman -Qo /bin/mountpoint
/bin/mountpoint is owned by sysvinit 2.88-2
[ben@Desktop ~]$ pacman -Qo /usr/share/man/man1/mountpoint.1.gz
/usr/share/man/man1/mountpoint.1.gz is owned by sysvinit 2.88-2

I did the pacman -Qo based on this sticky -
https://bbs.archlinux.org/viewtopic.php?id=130138

I would appreciate some help on what to do now.

Thanks

belbo

Last edited by belbo (2012-04-08 13:55:39)

Offline

#2 2012-04-08 14:09:44

jgreen1tc
Member
From: St. Louis
Registered: 2011-05-16
Posts: 247

Re: Can't upgrade because of confilicting files

The sticky you referenced has nothing to do with the error you have. Pacman didn't abort at all according to your error. It asked for your input. Try googling what happened with the packages in conflict (kmod/module-init-tools and gnupg/gnupg2) and you should find what you need.

Offline

#3 2012-04-08 14:24:08

karol
Archivist
Registered: 2009-05-06
Posts: 25,431

Re: Can't upgrade because of confilicting files

jgreen1tc wrote:

Try googling what happened with the packages in conflict (kmod/module-init-tools and gnupg/gnupg2) and you should find what you need.

That's not the problem [1] - this is:

error: failed to commit transaction (conflicting files)
util-linux: /bin/mountpoint exists in filesystem
util-linux: /usr/share/man/man1/mountpoint.1.gz exists in filesystem
Errors occurred, no packages were upgraded.

https://projects.archlinux.org/svntogit … e35cf4d2ce
Try 'pacman -Syu sysvinit'. Not sure why pacman doesn't list sysvinit as a package that needs to be updated. sysvinit 2.88-3 is in the repos since September and you're still using the previous version.


[1]
* http://www.archlinux.org/news/kmod-repl … nit-tools/
* gnupg thing is just a regular replacement.

Last edited by karol (2012-04-08 14:41:05)

Offline

#4 2012-04-08 22:17:33

bikepunk
Member
Registered: 2010-01-21
Posts: 23

Re: Can't upgrade because of confilicting files

Offline

#5 2012-04-08 22:19:00

karol
Archivist
Registered: 2009-05-06
Posts: 25,431

Re: Can't upgrade because of confilicting files

bikepunk wrote:

Which part of that thread is relevant?

Offline

#6 2012-04-08 22:24:12

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,096
Website

Re: Can't upgrade because of confilicting files

karol wrote:

Which part of that thread is relevant?

The part where you're supposed to say 'no' to the SyncFirst prompt.

Offline

#7 2012-04-08 22:35:27

karol
Archivist
Registered: 2009-05-06
Posts: 25,431

Re: Can't upgrade because of confilicting files

falconindy wrote:
karol wrote:

Which part of that thread is relevant?

The part where you're supposed to say 'no' to the SyncFirst prompt.

Ah, I finally got what happened.


Edit: Sorry, bikepunk.

Last edited by karol (2012-04-08 22:39:03)

Offline

Board footer

Powered by FluxBB