You are not logged in.

#1 2012-04-23 03:32:37

From: Japan
Registered: 2011-11-20
Posts: 60

intel_do_flush_locked error

Exactly what it says on the tin.

I've been encountering this error lately, especially when I try to run stuff with Wine. Doesn't matter if it's older stuff (RPG Maker games) or newer (World of Warcraft) ... the programs just don't start and Wine throws this error message at me.

ranmaru@kodama: ~/Wine/RPGMaker/ % wine RPG_RT.exe
intel_do_flush_locked failed: Input/output error

Searching around the internet I narrowed it down to a video driver problem, but there doesn't seem to be a fix for it. The people on the Wine mailing list also seem to be clueless. Someone suggested somewhere to downgrade mesa, but that also was nothing but a wild guess.

Anyone seen this error before and knows what exactly it means and, hopefully, how to fix it?



#2 2012-04-28 14:56:29

Registered: 2012-04-28
Posts: 16

Re: intel_do_flush_locked error

I have also this error when running a game I am developping using SFML lib.

I searched with a friend for hours and found that it is a driver bug probably caused by the low quality of intel integrated GPU's drivers (kind of outdated from standards) but that some people got it fixed with an update a few weeks ago.

However, any update won't fix my problem up to now, I'm sorry I can't help but I just can tell you're far to be the only one having this trouble! Even on Windows 7 people had this bug but for all I know a driver update fixed it too.


#3 2012-08-18 20:01:47

Registered: 2012-07-16
Posts: 4

Re: intel_do_flush_locked error

I have solved this problem using UXA acceleration method instead of SNA (particularly to run StarCraft through Wine). Look here:

Last edited by Batto (2012-08-18 20:02:16)


#4 2013-03-23 01:28:30

Registered: 2013-03-23
Posts: 4

Re: intel_do_flush_locked error

Sorry to resurrect such an old thread with my first post, but is there any better way this can be fixed? I've been dealing with this for about 5 months by repeatedly downgrading xf86-video-intel and cannot file a bug report because there is no way I know to get enough information. All I know is that any time I try to run something with OpenGL under SNA, it immediately crashes with this error, and UXA is too slow to be usable.

This is the entire contents of my 20-intel.conf:

Section "Device"
    Identifier    "Intel Graphics"
    Driver        "intel"
    VideoRam    1048576
    Option        "AccelMethod"    "sna"        # causes immediate crash of any OpenGL application
    Option        "SwapbuffersWait"    "off"
    Option        "TripleBuffer"        "off"
    Option        "Throttle"        "off"

Oddly enough, everything works fine if I use xf86-video-intel version 2.20.15, but I can't keep ignoring it with every upgrade because the latest versions of just about everything related to xorg require xf86-video-intel >= 2.21.0

I consider invariably crashing on the only decently fast acceleration method to be a serious regression and have only delayed posting this because of the ability to downgrade, which I can no longer do without affecting a very large number of packages.


#5 2013-04-11 14:33:32

Registered: 2013-04-11
Posts: 1

Re: intel_do_flush_locked error

I had the same problem. In my case the i915 module of Kernel 3.0.72 was not able to reset the crashed GPU (intel 945). I had to install an "older" kernel version (3.0.52) and the problem was solved.


#6 2014-03-21 03:36:02

Registered: 2013-05-22
Posts: 6

Re: intel_do_flush_locked error

I've been having the same problem after a recent update of xf86-video-intel, namely from 2.99.907-2 to 2.99.910-1.
I can roll back without breaking any dependencies for now, but I'm still baffled at the error, I don't have a clue about what's causing it or how else to fix it.


#7 2014-03-21 07:26:03

Registered: 2009-05-06
Posts: 25,440

Re: intel_do_flush_locked error

Do you have problems with both UXA and SNA?


Board footer

Powered by FluxBB