You are not logged in.

#1 2012-04-25 19:37:18

replabrobin
Member
Registered: 2010-05-06
Posts: 159

usb rocket launcher

I bought a geek gadget (dream cheeky usb Thunder/Storm  rocket launcher) for the kids in my office. It has a usb which connects to a hub having two devices one for control and one for a webcam. They are running ubuntu 11.10 and are able to use the webcam and the contol software (https://github.com/nmilford/stormLauncher).

I tried this on my arch system and although I can get the controls to work I cannot seem to get the webcam recognized.

In the log I see this

Apr 25 17:36:05 everest kernel: [603357.163018] usb 1-7: new high-speed USB device number 11 using ehci_hcd
Apr 25 17:36:05 everest kernel: [603357.287005] hub 1-7:1.0: USB hub found
Apr 25 17:36:05 everest kernel: [603357.287055] hub 1-7:1.0: 4 ports detected
Apr 25 17:36:06 everest kernel: [603357.566523] usb 1-7.1: new low-speed USB device number 12 using ehci_hcd
Apr 25 17:36:06 everest kernel: [603357.671410] generic-usb 0003:2123:1010.0004: hiddev0,hidraw0: USB HID v1.10 Device [Syntek USB Missile Launc
Apr 25 17:36:06 everest kernel: [603357.749745] usb 1-7.2: new high-speed USB device number 13 using ehci_hcd
Apr 25 17:36:06 everest kernel: [603357.864883] uvcvideo: Found UVC 1.00 device Altair USB2.0 Camera (0ac8:3450)
Apr 25 17:36:06 everest kernel: [603357.866769] input: Altair USB2.0 Camera as /devices/pci0000:00/0000:00:1d.7/usb1/1-7/1-7.2/1-7.2:1.0/input/i
Apr 25 17:36:07 everest mtp-probe: checking bus 1, device 13: "/sys/devices/pci0000:00/0000:00:1d.7/usb1/1-7/1-7.2"
Apr 25 17:36:07 everest mtp-probe: bus: 1, device: 13 was not an MTP device
Apr 25 17:36:07 everest mtp-probe: checking bus 1, device 12: "/sys/devices/pci0000:00/0000:00:1d.7/usb1/1-7/1-7.1"

and even though I can modprobe uvcvideo I can't get cheese to see the camera. I tried removing /usr/lib/udev/rules.d/69-libmtp.rules,
but that doesn't seem to improve the situation much. Basically the mtp-probe messages go away, but cheese still doesn't work.

The wiki entry https://wiki.archlinux.org/index.php/Webcam & http://www.ideasonboard.org/uvc/ seem to indicate that the webcam should be ok,
but I am stuck. Any ideas? I need to retaliate against the ubuntuite youngsters smile

Offline

#2 2012-04-25 22:41:40

pigiron
Member
From: USA
Registered: 2009-07-14
Posts: 139

Re: usb rocket launcher

Apr 25 17:36:07 everest mtp-probe: bus: 1, device: 13 was not an MTP device

That is an information message and not an error message. It simply means that the device doesn't use the Media Transfer Protocol.

Starting with the simple stuff... is a /dev/video? device created?

If so, is your User ID in the "video" group?

Offline

#3 2012-04-26 07:32:26

replabrobin
Member
Registered: 2010-05-06
Posts: 159

Re: usb rocket launcher

/dev/video0 does exist; and I did check that it comes and goes with the usb being present or not. According to groups I do seem to be in the  video group.
I got an error related to formats when cheese runs something like "WARNING **: Could not negotiate format".

Offline

#4 2012-04-27 17:04:55

replabrobin
Member
Registered: 2010-05-06
Posts: 159

Re: usb rocket launcher

SOLVED: I find I can use the camera on the thunder storm launcher with mplayer I have to a command like

mplayer tv:// -tv driver=v4l2:width=640:height=480:device=/dev/video0 -nosound

and then it works fine. I have retaliated against the ubuntist faction and Arch reigns supreme smile

I am a bit mystified why cheese cannot negotiate a format. Perhaps I need to explore some of the LD_PRELOAD tricks.

Offline

Board footer

Powered by FluxBB