You are not logged in.

#1 2012-05-12 10:22:28

tomek@vz
Member
Registered: 2009-07-20
Posts: 33

Pulseaudio not starting

30 minutes back from now everything worked fine. Updated Arch, and now i see the volume applet in Gnome does not start...ok...

 (gnome-sound-applet:1480): sound-cc-panel-WARNING **: Failed to connect context: Connection refused

Hm...pulseaudio also does not work...

E: [pulseaudio] module.c: Failed to open module "module-cork-music-on-phone": file not found
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.

So any ideas?


For some tasks, the CLI is quicker. That's not elitism nor arrogance, that's just a fact of life.

Offline

#2 2012-05-12 10:58:08

toad
Member
From: if only I knew
Registered: 2008-12-22
Posts: 1,775
Website

Re: Pulseaudio not starting

Wasn't there a pacnew file for pulseaudio? Haven't checked it yet but perhaps worth a look.


never trust a toad...
::Grateful ArchDonor::
::Grateful Wikipedia Donor::

Offline

#3 2012-05-12 11:00:26

OldFuzzface
Member
Registered: 2012-05-12
Posts: 7

Re: Pulseaudio not starting

same problem here. quick fix (for me): downgrade pulseaudio and libpulse to 1.1-4.

Offline

#4 2012-05-12 11:09:46

tomek@vz
Member
Registered: 2009-07-20
Posts: 33

Re: Pulseaudio not starting

toad wrote:

Wasn't there a pacnew file for pulseaudio? Haven't checked it yet but perhaps worth a look.

Yep - thanks for bringing that up. Replaced old conf with new and now it all works again, problem solved smile


For some tasks, the CLI is quicker. That's not elitism nor arrogance, that's just a fact of life.

Offline

#5 2012-05-12 11:24:35

amtrack
Member
Registered: 2012-05-12
Posts: 3

Re: Pulseaudio not starting

I think there is no need to downgrade.

Changing the line in $HOME/.pulse/default.pa from
load-module module-cork-music-on-phone
to
load-module module-role-cork
worked for me

Offline

#6 2012-05-12 12:35:19

olorian
Member
Registered: 2011-12-16
Posts: 86

Re: Pulseaudio not starting

Editing /etc/pulse/default.pa (as I don't have any default.pa in my home folder AND I wished to apply the fix system-wide) as amtrack suggested did the trick for me too. Thank you very much!

Offline

#7 2012-05-13 19:43:14

omer666
Member
Registered: 2011-01-26
Posts: 70

Re: Pulseaudio not starting

What is this pacnew file ? Where is it located ? I've got no message from pacman, nothing in /etc. Also I tried the default.pa trick but it was already this way. I don't have any sound and I'm really loosing my tempe

[Edit] Resolved !
Don't ever try to solve problems on the evening. The master channel was mutted after the update because my soundcard is not well recognised, that's all. Got to do some tricks and that will work fine.

[Edit 2] In the end it seems that I was using a deprecated asoundrc.conf in /etc.

Last edited by omer666 (2012-05-14 06:26:38)

Offline

#8 2012-05-15 16:04:54

h54
Member
Registered: 2011-11-22
Posts: 96

Re: Pulseaudio not starting

omer666 wrote:

What is this pacnew file ? Where is it located ? I've got no message from pacman, nothing in /etc. Also I tried the default.pa trick but it was already this way. I don't have any sound and I'm really loosing my tempe

[Edit] Resolved !
Don't ever try to solve problems on the evening. The master channel was mutted after the update because my soundcard is not well recognised, that's all. Got to do some tricks and that will work fine.

[Edit 2] In the end it seems that I was using a deprecated asoundrc.conf in /etc.


How exactly did you fix it?  I am getting no sound (tray icon flickers) when I attempt to configure and test speakers/sound devices.  I even clean installed a few times just to make sure that I didn't mess something up.

There are no pacnew files either...

Offline

#9 2012-05-15 16:48:37

marvn
Member
From: Prague
Registered: 2010-01-05
Posts: 84

Re: Pulseaudio not starting

h54 wrote:
omer666 wrote:

What is this pacnew file ? Where is it located ? I've got no message from pacman, nothing in /etc. Also I tried the default.pa trick but it was already this way. I don't have any sound and I'm really loosing my tempe

[Edit] Resolved !
Don't ever try to solve problems on the evening. The master channel was mutted after the update because my soundcard is not well recognised, that's all. Got to do some tricks and that will work fine.

[Edit 2] In the end it seems that I was using a deprecated asoundrc.conf in /etc.


How exactly did you fix it?  I am getting no sound (tray icon flickers) when I attempt to configure and test speakers/sound devices.  I even clean installed a few times just to make sure that I didn't mess something up.

There are no pacnew files either...

look into /etc/pluse/ dir, there should be default.pa and default.pa.pacnew. use the pacnew (mv default.pa.pacnew dafault.pa) or merge it somehow. "pulseaudio --start" to test if it's starting. if it does, reboot and everything should be working again...


core i5 4590, x86_64, nvidia 970

Offline

#10 2012-05-15 19:41:58

h54
Member
Registered: 2011-11-22
Posts: 96

Re: Pulseaudio not starting

marvn wrote:
h54 wrote:
omer666 wrote:

What is this pacnew file ? Where is it located ? I've got no message from pacman, nothing in /etc. Also I tried the default.pa trick but it was already this way. I don't have any sound and I'm really loosing my tempe

[Edit] Resolved !
Don't ever try to solve problems on the evening. The master channel was mutted after the update because my soundcard is not well recognised, that's all. Got to do some tricks and that will work fine.

[Edit 2] In the end it seems that I was using a deprecated asoundrc.conf in /etc.


How exactly did you fix it?  I am getting no sound (tray icon flickers) when I attempt to configure and test speakers/sound devices.  I even clean installed a few times just to make sure that I didn't mess something up.

There are no pacnew files either...

look into /etc/pluse/ dir, there should be default.pa and default.pa.pacnew. use the pacnew (mv default.pa.pacnew dafault.pa) or merge it somehow. "pulseaudio --start" to test if it's starting. if it does, reboot and everything should be working again...


Thanks, thats exactly where I looked once it updated and there was no pacnew.  This is so confounding because I've dealt with pacnew files before and it has never been an issue.  I'm formatting again just to make sure.


Thanks for the reply.

Offline

#11 2012-05-16 05:54:15

toad
Member
From: if only I knew
Registered: 2008-12-22
Posts: 1,775
Website

Re: Pulseaudio not starting

A simple "locate pacnew" should do it. Alternatively use pacmatic instead of pacman to keep abreast of stuff.


never trust a toad...
::Grateful ArchDonor::
::Grateful Wikipedia Donor::

Offline

#12 2012-05-16 14:13:53

fantab
Member
From: 3rd Rock from the Sun
Registered: 2011-06-07
Posts: 152

Re: Pulseaudio not starting

PulseAudio is not working when I try to start it I get an error: Daemon startup failed. (By the way, I have sound and I can play my music and videos; system beep also works). There is no icon in the top bar (gnome-shell) and system settings-sound is non functional.

I followed this:
$ pulseaudio --kill
$ killall pulseaudio
$ killall -9 pulseaudio
$ rm -rf ~/.pulse*
$ rm -rf /tmp/pulse*
$ pulseaudio --start

It didn't help, so I used verbose -vvvv and found following errors:

E: [pulseaudio] module-equalizer-sink.c: No resume state
E: [pulseaudio] module.c: Failed to open module "module-cork-music-on-phone": file not found
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.

I need forum help to resolve this issue.

Thanks...


"Evolution is the nature's way of issuing upgrades".
__________________________________________________________
Arch_x64-Gnome-Shell ~ Arch-lts_x64-Xfce ~ Trusty Thar_x64-Unity ~ LMDE_x64-Cinnamon

Offline

#13 2012-05-16 14:45:49

h54
Member
Registered: 2011-11-22
Posts: 96

Re: Pulseaudio not starting

toad wrote:

A simple "locate pacnew" should do it. Alternatively use pacmatic instead of pacman to keep abreast of stuff.


Thanks, will do from now on.

Offline

#14 2012-05-16 15:01:55

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,002

Re: Pulseaudio not starting

@fantab: Did you change anything in /etc/pulse ??

Are there any *.pacnew files in /etc/pulse that need to be merged?
Is your system fully up to date ? (Have you run pacman -Syu   ??)


Edit:  Noted the other thread.  Check for  pacnew files

Last edited by ewaller (2012-05-16 15:18:15)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#15 2012-05-16 15:17:09

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,002

Re: Pulseaudio not starting

Moderator:  Noted there were two threads running.  Merged.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#16 2012-05-16 18:10:39

marvn
Member
From: Prague
Registered: 2010-01-05
Posts: 84

Re: Pulseaudio not starting

fantab wrote:

PulseAudio is not working when I try to start it I get an error: Daemon startup failed. (By the way, I have sound and I can play my music and videos; system beep also works). There is no icon in the top bar (gnome-shell) and system settings-sound is non functional.

I followed this:
$ pulseaudio --kill
$ killall pulseaudio
$ killall -9 pulseaudio
$ rm -rf ~/.pulse*
$ rm -rf /tmp/pulse*
$ pulseaudio --start

It didn't help, so I used verbose -vvvv and found following errors:

E: [pulseaudio] module-equalizer-sink.c: No resume state
E: [pulseaudio] module.c: Failed to open module "module-cork-music-on-phone": file not found
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.

I need forum help to resolve this issue.

Thanks...

Well, "module-cork-music-on-phone" shouldn't be loading. You can try "rm /etc/pulse/default.pa && pacman -S libpulse pulseaudio" ... than the default.pa file will be the default one and "pulseaudio --start" should work


core i5 4590, x86_64, nvidia 970

Offline

#17 2012-05-17 02:36:39

fantab
Member
From: 3rd Rock from the Sun
Registered: 2011-06-07
Posts: 152

Re: Pulseaudio not starting

ewaller wrote:

@fantab: Did you change anything in /etc/pulse ??

Are there any *.pacnew files in /etc/pulse that need to be merged?
Is your system fully up to date ? (Have you run pacman -Syu   ??)


Edit:  Noted the other thread.  Check for  pacnew files

Yes, there was a default.pa.pacnew file in /etc/pulse/. I merged it with default.pa but it did not solve my problem. I  kept getting the exact same message as I have posted above. However:

marvn wrote:

Well, "module-cork-music-on-phone" shouldn't be loading. You can try "rm /etc/pulse/default.pa && pacman -S libpulse pulseaudio" ... than the default.pa file will be the default one and "pulseaudio --start" should work

Thanks for your observation, marvn. I just edited /etc/pulse/default.pa and commented out the following line:

#load-module module-cork-music-on-phone

And now PulseAudio is working again. Will there be any issues later on having edited the said file the way I did?

@ewaller: I didn't realize that you have moved my first post and thought that I may not have posted properly and created the second topic.

Thanks to you all...

Last edited by fantab (2012-05-17 02:45:21)


"Evolution is the nature's way of issuing upgrades".
__________________________________________________________
Arch_x64-Gnome-Shell ~ Arch-lts_x64-Xfce ~ Trusty Thar_x64-Unity ~ LMDE_x64-Cinnamon

Offline

#18 2012-05-17 05:41:46

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,002

Re: Pulseaudio not starting

fantab wrote:

@ewaller: I didn't realize that you have moved my first post and thought that I may not have posted properly and created the second topic. ..

No worries.   If I came across as being curt, it is probably because I was in a fighting mode day at the $DAYJOB.  I  may have hit you with my negative karma -- sorry about that.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#19 2012-05-18 15:44:14

h54
Member
Registered: 2011-11-22
Posts: 96

Re: Pulseaudio not starting

Well, after another clean format and trying for a few hours to pulse working, I downgrade pulseaudio and libpulse to the previous version and added them to the ignore packages list in pacman.conf.  I have no issues now.  Too bad...

Offline

#20 2012-05-19 05:01:17

dunkles
Member
From: Chile
Registered: 2010-04-26
Posts: 64

Re: Pulseaudio not starting

same problem here, please update the packages and fix this error sad

Offline

#21 2012-12-24 02:29:20

bassu
Member
Registered: 2011-12-21
Posts: 90

Re: Pulseaudio not starting

fantab wrote:

I followed this:
$ pulseaudio --kill
$ killall pulseaudio
$ killall -9 pulseaudio
$ rm -rf ~/.pulse*
$ rm -rf /tmp/pulse*
$ pulseaudio --start

Deleting the profile files will remove alamixer settings. If you do that, you have to unmute mixers by pressing "m" after launching alsamixer or in GUI. You forgot to mention that.


The greatest threat to knowledge is not ignorance - it is the illusion of knowledge!

Offline

Board footer

Powered by FluxBB