You are not logged in.

#1 2012-05-17 23:13:39

dioltas
Member
Registered: 2009-06-03
Posts: 44

[SOLVED] Bumblebee / Optirun / BBSwitch / Nvidia issues since upgrade

Hello,

I haven't tried using bumblebee's optirun for a while, but after trying today it doesn't seem to work. Also my fan is running constantly so I'm guessing the graphics card is on all the time.

This was the error I was getting when trying

$optirun glxspheres 
[ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module "nouveau" (module does not exist, 0)

[ERROR]Aborting because fallback start is disabled.

I tried doing a full system upgrade, updating all packages from the AUR, and reinstalling dkms-bbswitch, nvidia-utils-bumblebee, dkms-nvidia, bumblebee. But none of this seemed to have helped.

nouveau is blacklisted in /etc/modules.d/, and it's not even installed. But when I did

lsmod | grep nouveau

there was several entries..

After rebooting, I removed the nouveau module, and tried to "modprobe nvidia". It complained that the module didn't exist. I looked in /etc/bumblebee/bumblebee.conf, and the Driver field was not set, so I set it to nvidia.

After all this the error message had changed to:

$ optirun glxspheres
[ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module "mouse" (module does not exist, 0)

[ERROR]Aborting because fallback start is disabled.

And now somehow, nvidia was listed by lsmod. When I restarted bumblebeed, it did seem to stop the fan, but still optirun does not work. Now when I check nvidia is no longer listed!

I've tried so many things now that I'm just not sure what's going on anymore. It used to work fine.

My graphics card is GT555M. Here is my bumblebee.conf.

When I try to modprobe / insmod nvidia, I get an error.

$ sudo modprobe nvidia
ERROR: could not insert 'nvidia': No such device
$ sudo insmod /var/lib/dkms/nvidia/295.49/3.3.6-1-ARCH/x86_64/module/nvidia.ko
Error: could not insert module /var/lib/dkms/nvidia/295.49/3.3.6-1-ARCH/x86_64/module/nvidia.ko: No such device
$ locate nvidia | grep ko
/lib/modules/3.3.6-1-ARCH/kernel/drivers/net/ethernet/nvidia/forcedeth.ko.gz
/lib/modules/3.3.6-1-ARCH/kernel/drivers/video/nvidia.ko
/var/lib/dkms/nvidia/295.49/3.3.6-1-ARCH/x86_64/module/nvidia.ko

Thanks for your help.

Last edited by dioltas (2012-05-20 13:12:52)

Offline

#2 2012-05-18 11:08:12

erdk
Member
From: Gdansk, Poland
Registered: 2012-01-23
Posts: 15

Re: [SOLVED] Bumblebee / Optirun / BBSwitch / Nvidia issues since upgrade

Could you post your /etc/bumblebee/xorg.conf.nvidia? This error about missing 'mouse' module is strange...

It's normal, that you cannot insert nvidia module, because bbswitch is running and physically turning off nvidia card: from system point of view there's no such device.
You could test it by this:
# echo ON >> /proc/acpi/bbswitch
# modprobe nvidia


Archlinux, CentOS 7
Github | Deviantart

Offline

#3 2012-05-18 14:07:51

dphoyes
Member
Registered: 2009-02-19
Posts: 8

Re: [SOLVED] Bumblebee / Optirun / BBSwitch / Nvidia issues since upgrade

I am having very similar issues. Before upgrading yesterday Bumblebee was working great. Now:

$ optirun -vv glxgears
[DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[INFO]Configured driver: nvidia
[DEBUG]Skipping auto-detection, using configured driver 'nvidia'
[DEBUG]Process modinfo started, PID 29960.
[DEBUG]Hiding stderr for execution of modinfo
[DEBUG]SIGCHILD received, but wait failed with No child processes
[DEBUG]Active configuration:
[DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[DEBUG] X display: :8
[DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia-bumblebee:/usr/lib32/nvidia-bumblebee
[DEBUG] Socket path: /var/run/bumblebee.socket
[DEBUG] VGL Compression: proxy
[DEBUG]optirun version 3.0 starting...
[INFO]Response: No - error: [XORG] (EE) Failed to load module "mouse" (module does not exist, 0)

[ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module "mouse" (module does not exist, 0)

[DEBUG]Socket closed.
[ERROR]Aborting because fallback start is disabled.
[DEBUG]Killing all remaining processes.
[1] :( 

bumblebeed starts without any errors, and successfully powers off the nvidia card using bbswitch. Having said that, the card doesn't get turned off again after generating the above errors.

My bumblebee.conf:

# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
[bumblebeed]
# The secondary Xorg server DISPLAY number
VirtualDisplay=:8
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
KeepUnusedXServer=false
# The name of the Bumbleblee server group name (GID name)
ServerGroup=bumblebee
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
TurnCardOffAtExit=false
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
NoEcoModeOverride=false
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=nvidia

## Client options. Will take effect on the next optirun executed.
[optirun]
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
VGLTransport=proxy
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?
AllowFallbackToIGC=false


# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
#         bbswitch - new in BB 3, recommended if available
#       switcheroo - vga_switcheroo method
#             none - disable PM completely
# https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia
Module=nvidia
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/nvidia-bumblebee:/usr/lib32/nvidia-bumblebee
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia-bumblebee/xorg/,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

## Section with nouveau driver specific options, only parsed if Driver=nouveau
[driver-nouveau]
KernelDriver=nouveau
PMMethod=auto
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau

My xorg.conf.nvidia:

Section "ServerLayout"
    Identifier "Layout0"
    Option "AutoAddDevices" "false"
EndSection

Section "Device"
    Identifier "Device1"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    Option "NoLogo" "true"
    Option "UseEDID" "false"
    Option "ConnectedMonitor" "DFP"
EndSection

Offline

#4 2012-05-18 20:08:49

dioltas
Member
Registered: 2009-06-03
Posts: 44

Re: [SOLVED] Bumblebee / Optirun / BBSwitch / Nvidia issues since upgrade

Thanks for the replies.

I did not know about the -vv option to optirun. The issues do seem very similar, starting bumblebeed for me seems to turn off the card, but as you said when I try to use optirun it seems to stay on.

Here is my verbose output:

$ optirun -vv glxspheres 
[DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[DEBUG]Process modinfo started, PID 13776.
[DEBUG]Hiding stderr for execution of modinfo
[DEBUG]SIGCHILD received, but wait failed with No child processes
[DEBUG]Detected nvidia driver (module nvidia)
[DEBUG]Active configuration:
[DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[DEBUG] X display: :8
[DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia-bumblebee:/usr/lib32/nvidia-bumblebee
[DEBUG] Socket path: /var/run/bumblebee.socket
[DEBUG] VGL Compression: proxy
[DEBUG]optirun version 3.0 starting...
[INFO]Response: No - error: [XORG] (EE) Failed to load module "mouse" (module does not exist, 0)

[ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module "mouse" (module does not exist, 0)

[DEBUG]Socket closed.
[ERROR]Aborting because fallback start is disabled.
[DEBUG]Killing all remaining processes.

Seems to be exactly the same.

Here is my xorg.nvidia.conf,

Section "ServerLayout"
    Identifier "Layout0"
    Option "AutoAddDevices" "false"
EndSection

Section "Device"
    Identifier "Device1"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    Option "NoLogo" "true"
    Option "UseEDID" "false"
    Option "ConnectedMonitor" "DFP"
EndSection

Again, same as yours, as I haven't changed it.

After trying to use optirun, nvidia module seems to be now loaded, and modprobe doesn't give any errors. After restarting bumblebeed, nvidia module is no longer loaded, but I can load / remove it.

$ cat /proc/acpi/bbswitch 
0000:01:00.0 ON

So that makes sense.

# echo OFF >> /proc/acpi/bbswitch
# cat /proc/acpi/bbswitch 
0000:01:00.0 ON
# rmmod nvidia
# lsmod | grep nvid
# echo OFF >> /proc/acpi/bbswitch
# cat /proc/acpi/bbswitch 
0000:01:00.0 OFF

Seems it wouldn't turn off until I removed the nvidia module, although maybe I just needed to wait for a while.

Then I tried this:

modprobe nvidia
# lsmod | grep nvid
nvidia              12275463  0 
i2c_core               20593  7 i2c_i801,drm,drm_kms_helper,i2c_algo_bit,i915,videodev,nvidia
# cat /proc/acpi/bbswitch 
0000:01:00.0 ON
# echo OFF >> /proc/acpi/bbswitch
# cat /proc/acpi/bbswitch 
0000:01:00.0 ON
# cat /proc/acpi/bbswitch 
0000:01:00.0 ON
# echo OFF >> /proc/acpi/bbswitch
# cat /proc/acpi/bbswitch 
0000:01:00.0 ON
# rmmod nvidia
# cat /proc/acpi/bbswitch 
0000:01:00.0 ON
# echo OFF >> /proc/acpi/bbswitch
# cat /proc/acpi/bbswitch 
0000:01:00.0 OFF

It seems that it changed to ON when I loaded nvidia, and would only go to OFF when the module was removed.

At least I now know how to stop it so that the fan will switch off.
The failed to load "mouse" message is very confusing. It was nouveau at first, so I'm not too sure what's going on.

These are the packages I have installed:

bumblebee 3.0-3
dkms-bbswitch 0.4.2-1
dkms-nvidia 295.49-1
lib32-nvidia-utils 295.53-1
nvidia-utils-bumblebee 295.53-1

dkms daemon wasn't running when I updated (as I didn't know about it), not sure if that makes a difference. I've added it to my rc.conf, but when I check now, it doesn't seem to be running either.

Offline

#5 2012-05-19 15:12:58

dphoyes
Member
Registered: 2009-02-19
Posts: 8

Re: [SOLVED] Bumblebee / Optirun / BBSwitch / Nvidia issues since upgrade

I tried installing xf86-input-mouse. This got rid of the mouse complaints. Instead, I now get:

$ optirun glxgears
[ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module. Please see the

[ERROR]Aborting because fallback start is disabled.
[1] :( 

The full output generated by the bumblebee server is:

[WARN][XORG] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[WARN][XORG] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[ERROR][XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module. Please see the
[ERROR][XORG] (EE) NVIDIA(0):     system's kernel log for additional error messages and
[ERROR][XORG] (EE) NVIDIA(0):     consult the NVIDIA README for details.
[ERROR][XORG] (EE) NVIDIA(0):  *** Aborting ***
[ERROR][XORG] (EE) Screen(s) found, but none have a usable configuration.
[ERROR]X did not start properly

EDIT: Now managed to narrow the problems down to a single package. Downgrading nvidia-utils-bumblebee to 295.49 fixes everything.

Last edited by dphoyes (2012-05-19 16:35:09)

Offline

#6 2012-05-19 20:18:07

samsagax
Member
Registered: 2011-03-18
Posts: 33

Re: [SOLVED] Bumblebee / Optirun / BBSwitch / Nvidia issues since upgrade

These are the packages I have installed:

bumblebee 3.0-3
dkms-bbswitch 0.4.2-1
dkms-nvidia 295.49-1
lib32-nvidia-utils 295.53-1
nvidia-utils-bumblebee 295.53-1

dkms daemon wasn't running when I updated (as I didn't know about it), not sure if that makes a difference. I've added it to my rc.conf, but when I check now, it doesn't seem to be running either.

Seems that dkms-nvidia is not updated. There is an api mismatch error on your nvidia installation. Should dkms-nvidia package be updated.

Offline

#7 2012-05-20 13:12:16

dioltas
Member
Registered: 2009-06-03
Posts: 44

Re: [SOLVED] Bumblebee / Optirun / BBSwitch / Nvidia issues since upgrade

samsagax wrote:

These are the packages I have installed:

bumblebee 3.0-3
dkms-bbswitch 0.4.2-1
dkms-nvidia 295.49-1
lib32-nvidia-utils 295.53-1
nvidia-utils-bumblebee 295.53-1

dkms daemon wasn't running when I updated (as I didn't know about it), not sure if that makes a difference. I've added it to my rc.conf, but when I check now, it doesn't seem to be running either.

Seems that dkms-nvidia is not updated. There is an api mismatch error on your nvidia installation. Should dkms-nvidia package be updated.


Well spotted! I totally missed that.

I had switched to dkms-nvidia due to a previous issue causing bumblebee to not work.

I removed dkms-nvidia and installed nvidia-bumblebee 295.53-1, and now it's working fine again.

Just checked the AUR, and the dkms-nvidia package has already been flagged out of date.

Will mark the thread as solved, seems this version mismatch was all that was causing the issue.

Offline

Board footer

Powered by FluxBB