You are not logged in.

#1 2012-05-24 14:12:15

tkdncty2
Member
From: Budapest,Hungary
Registered: 2012-05-24
Posts: 24

[SOLVED] Some UTF-8 Hungarian fonts display as squares

Hello everyone!

I installed Arch and in the installer, after I set the Hungarian keyboard all the accented letters (öüóőúéáűí) displayed correctly.

I configured the localization in /etc/rc.conf and made the Hungarian locale available.

When the system started up after install, some fonts work (like é and á) and some (like ű) display as a square.

If I set the locale to the iso88592 from the UTF version, all the accented letters appear, but the accents themselves appear wrongly.

The relevant part from my rc.conf:

    KEYMAP="hu.map.gz"
    CONSOLEFONT="lat2-16.psfu.gz"
    CONSOLEMAP=
    LOCALE="hu_HU.utf8"
    DAEMON_LOCALE="yes"
    USECOLOR="yes"

Do you know what the problem could be?

Last edited by tkdncty2 (2012-05-25 07:59:02)

Offline

#2 2012-05-24 14:17:53

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 4,068

Re: [SOLVED] Some UTF-8 Hungarian fonts display as squares

squares == the font does not have the character.

Leave the locale as utf8, it is not the problem, but find some font that has the characters you need.


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#3 2012-05-24 16:09:52

tkdncty2
Member
From: Budapest,Hungary
Registered: 2012-05-24
Posts: 24

Re: [SOLVED] Some UTF-8 Hungarian fonts display as squares

I booted the netinstall CD, selected "hu.map.gz" as the keymap and "lat2-16.psfu.gz" as the consolefont, and on the netinstall CD, all the hungarian characters worked correctly.

What could be different on the installed system that prevents it from working?


Edit:

It appears that this could be traced back to this bug:
https://bugs.archlinux.org/task/29781

Setting the fonts with the "setfont" command does work, but when I restart the system it forgets it, maybe because of the graphics driver as someone mentioned in the comments.

Last edited by tkdncty2 (2012-05-24 16:40:48)

Offline

#4 2012-05-24 17:35:49

scar
Member
From: Hungary
Registered: 2009-10-01
Posts: 430

Re: [SOLVED] Some UTF-8 Hungarian fonts display as squares

Here is the relevant section of my /etc/rc.conf, I'm hungarian too.
Be careful with typos.

LOCALE="hu_HU.UTF-8"
DAEMON_LOCALE="no"
HARDWARECLOCK="UTC"
TIMEZONE="Europe/Budapest"
KEYMAP="hu"
CONSOLEFONT="lat2-16"
CONSOLEMAP=
USECOLOR="yes"


“The future has already arrived. It's just not evenly distributed yet.”
― William Gibson

Offline

#5 2012-05-24 20:54:54

tkdncty2
Member
From: Budapest,Hungary
Registered: 2012-05-24
Posts: 24

Re: [SOLVED] Some UTF-8 Hungarian fonts display as squares

Thanks, I tried out your version of the conf file, but it didn't solve the problem for me.

Edit:

It seems like the culprit was the noveau driver. I installed NVIDIA, and everything works now.

Last edited by tkdncty2 (2012-05-24 21:01:04)

Offline

Board footer

Powered by FluxBB