You are not logged in.

#1 2012-05-31 21:05:52

maistora
Member
Registered: 2012-05-31
Posts: 3

Troubles after installing Catalyst and re-installing KDE

Hi everybody, when I was installing arch I was following the wiki and installed the open source driver xf86-video-ati and KDE (the last version in the repository). After that everything worked fine, until I heard about some nice games that run on Linux. This is the place where the troubles began. I read that I should switch video drivers with the catalyst ones for better 3D performance. After a couple painful days I had the Catalyst working... or had I. In this painful period I uninstalled the xf86-video-ati driver, installed the Catalyst (several times), after that I had many crashes from the KDE so I decided to re-install it too :] So the result from all this is: I can play the games that I wanted, but many of the nice KDE effects disappear (ex. the window switching - whatever type of window switch I select I get the basic one) plus the synaptics drivers don't work. I also found some errors in the /var/log/kdm.log file:

X.Org X Server 1.11.4
Release Date: 2012-01-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.2-1-ARCH x86_64 
Current Operating System: Linux sphex 3.3.6-1-ARCH #1 SMP PREEMPT Sun May 13 10:52:32 CEST 2012 x86_64
Kernel command line: root=/dev/sda2 ro nomodeset
Build Date: 29 January 2012  03:38:00PM
 
Current version of pixman: 0.24.4
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu May 31 21:56:50 2012
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(EE) module ABI major version (16) doesn't match the server's version (13)
(EE) Failed to load module "synaptics" (module requirement mismatch, 0)
(EE) No input driver matching `synaptics'
(EE) fglrx(0): Can not enable interrupt sourceID 0xff000066!
klauncher(586) kdemain: No DBUS session-bus found. Check if you have started the DBUS server. 
kdeinit4: Communication error with launcher. Exiting!
kdmgreet(580)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed:  "Not connected to D-Bus server" 

kdmgreet(580)/kdecore (K*TimeZone*): No time zone information obtained from ktimezoned 
(EE) fglrx(0): Can not enable interrupt sourceID 0xff000066!
(EE) fglrx(0): Can not enable interrupt sourceID 0xff000066!
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Compat map for group 2 redefined
>                   Using new definition
> Warning:          Compat map for group 3 redefined
>                   Using new definition
> Warning:          Compat map for group 4 redefined
>                   Using new definition
Errors from xkbcomp are not fatal to the X server
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Compat map for group 2 redefined
>                   Using new definition
> Warning:          Compat map for group 3 redefined
>                   Using new definition
> Warning:          Compat map for group 4 redefined
>                   Using new definition
Errors from xkbcomp are not fatal to the X server
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Compat map for group 2 redefined
>                   Using new definition
> Warning:          Compat map for group 3 redefined
>                   Using new definition
> Warning:          Compat map for group 4 redefined
>                   Using new definition
Errors from xkbcomp are not fatal to the X server
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Compat map for group 2 redefined
>                   Using new definition
> Warning:          Compat map for group 3 redefined
>                   Using new definition
> Warning:          Compat map for group 4 redefined
>                   Using new definition
Errors from xkbcomp are not fatal to the X server
(EE) fglrx(0): Can not enable interrupt sourceID 0xff000066!
(EE) fglrx(0): Can not enable interrupt sourceID 0xff000066!
(EE) fglrx(0): Can not enable interrupt sourceID 0xff000066!

Same errors are seen in /var/log/Xorg.0.log. What causes them? Could this be the root problem for all others?
Here is also my /etc/X11/xorg.conf

Section "ServerLayout"
        Identifier     "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:1:0:0"
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

EDIT:
Here is some more info on my graphics card:

01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV620 [Mobility Radeon HD 3400 Series] (prog-if 00 [VGA controller])
        Subsystem: ASUSTeK Computer Inc. Device 19e2
        Flags: bus master, fast devsel, latency 0, IRQ 40
        Memory at c0000000 (32-bit, prefetchable) [size=512M]
        I/O ports at d800 [size=256]
        Memory at fdef0000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at fdec0000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: fglrx_pci

Any help would be highly appreciated.

Last edited by maistora (2012-05-31 21:34:25)

Offline

#2 2012-05-31 22:06:33

eticre
Member
Registered: 2011-10-15
Posts: 49

Re: Troubles after installing Catalyst and re-installing KDE

hi

try  boot without any xorg.conf or try in xorg.conf
Driver "ati"

Offline

#3 2012-06-01 21:43:09

maistora
Member
Registered: 2012-05-31
Posts: 3

Re: Troubles after installing Catalyst and re-installing KDE

Neither of these worked for me.

Offline

#4 2012-06-01 21:53:29

Pres
Member
Registered: 2011-09-12
Posts: 423

Re: Troubles after installing Catalyst and re-installing KDE

(EE) module ABI major version (16) doesn't match the server's version (13)

There's your problem. Are you using the xorg111 repo? If not, enable that and then pacman -Syuu.

As a warning, xorg-server 1.11 is now broken with the new udev package (at least until someone rebuilds it and updates the repo). You'll need to rebuild it manually to avoid this.

Last edited by Pres (2012-06-01 21:54:17)

Offline

#5 2012-06-01 21:57:47

Gusar
Member
Registered: 2009-08-25
Posts: 3,466

Re: Troubles after installing Catalyst and re-installing KDE

You're trying to use a synaptics driver built for xorg-server-1.12 with 1.11, that's one problem. I assume you're using the [xorg111] repository? That repository must have a xf86-input-synaptics package. If it doesn't, you'll need to compile it yourself.

The kwin issues, check it's settings, it's possible kwin is configured to use xrender instead of opengl. Many effects are not available in xrender mode, so switch to opengl mode.

Offline

#6 2012-06-01 22:59:31

maistora
Member
Registered: 2012-05-31
Posts: 3

Re: Troubles after installing Catalyst and re-installing KDE

Yes, I am using xorg111 repo.
This is very helpful. I will see what could I do tomorrow. Thank you Pres and Gusar.

Last edited by maistora (2012-06-01 23:33:38)

Offline

Board footer

Powered by FluxBB