You are not logged in.

#1 2012-06-02 19:17:28

Luminary
Member
Registered: 2012-02-15
Posts: 8

perl upgrade problems

Hi, I guess I recently updated my perl to 5.16. I guess it broke something, since I can't use IO::Socket::IP or IO::Socket::INET anymore. I always get this error.

Perl API version v5.14.0 of Socket does not match v5.16.0 at /usr/share/perl5/core_perl/XSLoader.pm line 92.
Compilation failed in require at /usr/lib/perl5/site_perl/IO/Socket.pm line 12.
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/IO/Socket.pm line 12.
Compilation failed in require at (eval 2) line 2.
	...propagated at /usr/share/perl5/core_perl/base.pm line 84.
BEGIN failed--compilation aborted at /usr/share/perl5/site_perl/IO/Socket/IP.pm line 10.
Compilation failed in require at test.pl line 4.

I've tried reinstalling perl, uninstalling then reinstalling it, and even deleting /usr/share/perl5/ and reinstalling, still the same problem no matter what I do. Any solutions?

Offline

#2 2012-06-02 19:19:55

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,092
Website

Re: perl upgrade problems

Just like every other perl upgrade -- you built/installed those things yourself, so you need to take care of them.

Offline

#3 2012-06-02 19:29:13

Luminary
Member
Registered: 2012-02-15
Posts: 8

Re: perl upgrade problems

falconindy wrote:

Just like every other perl upgrade -- you built/installed those things yourself, so you need to take care of them.

I've tried rebuilding them, is there something else I'm missing? I figured installing IO::Socket::IP with cpan would fix it, so I'm sorta at a dead end.

Thanks for the response.

EDIT: Sorry, I figured it out. Needed to rebuild "Socket". I figured cpan would rebuild the dependency since it upgraded.

Thanks!

Last edited by Luminary (2012-06-02 19:32:30)

Offline

#4 2012-06-02 20:00:58

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,304
Website

Re: perl upgrade problems

Please remember to mark your thread as [Solved] by editing your first post.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB