You are not logged in.

#1 2012-06-07 21:55:28

Registered: 2012-06-07
Posts: 15

[SOLVED]MonoDevelop 3.0.2 build failure

Hello everyone. I'm really sorry, if there are any mistakes in the text below: I am kind of a new to building from source, and my English is quite bad.

So, I've decided to make a MonoDevelop package for a new version: I didn't find it in AUR or testing repository.
People say, it's really better and featured then all the previous versions.

Log of my actions:

git clone git://
cd monodevelop
git submodule init
git submodule update

then made monodevelop.tar.gz

My PKGBUILD was copied from version: /var/abs/extra/monodevelop/PKGBUILD, with couple of changes(version, and a local .tar.gz as a source)

pkgdesc="An IDE primarily designed for C# and other .NET languages"
arch=('i686' 'x86_64')
depends=('mono>=2.10.5' 'mono-addins>=0.6.2' 'gnome-sharp')

build() {
  export MONO_SHARED_DIR=$srcdir/src/.wabi
  mkdir -p $MONO_SHARED_DIR

  cd $srcdir/$pkgname
  ./configure --prefix=/usr
  make || return 1

package() {
  cd $srcdir/$pkgname
  make DESTDIR=$pkgdir install


Maybe it's not like it should be: i'm doing it the first time now.
makepkg -g>>PKGBUILD worked fine.



/*trimmed lines*/

make[3]: Leaving directory `/home/jediknight/build/src/monodevelop/main/src/tools'
make[3]: Entering directory `/home/jediknight/build/src/monodevelop/main/src'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/home/jediknight/build/src/monodevelop/main/src'
make[2]: Leaving directory `/home/jediknight/build/src/monodevelop/main/src'
Making all in po
make[2]: Entering directory `/home/jediknight/build/src/monodevelop/main/po'
make[2]: ../build/locale/cs/LC_MESSAGES/: Command not found
make[2]: *** [../build/locale/cs/LC_MESSAGES/] Error 127
make[2]: Leaving directory `/home/jediknight/build/src/monodevelop/main/po'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/jediknight/build/src/monodevelop/main'
make: *** [all-recursive] Error 1

And this is how it finished.

It is not a problem of my bad PKGBUILD file: when this failed, I tried to install it with a common commands: configure --profile=stable --prefix=... && make && make run, and make failed again with the same message.

So, my question is:
1) What could possibly go wrong, according to the log?
2) What should I change somehow?
3) Maybe, someone has a compiled binary package for a MonoDevelop 3.0.2?

Last edited by JediKnight (2012-06-07 23:03:54)


#2 2012-06-07 22:15:02

Inspector Parrot
Registered: 2011-11-29
Posts: 19,307

Re: [SOLVED]MonoDevelop 3.0.2 build failure

JediKnight wrote:

I didn't find it in AUR

What search term did you use??  Here is monodevelop-git already in the AUR.

It seems it may have been abandonded, but perhaps you could take over that package rather than starting a new one.

Additionally, a patch is applied in that PKGBUILD.  Perhaps that could be needed to solve your problem.

"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman


#3 2012-06-07 22:44:49

Registered: 2012-06-07
Posts: 15

Re: [SOLVED]MonoDevelop 3.0.2 build failure

'monodevelop-git' name tells nothing about a version for me... Like I said - never had an experience with building from source before, and with git too, of course.

Anyways, thanks for advice. Trying to install...

UPD: Works perfectly, thank you! Included patch fixed that problem.

Last edited by JediKnight (2012-06-07 22:58:45)


Board footer

Powered by FluxBB