You are not logged in.

#1 2012-06-09 04:16:20

jim1960
Member
Registered: 2011-08-19
Posts: 24

Automount with pmount/udisks/udisks2..

When I plugin USB 3.0  external media(flash pen, HDD, Card Reader..) to USB 3.0 port, udisksvm can't mount it, dmesg show:
xhci_hcd 0000:05:00.0: WARN Successful completion on short TX: needs XHCI_TRUST_TX_LENGTH quirk?

but it can be mounted with thunar or plugin to USB 2.0 port then udisksvm will auto mounted .

It had no problem in linux-ck v3.3.x, so how to fix it?

Last edited by jim1960 (2012-06-22 14:20:16)


Sorry for my poor english.

Offline

#2 2012-06-14 04:17:56

jim1960
Member
Registered: 2011-08-19
Posts: 24

Re: Automount with pmount/udisks/udisks2..

udisks conflict udisks2?
I manual kill the process of udisks2, then udisksvm work fine with usb 2.0 & 3.0

In My system:
libgdu, traydevice, usb-creator, xfce4-power-manager NEED udisks
gnome-disk-utility, gvfs NEED udisks2

PS: I use .xinitrc to start icewm
(exec ck-launch-session dbus-launch --exit-with-session icewm-session)


Sorry for my poor english.

Offline

#3 2012-06-14 10:28:08

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,535
Website

Re: Automount with pmount/udisks/udisks2..

No idea about USB-3.0 but I would encourage you to remove the "linux-ck" from your topic since I am sure that you will experience the same problem with the linux package from [testing].  In other words, this is a 3.4.x issue not a 3.4.x-ck issue wink


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#4 2012-06-14 12:03:06

broken pipe
Member
Registered: 2010-12-10
Posts: 216

Re: Automount with pmount/udisks/udisks2..

i don't think it's related to linux-ck. 2 of my external drives are connected via usb 3.0 and i'm always on the latest CK kernel.
anything in the errors log? lsusb? dmesg? kernel log?

why don't you go with thunar + gvfs (+ polkit-gnome)

Offline

#5 2012-06-14 14:44:05

jim1960
Member
Registered: 2011-08-19
Posts: 24

Re: Automount with pmount/udisks/udisks2..

broken pipe wrote:

i don't think it's related to linux-ck. 2 of my external drives are connected via usb 3.0 and i'm always on the latest CK kernel.
anything in the errors log? lsusb? dmesg? kernel log?

why don't you go with thunar + gvfs (+ polkit-gnome)

I agree it is not related to kernel, the point is the post of #2 which udisks conflict with udisks2!
When I kill the process of udisks2 then udisksvm which use udisks just work fine!

But thunar with gvfs didn't show any external media while plug-in to usb 2.0 or 3.0 port.
error message:

thunar-volman: Unknown USB device type.
thunar-volman: Could not detect the volume corresponding to the device.


Sorry for my poor english.

Offline

#6 2012-06-14 17:04:52

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,535
Website

Re: Automount with pmount/udisks/udisks2..

jim1960 wrote:

I agree it is not related to kernel, the point is the post of #2 which udisks conflict with udisks2!

Can you edit the original post's title to make this clear?


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#7 2012-06-22 14:39:28

jim1960
Member
Registered: 2011-08-19
Posts: 24

Re: Automount with pmount/udisks/udisks2..

graysky wrote:
jim1960 wrote:

I agree it is not related to kernel, the point is the post of #2 which udisks conflict with udisks2!

Can you edit the original post's title to make this clear?

Sorry for delay and my english (I don't speak english)

While remove pmount package then devmon do the automount, but udisksvm still didn't work.

Sometime udisks mount first than udisks2, sometime reverse...


Sorry for my poor english.

Offline

Board footer

Powered by FluxBB