You are not logged in.

#1 2012-06-09 19:30:47

varsovie
Member
Registered: 2006-12-24
Posts: 14

[SOLVED] Pacman -Syu => login incorrect

After 2 years finally i did  pacman -Syu due more & more programs wanted newer kernel etc.

After full install first problem - Unable to login.
After type login name immedietly i got 4 times - Login Incorrect sad
I found the reason is missing lib dependency. PAM it looking it in /lib/security instead of real package /usr/lib/security so i quickly fixed it with symlink.
The next problem in pacman -Syu there was no syslog-ng so had to update it manually to see any error logs.

The problem i still have is that after login when password is correct i'm immediately logged out sad
in /var/log/auth.d i have only then: session opened, module UNKNOWN and logout sad
I have still problem with /lib/security/pam_env.so LIBPAM_1.1.3 not found required by pam_mail.so

I love everytime pacman -Syu wink

Last edited by varsovie (2012-06-09 20:45:20)

Offline

#2 2012-06-09 20:02:42

Terminator
Member
From: Belgium
Registered: 2012-05-07
Posts: 265

Re: [SOLVED] Pacman -Syu => login incorrect

lol

After you fixed it or reinstalled, you might want to run 'pacman -Syu' more often. It tends to be less painfull when done regularly.

Offline

#3 2012-06-09 20:18:40

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,700
Website

Re: [SOLVED] Pacman -Syu => login incorrect

WHOA!

Sorry I can't really help with the issue at hand, but I'm curious why you would even want to use a rolling release if you only update every couple years?  Release based distro's would be more up to date than your system most of the time.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#4 2012-06-09 20:45:00

varsovie
Member
Registered: 2006-12-24
Posts: 14

Re: [SOLVED] Pacman -Syu => login incorrect

SOLVED smile

The problem is that current latest:
pam-1.1.5-3-i686.pkg.tar.xz
Doesn't contain /lib/libpam***
So i fixed it by get necessary files /lib/libpam*** from pam-1.1.3 then update 1.1.5 smile

And little log dump for people to easier find this topic in future.

2012-06-09T20:44:14+02:00 r39 sshd[1256]: PAM unable to dlopen(/lib/security/pam_env.so): /lib/libpam.so.0: version `LIBPAM_MODUTIL_1.1.3' not found (required by /lib/security/pam_env.so)
2012-06-09T20:44:14+02:00 r39 sshd[1256]: PAM adding faulty module: /lib/security/pam_env.so
2012-06-09T20:44:17+02:00 r39 sshd[1256]: Failed password for root from 192.168.1.105 port 5806 ssh2
....
Jun  9 21:33:35 r39 login[1140]: PAM unable to dlopen(/lib/security/pam_mail.so): /lib/security/pam_mail.so: file too short
Jun  9 21:33:35 r39 login[1140]: PAM adding faulty module: /lib/security/pam_mail.so
...
Jun  9 21:34:13 r39 login[1154]: PAM adding faulty module: /lib/security/pam_lastlog.so
Jun  9 21:34:16 r39 login[1154]: FAILED LOGIN (1) on '/dev/tty1' FOR 'root', Module is unknown
Jun  9 21:34:19 r39 login[1154]: FAILED LOGIN (2) on '/dev/tty1' FOR 'UNKNOWN', Module is unknown
Jun  9 21:34:22 r39 login[1154]: FAILED LOGIN (3) on '/dev/tty1' FOR 'UNKNOWN', Module is unknown
Jun  9 21:34:24 r39 sshd[329]: Received signal 15; terminating.

Last edited by varsovie (2012-06-09 20:47:06)

Offline

#5 2012-06-09 20:53:22

varsovie
Member
Registered: 2006-12-24
Posts: 14

Re: [SOLVED] Pacman -Syu => login incorrect

Trilby wrote:

WHOA!
Sorry I can't really help with the issue at hand, but I'm curious why you would even want to use a rolling release if you only update every couple years?  Release based distro's would be more up to date than your system most of the time.

I have many servers. Most of them mission critical production with Slackware ~4/6 working on i486 from years. About 4 years ago i began use Archlinux due is better than Slack for high-end solutions like my old RFID PHP Archlinux solution smile

default.jpg
http://www.youtube.com/watch?v=MdWjnAj-0v8

Offline

#6 2012-06-09 21:13:20

masteryod
Member
Registered: 2010-05-19
Posts: 433

Re: [SOLVED] Pacman -Syu => login incorrect

varsovie wrote:

After 2 years finally i did  pacman -Syu due more & more programs wanted newer kernel etc.[...]

How to say this... if you can't/don't want to maintain your system on daily/weekly basis you probably shouldn't use Arch, two years on any OS without any update is very bad idea, on Linux where things change very rapidly two years is hell of a lot! Either way read about rolling-release distribution (Arch) and what it is and what's not or go with more conservative distribution like Debian. But no matter what you choose no updates for two years is just awful idea.

[edit]

varsovie wrote:

I have many servers. Most of them mission critical production with Slackware ~4/6 working on i486 from years. About 4 years ago i began use Archlinux due is better than Slack for high-end solutions like my old RFID PHP Archlinux solution

OK no offense but if this "servers" are connected to the internet and you don't update them for years, this is just ridiculous.

Last edited by masteryod (2012-06-09 21:14:07)

Offline

#7 2012-06-09 23:31:53

varsovie
Member
Registered: 2006-12-24
Posts: 14

Re: [SOLVED] Pacman -Syu => login incorrect

masteryod wrote:

...

MasterYoda,

The Rolling-release conecpt in Archlinux doesn't work well for production server due many unforeseen broken dependencies sad
When You have fleet of over hundreds machines without direct human-access You can not risk untrusted pacman update every ~week.

In data centers it's not problem due i can still manage rollback with AMT. For onsite machines there is only one TCP port enabled for dedicated application ... so i don't have to worry about any security issue. It's more like QNX with removed most things wink I fully understand for You it can be just ridiculous, but please count how many hours You spend in last years to tweak config due pacman changes .... in industry we have machines with over 10 years uptime with 0 hours maintenance due it does only one embedded function.

The only reason for update in mission critical is feature implementation where ex. USB LTE driver needs newer kernel so we try first tweak sample O/S image (like here) before deploy newer hardware revision.

Offline

#8 2012-06-10 00:35:11

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,570
Website

Re: [SOLVED] Pacman -Syu => login incorrect

varsovie wrote:

The only reason for update in mission critical is feature implementation where ex. USB LTE driver needs newer kernel so we try first tweak sample O/S image (like here) before deploy newer hardware revision.

Or, presumably, security fixes...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#9 2012-06-10 11:56:18

masteryod
Member
Registered: 2010-05-19
Posts: 433

Re: [SOLVED] Pacman -Syu => login incorrect

varsovie wrote:

The Rolling-release conecpt in Archlinux doesn't work well for production server due many unforeseen broken dependencies sad
When You have fleet of over hundreds machines without direct human-access You can not risk untrusted pacman update every ~week.[...]

The only reason for update in mission critical is feature implementation where ex. USB LTE driver needs newer kernel so we try first tweak sample O/S image (like here) before deploy newer hardware revision.

Yeah that's exactly my point, why don't you go with distro that are more conservative like Debian Stable (support for ~3years) or CentOS/RedHat (10years support)? Aren't they more suitable for this kind of computer usage? System breakage by update risk is approaching zero and still you'll receive security updates/bugfixes. Or am I missing something here?

Offline

#10 2012-06-10 18:01:45

varsovie
Member
Registered: 2006-12-24
Posts: 14

Re: [SOLVED] Pacman -Syu => login incorrect

Master Yoda,
Redhat was denied due corporate top dog decision. So faced choice huge Ubuntu or Arch the answer was easy smile
So Arch won cool industry implantation like hydro plants in deep forests in Brasil and Africa smile
We have own CPU line like EVA-X5800 and not all x86 binaries run as desired without source code tweak wink
http://www.advantech.com/products/EVA-X … 957DF.aspx

Offline

Board footer

Powered by FluxBB