You are not logged in.

#1 2012-06-16 21:11:45

bart_b
Member
Registered: 2012-06-16
Posts: 20

[Solved] local_softirq_pending???

From kernel version 3.4.2-2 I get a boot msg like : "NOHZ local_softirq_pending 08" after network start

It causes no problems so far but this message irritates me immensely why print non fatal messages to the screen anyway

This has something to do with my Realtek NIC r8169 (driver=r8169 driverversion=2.3LK-NAPI) and this kernel version
And it seems that there were already some unresolved issues on this topic, see https://bbs.archlinux.org/viewtopic.php?id=115644  in 2011-03-24

How to get rid of these messages?

Last edited by bart_b (2012-06-20 22:30:53)

Offline

#2 2012-06-17 01:10:28

ignorant
Member
Registered: 2012-06-09
Posts: 50

Re: [Solved] local_softirq_pending???

Same problem, and it only just started happening with the 3.4 kernel. I haven't noticed any negative side effects aside from the weird messages on boot. (edit: I could be wrong, I downgraded my kernel after a day because I wanted my machine to be reliable beyond a doubt, even though I hadn't noticed any other problems).

$ lspci | grep -i realtek
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5289 (rev 01)
03:00.2 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 0a)

$ lsmod | grep r8169
r8169                  48740  0 
mii                     4091  1 r8169

Has anyone noticed any other problems from this?

Last edited by ignorant (2012-06-17 01:23:03)

Offline

#3 2012-06-17 08:30:10

bart_b
Member
Registered: 2012-06-16
Posts: 20

Re: [Solved] local_softirq_pending???

Found this thread in LKML https://lkml.org/lkml/2012/5/30/498 it seems a problem returning from 2007.
In my kernel.log

... r8169 0000:02:00.0: eth0: link down
... r8169 0000:02:00.0: eth0: link down
... NOHZ: local_softirq_pending 08
... ADDRCONF(NETDEV_UP): eth0: link is not ready
... r8169 0000:02:00.0: eth0: link up
... ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

It stops after I get an ip-address from the dhcp-server and this is a replication of the problem in the 2.6 release in 2007 and looks like a kind of early warning for a problem that will not exist in the near future (dhcp racy condition).
The next kernel release gets a patch for this according to the mailinglist, hope it gets solved soon.

Offline

#4 2012-06-17 20:41:35

ignorant
Member
Registered: 2012-06-09
Posts: 50

Re: [Solved] local_softirq_pending???

That's a relief. Read all the way through that thread. Good job finding it.

Offline

#5 2012-06-17 21:19:53

bart_b
Member
Registered: 2012-06-16
Posts: 20

Re: [Solved] local_softirq_pending???

Now we wait, untill the next kernel update...

Offline

#6 2012-06-20 09:00:51

CyrIng
Member
From: France
Registered: 2010-07-17
Posts: 78
Website

Re: [Solved] local_softirq_pending???

Same issue here starting with kernel 3.4.x using the following hardware : Rampage II Gene + Core i7-920 @ 3210 MHz + 3x2 GB Corsair + 3x2GB OCZ

[    5.494768] r8169 0000:06:00.0: eth0: link down
[    5.494775] device eth0 entered promiscuous mode
[    5.494780] r8169 0000:06:00.0: eth0: link down
[    5.494783] NOHZ: local_softirq_pending 08
[    5.494819] NOHZ: local_softirq_pending 08
[    5.495131] NOHZ: local_softirq_pending 08
[    5.496095] ADDRCONF(NETDEV_UP): eth0: link is not ready
[    5.501714] ADDRCONF(NETDEV_UP): br0: link is not ready
[    5.847642] ip_tables: (C) 2000-2006 Netfilter Core Team
[    5.875874] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
[    5.892283] ADDRCONF(NETDEV_UP): virbr0: link is not ready
[    6.366049] ip6_tables: (C) 2000-2006 Netfilter Core Team
[    8.559109] r8169 0000:06:00.0: eth0: link up
[    8.560244] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

Offline

#7 2012-06-20 09:42:17

bart_b
Member
Registered: 2012-06-16
Posts: 20

Re: [Solved] local_softirq_pending???

Found a solution, it seems that the new kernels are compiled with "Accelerate last non-dyntick-idle CPU's grace periods (RCU_FAST_NO_HZ)" option: Yes

explanation from the Linux kernel source:

This option causes RCU to attempt to accelerate grace periods
in order to allow CPUs to enter dynticks-idle state more
quickly. On the other hand, this option increases the overhead
of the dynticks-idle checking, particularly on systems with
large numbers of CPUs.

If you add

nohz=off

to the kernel line in grub the "NOHZ local_softirq_pending"  messages don't show up

Last edited by bart_b (2012-06-20 09:44:12)

Offline

#8 2012-06-20 22:24:46

bart_b
Member
Registered: 2012-06-16
Posts: 20

Re: [Solved] local_softirq_pending???

Today I build the 3.5-rc3 kernel and i'm relieved to say that in the upcoming release the problem looks to be solved.

Offline

#9 2012-06-23 17:27:57

ignorant
Member
Registered: 2012-06-09
Posts: 50

Re: [Solved] local_softirq_pending???

bart_b wrote:

Today I build the 3.5-rc3 kernel and i'm relieved to say that in the upcoming release the problem looks to be solved.

Very cool. I didn't mind it too much though, I haven't notice any other problems from this.

Offline

#10 2012-07-25 09:32:05

Ypnose
Member
From: Jailed in the shell
Registered: 2011-04-21
Posts: 353
Website

Re: [Solved] local_softirq_pending???

Hi,
Ten minutes ago, I had exactly the same issue with a ASUS M4A89GTD PRO + Phenom II X4 955 BE on 3.4.6 kernel.

Here the logs:

Jul 25 11:14:14 localhost kernel: [   11.116459] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
Jul 25 11:14:15 localhost kernel: [   11.854794] r8169 0000:04:00.0: eth0: link down
Jul 25 11:14:15 localhost kernel: [   11.854818] r8169 0000:04:00.0: eth0: link down
Jul 25 11:14:15 localhost kernel: [   11.854844] NOHZ: local_softirq_pending 08
Jul 25 11:14:15 localhost kernel: [   11.854989] NOHZ: local_softirq_pending 08
Jul 25 11:14:15 localhost kernel: [   11.855136] NOHZ: local_softirq_pending 08
Jul 25 11:14:15 localhost kernel: [   11.855280] NOHZ: local_softirq_pending 08
Jul 25 11:14:15 localhost kernel: [   11.855432] NOHZ: local_softirq_pending 08
Jul 25 11:14:15 localhost kernel: [   11.855587] NOHZ: local_softirq_pending 08
Jul 25 11:14:15 localhost kernel: [   11.855731] NOHZ: local_softirq_pending 08
Jul 25 11:14:15 localhost kernel: [   11.855881] NOHZ: local_softirq_pending 08
Jul 25 11:14:15 localhost kernel: [   11.857203] NOHZ: local_softirq_pending 08
Jul 25 11:14:17 localhost kernel: [   13.424616] r8169 0000:04:00.0: eth0: link up

The problem is the same as said here: https://bugzilla.kernel.org/show_bug.cgi?id=32962

lspci:

04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)

Github -- My terminal font Envypn

Offline

#11 2012-07-25 13:33:44

bart_b
Member
Registered: 2012-06-16
Posts: 20

Re: [Solved] local_softirq_pending???

@Ypnose
Since a couple of weeks I run the 3.5.rcX and now the 3.5.0 mainline with no issues. It also gave me the opportunity to optimize this kernel to my machine specs.
The fulldiff for r8168 can be found here http://git.kernel.org/?p=linux/kernel/g … 60ef59bfaa and substantial change has been made. Also the bufferbloat problem had attention by the introduction of CoDel, Controlled Delay Management this is a huge improvement from my POV.

Offline

Board footer

Powered by FluxBB